Post Reply 

wrong import bitmaps with gimp 2.8.10 (Fedora 20)

Apr 8, 2014, 12:33
Post: #1
wrong import bitmaps with gimp 2.8.10 (Fedora 20)
Hi all,

I recently upgraded to F20. When I load a bitmap (PNG or JPG) with
Gimp 2.8.10. the figure colors looks bad. If I inspect the color channel it
seems that the green channel is empty (null). I tried with the same
figure in Gimp 2.6 (Fedora 14) and it looks right. (I don't have right
now a way to try in a newer system (let's say F19).)

I thought that perhaps it was some bad configuration of my user. I
tried a new "fresh" user, and it happens the same.

Any ideas?

Regards, Mario

This is the actual image:
   

This is the file imported in Gimp
   

This is the green channel
   

This is the blue channel:
   

Any ideas?

TIA, Mario
Find all posts by this user
Quote this message in a reply
Apr 8, 2014, 15:18 (This post was last modified: Apr 8, 2014 15:20 by mario.storti.)
Post: #2
RE: wrong import bitmaps with gimp 2.8.10 (Fedora 20)
(Apr 8, 2014 13:25)ofnuts Wrote:  Your green channel is OK in the preview. Looks like you have a strange screen color profile. What happens when you got to Edit/Preferences -> Color management and change "Color managed display" to "No color management"? You can also untick the "Try to use the system monitor profile" if it is checked.

One last question. If you save a copy of the picture again and look at it with another picture browser, is the green channel completely gone or is it still there?

YES, THANK YOU, the problem was solved with both of your recommendations:

1) If I set "No color management" -> I see the picture right.

2 ) If I leave "Color managed display" but untick the "Try to use the
system monitor profile" -> I see the picture right.

So, it seems that Gimp detects wrong the monitor? I have a
notebook SAMSUNG NP300E4 CI5 2450 4G 1TB. The monitor, as shown by
the KDE display manager is "AU Optronics LVDS1".

Regards, Mario
Find all posts by this user
Quote this message in a reply
Apr 8, 2014, 17:36
Post: #3
RE: wrong import bitmaps with gimp 2.8.10 (Fedora 20)
(Apr 8, 2014 16:06)ofnuts Wrote:  Gimp doesn't detect the monitor, it uses a system profile created by the system. So you have to figure out where that file is and why it was created that way.

I see. I have the following in in /etc/gimp/2.0/gimprc. (I checked
that this file is exactly the same as the file in the RPM Fedora
package).

Code:
(color-management
#     (mode display)
      (display-profile-from-gdk yes)
#     (display-rendering-intent perceptual)
#     (simulation-rendering-intent perceptual)
#     (simulation-gamut-check no)
#     (out-of-gamut-color (color-rgb 0.501961 0.501961 0.501961))
#     (display-module "CdisplayLcms")
)

but in the Gimp tarball from http://www.gimp.org/downloads/ it says

Code:
# (color-management
#     (mode display)
#     (display-profile-from-gdk no)
#     (display-rendering-intent perceptual)
#     (simulation-rendering-intent perceptual)
#     (simulation-gamut-check no)
#     (out-of-gamut-color (color-rgb 0.501961 0.501961 0.501961))
#     (display-module "CdisplayLcms"))

So it seems that in the gimprc file for Fedora the option
display-profile-from-gdk has been deliberately set to yes. Is it
possible that the Fedora packagers by mistake have modified this file?
Should I contact them for reporting this issue?

You solved already my problem. I just want to report the problem (if
any) that may affect other users.
Find all posts by this user
Quote this message in a reply
Apr 8, 2014, 20:44
Post: #4
RE: wrong import bitmaps with gimp 2.8.10 (Fedora 20)
(Apr 8, 2014 18:55)ofnuts Wrote:  The problem isn't that Gimp is used a monitor profile (which is nice), but that the monitor profile is totally botched.

Many default Gimp options are meant to make Gimp run adequately on small machines, but today's small machines are 2009's power monsters so some of these defaults are no longer relevant.

OK, I will write to the Fedora Gimp maintainer just to let him know of the problem. Regards, and again THANKS for your help.
Find all posts by this user
Quote this message in a reply
Apr 8, 2014, 21:32
Post: #5
RE: wrong import bitmaps with gimp 2.8.10 (Fedora 20)
Bug submitted at Fedora Bugzilla

https://bugzilla.redhat.com/show_bug.cgi?id=1085544
Find all posts by this user
Quote this message in a reply
Apr 9, 2014, 00:10
Post: #6
RE: wrong import bitmaps with gimp 2.8.10 (Fedora 20)
(Apr 8, 2014 22:49)ofnuts Wrote:  The bug report isn't going to fly... the bug isn't with Gimp but with the monitor profile creation.

Well, in that case I don't know what else to do. I read some here

https://en.wikipedia.org/wiki/Linux_color_management

but it's beyond my understandings. Perhaps its not important. I leave
this in the hands of the Fedora Package Maintainer.
Find all posts by this user
Quote this message in a reply
Apr 9, 2014, 11:11
Post: #7
RE: wrong import bitmaps with gimp 2.8.10 (Fedora 20)
(Apr 9, 2014 06:42)ofnuts Wrote:  The thing to do is to report the bug, but as a bug in the monitor profile, which requires a title different from "Gimp import bitmaps wrong" (1) it's not Gimp, 2) its not specific to bitmaps, and 3) bitmaps are imported OK, the problem is in the display).

To impove the big report, you can see of other apps that use color management (possible candidates: DarkTable, Digikam, GPhoto, Gwenview...), have the same problem.

And find your monitor profile and attach it to the bug report.

You are right! DigiKam also has the problem but Gwenview not. DigiKam
uses LittleCMS (package package lcms2-2.6-1.fc20.x86_64). I don't know
if Gimp uses thes same. I will search more for the place where to
report the bug. Regards, Mario
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  How to change the weight of a font in gimp? adrianh 3 344 Oct 4, 2018 16:40
Last Post: paynekj
  Gradient Tool in GIMP 2.10 mrg4541 1 309 Oct 1, 2018 21:18
Last Post: paynekj
  GIMP on Windows 10 what gives? piginhat 1 419 Sep 27, 2018 13:11
Last Post: paynekj
  GIMP 2.10.6 not responding HBS 1 269 Sep 24, 2018 08:49
Last Post: paynekj
  Gimp Latest Build has me a little puzzled kmk55 1 281 Sep 14, 2018 08:40
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS