Post Reply 

Won't start without sudo

May 16, 2011, 08:16
Post: #1
Won't start without sudo
Suddenly, gimp won't start unless I call it from the command line using sudo.

So far, I've done this:

Synaptic>completely remove gimp and gimp-data
deleted gimp2.6 folder from /home/user/
reinstall

Sudo apt-get remove --purge gimp gimp-data
sudo apt-get autoremove
sudo apt-get install gimp gimp-data

After the second install, looked for gimp folder in user directory to double check file and folder permissions...it wasn't there.

This was working wonderfully yesterday. Any ideas?
Find all posts by this user
Quote this message in a reply
May 16, 2011, 10:10
Post: #2
RE: Won't start without sudo
~/gimp-2.6 will be created when you run Gimp.

I suspect some rights changed on some core component under /usr

How far does it run when you use gimp --verbose?

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
May 19, 2011, 12:38
Post: #3
RE: Won't start without sudo
Hey, thanks for replying. It auto-magically started working again. I went into all of gimps install locations and changed ownership from root to me. I'm not sure how I installed it as root only...

Any way, thanks for the help. Now to search for compatible vector formats for gimp and inkscape interoperability...

Over and out.
Find all posts by this user
Quote this message in a reply
May 19, 2011, 17:21
Post: #4
RE: Won't start without sudo
(May 19, 2011 12:38)peragrate Wrote:  Hey, thanks for replying. It auto-magically started working again. I went into all of gimps install locations and changed ownership from root to me. I'm not sure how I installed it as root only...

Any way, thanks for the help. Now to search for compatible vector formats for gimp and inkscape interoperability...

Over and out.
Changing ownership is a bit extreme... insuring 755 rights should have been enough.

Both Gimp and InkScape can import/export SVG.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  GIMP Taking Too Long to Start (Fonts) Seta 2 341 Jun 20, 2017 16:10
Last Post: Seta
  GIMP freezing on start up FluffyMuffins230 12 842 Sep 17, 2014 20:39
Last Post: FluffyMuffins230
Sad Start up error/Gimp keeps closing ms. shelley 1 383 Jul 3, 2014 17:35
Last Post: ms. shelley
  Gimp will not Start Podoowski 19 4,376 Jun 17, 2014 19:22
Last Post: rich2005
  Start without layers when creating a new image? puggsoy 5 406 Jun 16, 2014 12:01
Last Post: puggsoy

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS