Post Reply 

Windows and Set Up

Dec 12, 2013, 22:43
Post: #1
Windows and Set Up
I just downloaded the latest version of Gimp (2.8). I can't seem to find any way to set up the windows the way I could before.

I want my windows (toolbox, layers, project, etc) to all be separate windows. I don't want the toolbox or anything to be onto of the main project window either. I want all of the windows to be big (like the same size as the project window) with the shrink window and full window keys (the two buttons next to the red X in the top right hand corner).

Can anyone help? Where is this setting now? This is so frustrating!

[Image: ven8ys.jpg]
Visit this user's website Find all posts by this user
Quote this message in a reply
Dec 13, 2013, 07:03 (This post was last modified: Dec 13, 2013 07:04 by Softly.)
Post: #2
RE: Windows and Set Up
(Dec 12, 2013 23:03)ofnuts Wrote:  "Windows/Single window mode" -> and uncheck

If you have a backup of the "sessionrc" file from your Gimp 2.6 profile, you can try to copy it over to the Gimp 2.8 profile.


Where is this "Windows/Single window mode"? I don't see that anywhere.

[Image: ven8ys.jpg]
Visit this user's website Find all posts by this user
Quote this message in a reply
Dec 13, 2013, 10:16 (This post was last modified: Jan 26, 2014 13:19 by rich2005.)
Post: #3
RE: Windows and Set Up
Quote:...I can't seem to find any way to set up the windows the way I could before.
I want my windows (toolbox, layers, project, etc) to all be separate windows. I don't want the toolbox or anything to be onto of the main project window either. I want all of the windows to be big (like the same size as the project window) with the shrink window and full window keys (the two buttons next to the red X in the top right hand corner)...

Hmm.. a 'red X' - got to be windows 8 - 'all the windows big' - suggests a dual monitor setup. Probably wrong on both counts.

The previous posts tell you how to get out of single window mode.

This video demonstrates splitting the dialogs up in Windows 8.1 and Gimp 2.8.10. Alas it is a virtual machine and a bit limited on screen area.

having a tidy up - everyone finished with this ...going..going..gone
http://www.youtube.com/watch?v=dcAMTGLmJR4&hd=1 six minutes

First half is multi window mode, second half suggests keeping single window mode for one of the advantages - tabbed images.

There should be enough hints and clues in there to get you started.


Edit: If after all that, or because of all that Wink the Gimp windows are totally screwed up
then
Edit menu -> preferences -> Windows Management -> click on 'Reset Saved Windows Positions to Default Values'
restart Gimp, gets you back to the old 3 window mode.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Dec 14, 2013, 05:00
Post: #4
RE: Windows and Set Up
(Dec 13, 2013 07:51)ofnuts Wrote:  
(Dec 13, 2013 07:03)Softly Wrote:  Where is this "Windows/Single window mode"? I don't see that anywhere.

Oh! No. This is the exact OPPOSITE of what I want... But thank you.

[Image: ven8ys.jpg]
Visit this user's website Find all posts by this user
Quote this message in a reply
Dec 14, 2013, 05:03
Post: #5
RE: Windows and Set Up
(Dec 13, 2013 10:16)rich2005 Wrote:  
Quote:...I can't seem to find any way to set up the windows the way I could before.
I want my windows (toolbox, layers, project, etc) to all be separate windows. I don't want the toolbox or anything to be onto of the main project window either. I want all of the windows to be big (like the same size as the project window) with the shrink window and full window keys (the two buttons next to the red X in the top right hand corner)...

Hmm.. a 'red X' - got to be windows 8 - 'all the windows big' - suggests a dual monitor setup. Probably wrong on both counts.

The previous posts tell you how to get out of single window mode.

This video demonstrates splitting the dialogs up in Windows 8.1 and Gimp 2.8.10. Alas it is ...


This doesn't help either. And resetting the window set up puts me exactly where I am now. Which isn't what I want. And the red x is in ALL versions of Windows. Not just 8. Also, it's not a dual monitor. It's like when you have multiple windows of anything open.

[Image: ven8ys.jpg]
Visit this user's website Find all posts by this user
Quote this message in a reply
Dec 14, 2013, 06:34
Post: #6
RE: Windows and Set Up
Windows vista up to 8 are similar in system theme settings.

I don't believe you've told us exactly which win OS you have.

First, in gimp to get the separate windows, you need to click off the "Single-window" mode.

If you mean the - [_] X buttons, gimp has its own graphics interface.

But in xp I know, you can choose the classic theme and get the minimize maximise, close buttons.

You can though, drag the windows to the bottom or a little off screen if you want it out of your way.

Try using the basic theme if you're using a modern windows OS.
or checking the visual settings:
Right-click my computer, properties. You should see "Advanced system settings"

Under performance, click "settings..."
Then you should have something like "disable visual themes" under the "Visual Effects"
Tab. Win 8, afaik, doesn't have it, but vista & 7 might. XP has it.

Get back on us on what OS version your using and I can research it, as of now we're all shooting in the dark(kinda...)
Visit this user's website Find all posts by this user
Quote this message in a reply
Dec 14, 2013, 09:13
Post: #7
RE: Windows and Set Up
@Softly
You are correct the close button is red in windoze, shows how much I use M$. Please realise that the more information you give the quicker you might get a correct answer.

So, reading between the lines again. Is this what you want.

screenshot in win7 http://i.imgur.com/NghwI58.jpg

Edit -> Preferences -> Window Management -> Hint for docks and toolbox -> set to 'Normal window'

This will enable a minimise, maximise, close buttons on all the docks.

Then it is as the video to break off the tools and docks into individual windows.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Dec 16, 2013, 05:08
Post: #8
RE: Windows and Set Up
(Dec 14, 2013 09:13)rich2005 Wrote:  @Softly
.
Edit -> Preferences -> Window Management -> Hint for docks and toolbox -> set to 'Normal window'
.
This will enable a minimise, maximise, close buttons on all the docks.

Then after you change it, be sure to restart gimp (close, reopen) and the changes will appear. Thanks Rich! I also have this problem/no fixed Smile
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Gimp 2.8.22 in Windows 10: Filename issue Mona Eberhardt 3 366 Jan 28, 2018 21:16
Last Post: ythgilb
  Utility Windows Aren't Closing FantWriter 1 306 Nov 9, 2017 05:20
Last Post: paynekj
  Abysmal performance on 2.8.14/Windows Volrath 3 475 Oct 5, 2014 10:04
Last Post: Volrath
  Missing icons v2.8.14 on Windows reyahtbor 3 687 Sep 1, 2014 07:35
Last Post: rich2005
  Gimp not working on windows 8.1 Justmenow 6 1,182 Aug 4, 2014 12:51
Last Post: Justmenow

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS