Post Reply 

What the fix for fonts not using bold?

Nov 11, 2013, 18:56
Post: #1
What the fix for fonts not using bold?
So, GIMP is not actually letting fonts use bold or italics. It's been reported, it's on bugzilla, and I figured it would get fixed.
And 2.8.8 came out and it is still not fixed.

This is killing my productivity here; I make comics and I need this ability.

When I read through the case notes on bugzilla someone there talks about a fix that can be made with some small edit of some config file or something, but honestly, I can't follow it. I don't understand what he is talking about. Can someone please explain to me how I can fix my GIMP?

Windows 7, 64-bit
Find all posts by this user
Quote this message in a reply
Nov 11, 2013, 23:20
Post: #2
RE: What the fix for fonts not using bold?
Bug 708110
https://bugzilla.gnome.org/show_bug.cgi?id=708110
Find all posts by this user
Quote this message in a reply
Nov 12, 2013, 05:54 (This post was last modified: Nov 12, 2013 05:57 by iForStyle007.)
Post: #3
RE: What the fix for fonts not using bold?
Hmm...strange your having this bug,
what font specifically that came with gimp?
I'd like to test it, maybe you can use an alternate gimp-default that works with bold and/or italic settings.

Did you try to bold it using both the toolbox setting and the above popup toolbar on top of the text box?
Also try enabling the classic text editor "[]use editor" under the Text Tool Options and try to bold/italicize it there too.

Since you make comics, my results with Sans & Comic sans (*omitting comic sans bold fonts)
I'm running gimp 2.8.6 on windows 8

[Image: attachment.php?aid=2667]
I've seen a similar issue on this forum.


Attached File(s) Thumbnail(s)
   

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Nov 12, 2013, 11:11 (This post was last modified: Nov 12, 2013 11:16 by rich2005.)
Post: #4
RE: What the fix for fonts not using bold?
I remember the post on the same subject a few weeks ago.
Revisiting the bug report, the only addition I could see was that it is still not fixed in Gimp 2.8.8
That seems to be the case, tried standard 32 and 64 bit Win7 installs and bold/italic still not working for the test font 'augie'
Hoped that parthas 64 bit might be better, not the case.

This one works,
http://www.gimpchat.com/viewtopic.php?f=7&t=8952
Samj is somewhat critical of current Gimp windows compilations.

Snags
It is a portable, it is 32 bit, but a quick trial and it works (so far) in a Win7 64 bit VM.
The archive is 7-zipped so you will need an unpacker 7zip or maybe peazip (careful with this for advertising, get the portable version)
No installer, so you have to do it yourself. I put it in 'Program Files(x86)' but it might be better straight under C:\
[Image: yny6qe9.jpg]

It still uses your regular .\gimp-2.8 profile so put your extra fonts there
[Image: 7hAdYBo.jpg]

And a quick test,
Top line has the CD bold and FG italic. As you can see this is taken from a development version 2.8.9, hopefully this bug will be fixed for windows users (no problem in linux) in 2.8.10
[Image: qRpLEEN.jpg]

Hope this helps.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Nov 13, 2013, 11:17
Post: #5
RE: What the fix for fonts not using bold?
(Nov 11, 2013 18:56)Marscaleb Wrote:  So, GIMP is not actually letting fonts use bold or italics. It's been reported, it's on bugzilla...
When I read through the case notes on bugzilla someone there talks about a fix that can be made with some small edit of some config file or something... how I can fix my GIMP?
Windows 7, 64-bit

Revisited the bug report and digging a bit deeper into the fix

This should work but no guarantees.

The attached zip (fontconfig.zip) contains 2 folders; fonts and fontconfig

Unzip to somewhere convenient (I used the desktop) then in
C:\Program Files\GIMP 2\etc\
back up the existing fonts folder (suggest fonts_bak) and copy/move the new folder in.

The fontconfig folder goes in
C:\Program Files\GIMP 2\share\
where there is no existing folder of that name.

A demo of the above http://www.youtube.com/watch?v=-17vfl_z0p4&hd=1 two and a half mins.


Attached File(s)
.zip  fontconfig.zip (Size: 34.35 KB / Downloads: 55)

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Nov 15, 2013, 06:19 (This post was last modified: Nov 15, 2013 06:19 by Marscaleb.)
Post: #6
RE: What the fix for fonts not using bold?
Hey alright, that did it! It's working! Thank you.

However, while it's not exactly a major problem, I've noticed that the letter spacing is not identical to what it was before.

Here's a sample image.
http://img194.imageshack.us/img194/2316/f5g4.png
In it, we see a piece of text that I made before updating to 2.8.6. Gimp saved the raster of the text, so if I don't adjust the text in anyway, it stays exactly how it looked in 2.8.4. (This is how it worked prior to trying the fix as well.)
In the red box you can see the same text after I have tried to edit it. Prior to applying the fix the bold and italic effect would completely disappear. But now the text gets recalculated and it doesn't take up quite the same amount of space.
I compared the actual pixel size, and it is the same size, but the letter spacing is smaller.

This isn't actually a problem, but I thought it was odd, and so I wanted to mention it.

...

When I first saw the change happen, I thought the bold effect was smaller than it was before. This got me thinking that I'd like to be able to adjust how strong the bold and italic effects are. Usually I've wanted the bold or italics on a word to be more noticeable. I mean, I'm trying to draw attention to it, so I want a bold effect that's stronger. The only other option is to increase the text size, but this requires making a separate text layer and then lining the two up.

I want to put in a feature request that GIMP would let me manually adjust the bold and italic strength in any text item. (As well as the text size of a selection within a text item.) How would I go about doing this?
Find all posts by this user
Quote this message in a reply
Nov 15, 2013, 08:48 (This post was last modified: Nov 15, 2013 09:25 by rich2005.)
Post: #7
RE: What the fix for fonts not using bold?
(Nov 15, 2013 06:19)Marscaleb Wrote:  However, while it's not exactly a major problem, I've noticed that the letter spacing is not identical to what it was before.
snip

When I first saw the change happen, I thought the bold effect was smaller than it was before. This got me thinking that I'd like to be able to adjust how strong the bold and italic effects are. Usually I've wanted the bold or italics on a word to be more noticeable. I mean, I'm trying to draw attention to it, so I want a bold effect that's stronger. The only other option is to increase the text size, but this requires making a separate text layer and then lining the two up.

That is doing it the hard way, nothing wrong with the hard way Wink but you can make use of the Gimp 2.8 text tool.
Have to confess I did not understand your screen shot, but I am more photo than graphics biased.
edit: Getting the screen ruler out, I can see the difference now. The long line of text, 770 pix vs. 740 pix

[Image: nYk28JN.jpg]

In the above
line 1 is straight forward default text
line 2 has the spacing adjusted for the whole of the text from the tool options settings.
line 3 has one part of the text (select it by swiping) adjusted for, bold & spacing & size, from the on-canvas text dialog.

Did this video when Gimp 2.8 first came out, still ok.
http://www.youtube.com/watch?v=ChcTE9KROmc&hd=1 only 4 mins, not that arduous.

Quote: I want to put in a feature request that GIMP would let me manually adjust the bold and italic strength in any text item. (As well as the text size of a selection within a text item.) How would I go about doing this?
This is not the place, no developers here. Best bet is to join the mailing list across at http://www.gimpusers.com/forums

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  How to install fonts for gimp only (not install on windows) Jacob123 1 91 Dec 7, 2018 08:58
Last Post: paynekj
  What method would I use in Gimp to fix this image? alock 2 344 May 30, 2018 14:57
Last Post: alock
  Scaling (reducing) image with fonts rubinho 2 472 Dec 17, 2017 17:17
Last Post: rubinho
  Miss-named fonts Andy Davies-Coward 1 407 Nov 26, 2017 05:14
Last Post: ythgilb
  Similarly named fonts not recognized poymando 0 343 Sep 16, 2017 17:58
Last Post: poymando

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS