Post Reply 

Using GIMP on Mac OS X

Feb 19, 2011, 19:28
Post: #1
Using GIMP on Mac OS X
Here's a complete newbie question. Even though I've had GIMP on my Macs for at least 5 years, spanning 10.4, 10.5, and now 10.6, on an old half-sphere iMac, a MacBook Pro, and now a 27" flat-screen iMac, I have never been very good at using it. I've never gotten past the "open a .jpg and resize it" level of facility.

Why? Because I can't figure out how to make about 80% of the functionality work!

For instance, right now, I've got GIMP 2.6.11 on Mac OS X 10.6.6 on a quad-core iMac Core i7 machine. I want to drag part of an image to somewhere else in the image. I have just used the lasso to select part of the image I want to move. I have the correct Layer selected that contains the image. In the Toolbox, I've selected the Move tool, and in the Move options at the bottom, I've selected the red box to indicate that I want to move the selection, not the layer or the path. I go back to the image window by clicking inside it. My cursor shows an arrow, a crosshair, and a small selection box. According to the documentation at http://docs.gimp.org/en/gimp-using-selec...ns-moving, Section 2.1.2 - Moving the other selections, I should be able to use Ctrl - Alt - click-n-drag to move my image selection wherever I want.

BUT IT DOESN'T WORK.

I have tried every combination of finger-twisting key manipulations I can think of with Shift, Ctrl, Alt, and Command, and nothing I do succeeds in moving that piece of the image. I've even tried using the set of Shift-Control-Command-Alt keys on the right side of the keyboard separate from the ones on the left side, just in case that makes a difference. About half the key combinations I've come up with, including Shift-Alt (or Alt-Shift, in case order is important), move the lasso selection itself, and the other half, including Shift-Ctrl (or Ctrl-Shift) switch from the Move Selection cursor to the Move Path cursor (an arrow, a circle with a bar through it, and part of a curve with a line tangent to it at a little square intersection point). Nothing moves the image contents though.

WHAT AM I DOING WRONG???

I have always had this feeling that there's something fundamental about using GIMP on a Mac that I'm simply missing. But in my occasional searches I haven't learned what it is. I must have a key binding wrong, or there's something set wrong in my X11 Preferences, or something. Can anyone help me get my computer set up so that GIMP works the way it should?

Thanks!
Find all posts by this user
Quote this message in a reply
Feb 25, 2011, 04:46
Post: #2
RE: Using GIMP on Mac OS X
Thanks, Ofnuts. The copy and paste-as-new-layer method seems to work pretty well.

I still can't get the move method to work, regardless of whether a Move tool or a Selection tool is the active tool. I don't know why, but at least I have a way to do what I want.

Thanks!
Find all posts by this user
Quote this message in a reply
Mar 3, 2011, 23:40
Post: #3
RE: Using GIMP on Mac OS X
Same problem here. Ctrl+Alt behaves as it should in Gimp for Windows7, doesn't for OSX. Copy/Paste does work, but having the same interface on all platforms saves frustration.
I've gotten it working for myself, so I figured I'd post here.

There's some patronizing advice here (http://gimper.net/viewtopic.php?t=4045), which suggests that the problem is with the default X11 key mapping in Leopard.

So, I followed steps 1 to 4 of this:
http://www.inkscapeforum.com/viewtopic.php?t=800&f=5
, with the following modification:
Change the line: "keycode 66 = Mode_switch" to "keycode 66 = Alt_L"
Change the line: "keycode 69 = Mode_switch" to "keycode 69 = Alt_R"

I quit X11, restarted GIMP, and now it works. Hope this helps somebody else.

There's a utility called xev (type "xev" in terminal, both OSX or X11) that you can use to see if the modifications to .Xmodmap worked. If you're seeing Alt_L and Alt_R when you hit the option keys in the X11 terminal, Ctrl+Alt+ClickAndDrag should work as well.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Gimp wont keep merging when exporting Ergu 1 105 Aug 8, 2018 21:22
Last Post: paynekj
  Printers not showing in gimp chrismacor 1 172 May 24, 2018 06:03
Last Post: paynekj
  Gimp 2.8 wont't see my wcoom bamboo tablet NullPointer 1 243 May 22, 2018 12:53
Last Post: paynekj
  Gimp compatibility katie98 1 175 May 22, 2018 05:53
Last Post: paynekj
  Using Adobe Typekit fonts within GIMP? Kevin M 10 1,770 May 21, 2018 16:07
Last Post: T.Mitarai

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS