Post Reply 

... user interface language ...

Jan 9, 2011, 03:18 (This post was last modified: Jan 9, 2011 03:29 by Earl_J.)
Post: #1
Question ... user interface language ...
Hello everyone,
here is a newbie question that I can't seem to find a solution for anywhere in the entire forum site. . . I've searched for "user interface language" without success and searched the tips and tutorials as well with similar results - none...
I added a free program to permit my wife to create email messages in the Japanese language. It works great... it installed itself and is not listed in the uninstall programs when I look for it.
Why would I want to uninstall it if it works great?
Well, (some of you may know where I'm heading here), it now installs itself when I start GIMP. My menus, messages, errors, and all warnings now appear in Japanese... I might be married to one, but I certainly can't operate my computer using Japanese.

Since it installed itself, I know it can be undone back to English. . . perhaps there is a way to disable it without having to use any of the menus in GIMP? Perhaps in the system folder in Windows or something along that line...
Additionally, I can still interpret some of the menu options by the location and the shortcut letters (O, P, Q), and so on...

I hope there is an easy preference or options function that will provide the solution.

Thank for the help...
I'm using Win 7 64-bit and both 2.4.7 and 2.6.11 produce the same result...

Until that time ... Earl J.


"Born on Valley Isle,
Home now, North Carolina;
Aloha y'all . . ."


Earl J.
Win 7 64-bit
GIMP 2.6.11
Visit this user's website Find all posts by this user
Quote this message in a reply
Jan 9, 2011, 08:55
Post: #2
RE: ... user interface language ...
What likely happens is that this program, when it installed itself, also changed a Windows setting that says you want a Japanese-speaking UI. Go there:
Control Panel → System → Advanced → Environment button in “System Variables”
and see if by any chance you haven't got a LANG variable whose value is now JP (and put it back to EN for English, for instance). You can also explore the "International" (from memory) part of the Control Panel(*).

Programs that don't show up as de-installable in the regular Windows programs list often provide an uninstall.exe or somesuch.

(*) You see the problem only in Gimp because, for market segmentation reasons, there is a version of W7 for each language, so W7 itself is impervious to the LANG setting, while Gimp has one version that talks al languages. On Linux, this would have changed the complete UI.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jan 9, 2011, 17:46 (This post was last modified: Jan 10, 2011 01:28 by Earl_J.)
Post: #3
RE: ... user interface language ...
Thanks ofnuts,
I checked but didn't find any items related to language...
I'll do a bit more research from the Windows side of things and see what I can find...
Thanks for the response and the advice ... although it didn't solve the problem, it does give me other avenues to explore.
Smile

Until that time ... Earl J.

Come to think of it, if GIMP is capable of multi-lingual functions, shouldn't it be easy to change amongst all the languages available? Now, to just find out how to do it in GIMP...
Any multi-lingual users willing to provide a little help here?

Until that time ... Earl J.


"Born on Valley Isle,
Home now, North Carolina;
Aloha y'all . . ."


Earl J.
Win 7 64-bit
GIMP 2.6.11
Visit this user's website Find all posts by this user
Quote this message in a reply
Jan 12, 2011, 02:27 (This post was last modified: Jan 12, 2011 02:29 by Earl_J.)
Post: #4
RE: ... user interface language ...
Found it y'all. . .
it was a Windows 7 alteration after all... thanks for the hint Ofnuts. . .
I did see the changes in the time and calendar functions for many other responses and results outside of GIMP; it certainly was not a GIMP-only phenomenon ...
Simply went to Microsoft support Knowledge Base and there it was...
and now, here it is:

To change your display language
When you change the display language, the text in menus and dialog boxes for some programs might not be in the language that you want. This happens because the program might not support Unicode. For more information about changing the text in menus and dialog boxes for programs that don't support Unicode, see Change the system locale.
If you want to set the display language for multiple users or for the Welcome screen, see Apply regional and language settings to reserved accounts.
1. Open Region and Language by clicking the Start button Picture of the Start button, clicking Control Panel, clicking Clock, Language, and Region, and then clicking Region and Language.
2. Click the Keyboards and Languages tab.
3. Under Display language, choose a language from the list, and then click OK.

All is right with the world again. . . (grin) well, at least my open source part of it ... (wink)



"Born on Valley Isle,
Home now, North Carolina;
Aloha y'all . . ."


Earl J.
Win 7 64-bit
GIMP 2.6.11
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Tongue Installing GIMP User Manual ozdoug 2 53 Aug 9, 2017 00:54
Last Post: ozdoug
  Printing help - User Defined paper size goad 2 265 Jul 10, 2014 14:14
Last Post: goad
Sad User Installation Failed! Fruity_Grebbles 10 1,106 Dec 6, 2013 08:10
Last Post: iForStyle007
  Get back standard interface triplemaya 4 528 Jun 30, 2013 08:59
Last Post: triplemaya
  Smudge inside selection.. Bug or user error? zeropointfield 4 804 Apr 22, 2013 07:32
Last Post: ofnuts

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS