Post Reply 

Transparent Layer Changing To Black instead of White after Export

Sep 8, 2011, 20:02
Post: #1
Transparent Layer Changing To Black instead of White after Export
Hi everyone,
Thanks in advance! I'm having an issue. I sell a template that has a transparent layer in sections, after saving as jpeg it is supposed to go white, but for some of my customers it recently started going black! Does anyone know what is causing this? I at first thought it had to do with not pasting the layers correctly, but its like this after export, so I don't think that should matter...I've attached a sample image so you can see what is happening. Where it is black, it was originally transparent around the circle image, and normally would save white.
Thanks,
Amanda


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Sep 8, 2011, 22:05
Post: #2
RE: Transparent Layer Changing To Black instead of White after Export
It looks like Gimp replaces the transparency by the background color when it flattens the JPEG to save it, so you must have had your background color set to black when you saved.

If transparency is important, use PNG instead of JPEG: on this kind of images it will give much better results and likely smaller file sizes. And if you want to insure a specific background color for you JPEG, kjust add a bottom layer of the right color to your image.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Sep 8, 2011, 22:45
Post: #3
RE: Transparent Layer Changing To Black instead of White after Export
(Sep 8, 2011 22:05)ofnuts Wrote:  It looks like Gimp replaces the transparency by the background color when it flattens the JPEG to save it, so you must have had your background color set to black when you saved.

If transparency is important, use PNG instead of JPEG: on this kind of images it will give much better results and likely smaller file sizes. And if you want to insure a specific background color for you JPEG, kjust add a bottom layer of the right color to your image.

You are amazing! I'm thinking that is the problem! I'm having my customer test it out, but I did a test with black as the background and that fixed it! You are great!!!
Thanks sooo much!
Amanda
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  change the default export setting of Untitled.png ezz9 2 186 Jun 9, 2017 16:31
Last Post: ezz9
  Unable to open, save, and export Rockymtnx 0 206 Oct 2, 2014 17:18
Last Post: Rockymtnx
  New layer color... btraven 0 186 Oct 2, 2014 00:47
Last Post: btraven
  Dragged Layer Dropping Issues darkikuto18 3 236 Sep 29, 2014 07:56
Last Post: fluffybunny2
  Get rid of the "new layer dialogue"? 3dDave 2 238 Sep 20, 2014 20:34
Last Post: 3dDave

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS