Post Reply 

Text effects broken?

Oct 1, 2013, 05:13
Post: #1
Text effects broken?
When I am editing text, GIMP will no longer apply italic nor bold effects. (Underline works though.)

I just upgraded from 2.8(.2?) to 2.8.6, and now I have this problem. I also just upgraded from Win XP to WIn 7 and upgraded from 32-bit to 64-bit, so I don't know if that is a factor.

I have files I created with the last version of GIMP that I can open and see the text properly formatted, but if I adjust the text the formatting disappears and WILL NOT come back.

Is anyone else having this problem? Does anyone know how to solve it?

Oh yeah, and GIMP won't print anymore either. My printer is set up correctly and I can print from other programs, but when I print from GIMP, it LOOKS like it went through, but the printer fails to do anything. I wind up having to tell GIMP to print to the microsoft xps writer (which DOES work) and then open the xps file I just made and have windows print it.
Does anyone else have this problem with 2.8.6 or did I do something wrong?
Find all posts by this user
Quote this message in a reply
Oct 1, 2013, 09:15
Post: #2
RE: Text effects broken?
Can't really help, the text bug is as it says, works in linux, not in windows.

Printing, never a strong point with Gimp. A Win7 64bit VM and Gimp 2.8.6 and it works as expected. For Win, Gimp basically fires up the Windows printer driver, so it is worth looking there for problems as well.
I assume you have already checked these but...
Sensible settings in the Gimp dialogue, margins, if there should be margins, etc.
http://i.imgur.com/vvDwIFU.jpg

Your printer set as default and printer settings correct; paper, size, tray,
Does anything show up in the printer queue when printing from Gimp?
http://i.imgur.com/OdbXyR2.jpg

It might help if you say what the printer is. Someone might have similar printer/fix

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Oct 2, 2013, 08:08
Post: #3
RE: Text effects broken?
(Oct 1, 2013 05:13)Marscaleb Wrote:  ...

I have files I created with the last version of GIMP that I can open and see the text properly formatted, but if I adjust the text the formatting disappears and WILL NOT come back.

...

As mentioned and revealed by the others, the font not being able to be bold italic is a bug specific to font selected. Maybe you can pick a similar font that works with bold / italic in the font list in Gimp. Or does it not work with all the fonts?

As for the
"but if I adjust the text the formatting dissapears"
Whenever you apply a graphic transformation to the text in gimp, outside of its font size/text formatting, using any of the image editing tools, you lose the text information, that is why it disappears.

Please look here to understand more: http://docs.gimp.org/en/gimp-layer-text-discard.html

*However, certain basic transformations to text you can still click the text tool and edit the text, it will give you a pop-up message like this when you do
See "Figure 9.2. Warning lose modifications"
http://docs.gimp.org/en/gimp-image-text-management.html

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Oct 12, 2013, 05:38
Post: #4
RE: Text effects broken?
Hi all,
I have hundreds of images that all have the same watermark (more or less but not exactly in the same place). It can easily be removed with the paint bucket with the default settings, the watermark is light grey, the pictures (JPGs) are black and white (a scanned book). But the sheer number of images makes it a gigantic effort to do it by hand. Any tips?
Find all posts by this user
Quote this message in a reply
Oct 12, 2013, 07:47
Post: #5
RE: Text effects broken?
(Oct 12, 2013 05:38)mahisehar Wrote:  Hi all,
I have hundreds of images that all have the same watermark (more or less but not exactly in the same place). It can easily be removed with the paint bucket with the default settings, the watermark is light grey, the pictures (JPGs) are black and white (a scanned book). But the sheer number of images makes it a gigantic effort to do it by hand. Any tips?

I thought I saw this somewhere...
Why do you have so many accounts?
You should keep your login info somewhere you can find it

vvvAlso, please check out the solutions here, thankyouvvvv

http://gimpforums.com/thread-automatical...=watermark
Visit this user's website Find all posts by this user
Quote this message in a reply
Oct 12, 2013, 11:49 (This post was last modified: Oct 12, 2013 11:49 by foxmuldr.)
Post: #6
RE: Text effects broken?
Since it works in Linux, you can install Oracle's VirtualBox, and download Ubuntu or Linux Mint, create a VM and run Linux in your Windows desktop. This will allow you to use GIMP (it comes installed by default). You can use the clipboard to transfer from your Linux instance to your Windows machine.

Or, just switch to Linux and be done with it (he said, posting from Linux Mint 15, using Windows as the VM instance in VirtualBox). :-)
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  text line spacing leavitt@buffalo.edu 1 159 Aug 20, 2018 20:07
Last Post: paynekj
  Character size in menus (text size) Punchcard 1 204 Aug 13, 2018 06:27
Last Post: paynekj
Exclamation Bug: Changing text size by one changes it by thousands Puntherline 1 238 Jun 16, 2018 18:25
Last Post: paynekj
Sad Cant Move Text Area ! bhavtosh 1 294 Mar 9, 2018 13:34
Last Post: paynekj
  Feature Request - Built in Outlined text cosmicvoyager 1 340 Sep 18, 2017 08:15
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS