Post Reply 

Strange behavior of color layer mode

Nov 11, 2011, 13:22
Post: #1
Strange behavior of color layer mode
Hi,

I notices by my opinion unexpected behavior of "color" mode if applied to upper layer in layers dialog.

I believed it should take hue and saturation from current(upper) layer and value (brightness) from below layer. As long as the two layers do not differ in brightness it seems to work properly. But the problem is when they differs...


I believe that the results should be same as if I make two copies of upper layer, one set to "hue" second to "saturation" mode...

Or another test: when I swith the two layers (reffering to first scenarion above), and set the above layer to "value" mode, ther results are OK.

So perhaps I dont understand what "color" mode is exactly doing...

My question should be like - does color mode work properly by our opinion?
Find all posts by this user
Quote this message in a reply
Nov 11, 2011, 13:59
Post: #2
RE: Strange behavior of color layer mode
Well I'm writing a plugin that generates "color mask" and now I found that the results (when using color mode on it) are very different to what I expected. In fact, this "better functionality" damages my effort...

I noticed that when origianal is bright, resulting colors are strongly desaturated...

Chances are that I would adjust my algorithm to be compatible with gimp's algorithm but it is extra work. And then I first need to find out gimp's algoritm...
Find all posts by this user
Quote this message in a reply
Nov 11, 2011, 21:01
Post: #3
RE: Strange behavior of color layer mode
Ofnuts,

I need it to be as simple as possible.

BTW, I already used gimp's in-build HSV <-> RGB conversions.
I converted RGB to HSV, set V to 0,5, and converted it back to RGB. Still when I set upper layer to color mode it doesnt work properly.

I would need exact formula what color mode is doing. May be I need to look into source.

For your information, I work on this:
http://code.google.com/p/selective-color...troduction
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  silver color pamopar 2 3,982 Nov 22, 2017 06:01
Last Post: georgemacin
  Color alpha function and its current errors Fuse809 0 285 Oct 11, 2014 03:53
Last Post: Fuse809
  GIMP 2.8 Eyedropper Color Selection Tool Not Working? Upgraded App is Slow?? tootallll 13 10,162 Oct 9, 2014 18:39
Last Post: Graphicman2014
  Using Color/Levels causing phosterization photos piotrkast 4 569 Oct 8, 2014 11:52
Last Post: piotrkast
  New layer color... btraven 0 248 Oct 2, 2014 00:47
Last Post: btraven

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS