Post Reply 

specifying delay !HELP!

Feb 19, 2014, 02:57
Post: #1
specifying delay !HELP!
hey... how do you specify the delay time between frames before saving as a gif file. i have multiple frames with different delay times... like this:
frame1 (500 ms)
frame2 (1000 ms)
frame3 (500 ms)

when i try and export it as an animated gif, it says:

Delay between frames where unspecified, and than i have to pick a number.

how to i specify my frames? I have already typed in the ms on all the layers, and it plays how i want it to in the animation playback.
Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 03:28
Post: #2
RE: specifying delay !HELP!
For the "Export Image as GIF" window

Type or adjust the number in "Delay between frames where unspecified:"
(higher numbers slower, 300-500 is good for slideshows)

-Then check on
"[]Use delay entered for all frames"

Then click export.

========
For individual frames
- Go to your layers window & type it in the frames like this:

Layer1name (200ms)
Layer2 name (100ms)
Layer3name...

*put a space between the layer name & parenthesis "()"
-Then don't check the "Use delay entered above for all frames" when you export it.

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 03:46
Post: #3
RE: specifying delay !HELP!
well, i didnt have the space between the layer name and the parenthesis. did that, but it still sets all the frames to 100 ms when i export it. any ideas?

ps, i did not check the use delay entered above box.
Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 04:01
Post: #4
RE: specifying delay !HELP!
(Feb 19, 2014 03:46)Vace Cooper Wrote:  well, i didnt have the space between the layer name and the parenthesis. did that, but it still sets all the frames to 100 ms when i export it. any ideas?

ps, i did not check the use delay entered above box.
Remove the spaces between the numbers and the 'ms' eg: (500ms)
Smile
Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 05:49 (This post was last modified: Feb 19, 2014 05:50 by iForStyle007.)
Post: #5
RE: specifying delay !HELP!
If that doesn't work, you might have it in the wrong place
One other thing,

To see what the layers look like with the timings added automatically (then you can edit them)

-First have your layers with no "(100ms)"

Then go to:

Filters > Animation > Optimize (for gif)...

After it processes, you'll see a new "(100ms)(combine)" next to each frame, that is how it should look.

Also visible here @step 3:
http://www.gimp.org/tutorials/Simple_Animations/
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 14:14
Post: #6
RE: specifying delay !HELP!
(Feb 19, 2014 04:01)fluffybunny2 Wrote:  Remove the spaces between the numbers and the 'ms' eg: (500ms)
Smile
I will give this a try quick..


(Feb 19, 2014 07:48)ofnuts Wrote:  The sentence is "Delay between frames where unspecified", so it is the delay used when there is not specific delay. If you have entered a delay on all frames, this is ignored.
and that is why im wondering how to specify the delay. is there a way to do this? or do you have to have the same delay time between all frames?
Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 14:22
Post: #7
RE: specifying delay !HELP!
removing the space between the numbers and the ms worked!!! all the tutorials ive watched put a space there.. maybe some tutorial maker should put up a new one correcting this wrong doing! thanks for all your help dudes!
-Vace!
Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 21:44 (This post was last modified: Feb 19, 2014 21:53 by iForStyle007.)
Post: #8
RE: specifying delay !HELP!
Quote: all the tutorials ive watched put a space there.. maybe some tutorial maker should put up a new one correcting this wrong doing! thanks for all your help dudes!
-Vace!

...I don't know about that, doing a search this was the first video tutorial with proper usage I found:
http://www.youtube.com/watch?v=ybBrl3hSCI8

Could you namedrop (no link if not a YTube vid) the video of where you saw the video/videos?

If they did use a space they either got lucky or sloppy (somewhere in their tutorial they might have used the "Optimize" filter that overwrites the give with a (##ms) like I said earlier or they add a uniform delay (see below for my final thoughts)

EDIT: *facepalm* hahaha, I found maybe one of the ones you talked about plus some think he sounds high lol, entertaining video none-the less:
@5:05
http://www.youtube.com/watch?v=f-9_HwRcd1A

(Feb 19, 2014 14:22)Vace Cooper Wrote:  removing the space between the numbers and the ms worked!!!

But its great that you finally fixed it!

A possible reason for the delay option not seeming to work for you is that you could be perceived it to look the same if the values is too low as it applies one delay uniformly to all frames (if none of the frames have the "(##ms)" tag at the end before you export with the "[]delay...unspecified" option.

Anyways, have fun! LOL
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Question gif animation frame delay carilchasens 4 3,208 Oct 26, 2013 11:52
Last Post: iForStyle007

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS