Post Reply 

setup problem: Folders?

Oct 7, 2011, 20:01
Post: #1
setup problem: Folders?
I have gimp up and running on a Debian Squeeze system and an iscan plugiin in ~/.gimp-2.6/plug-ins. iscan runs perfectly from a command line and gimp can open the default.png file it creates but a scan run from gimp hangs up just after the scan is complete and the message transforming image appears.

I think the problem must be related to the temporary file. I have gone to Edit/?references/Folders and tried to set the temporary file to /tmp but when I restart gimp the entry has gone back to File System. There must be a configuration file somewhere that controls this. In fact, if I click on the box one of the entry choices is Home Improvement. This is indeed a sub-directory of my home file but not one I would ever chose for giimp.

In short, I would like the temporary folder to be /tmp and the choice /home/tom/ Home Improvement to be eliminated.

Maybe I have misunderstood the root cause of the problem. Any suggestions or corrections?
Find all posts by this user
Quote this message in a reply
Oct 7, 2011, 21:31
Post: #2
RE: setup problem: Folders?
(Oct 7, 2011 20:40)ofnuts Wrote:  Start gimp as "gimp --verbose" in a terminal session and check for messages...

This generated a lot of messages, mostly parsing statements. I am attaching the final lines of the output which report libesmod.so.1 doesn't exist and includes a warning. After these lines the normal gimp windows appear, I started a scan from gimp, the iscan windows appeared, the scanner ran and the system hung translating the image.

There was no further verbose output.
Find all posts by this user
Quote this message in a reply
Oct 8, 2011, 00:16
Post: #3
RE: setup problem: Folders?
(Oct 7, 2011 22:28)ofnuts Wrote:  libesmod.so is part of the iscan stuff (or at least is used by it), so as long as you have this problem you can't expect iscan to run properly.

See there: http://ubuntuforums.org/archive/index.php/t-935107.html

I'll work on this but catch is that iscan run from a terminal works perfectly and writes a file default.png which gimp can open and edit with no difficulty.

iscan started by gimp runs the scanner and only hangs up at an xsane window that says transferring the image and converting the image. So is it a libesmod problem or lack of a folder with proper read/write permissions? If I could set the temporary folder to /tmp as recommended it would remove one possible cause.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Can't change page setup settings defunk 4 1,456 Aug 22, 2017 05:15
Last Post: ythgilb
  problem with drop shadow Kharl 37 2,033 Oct 8, 2014 04:53
Last Post: Kharl
  Pattern Fill Problem, Request BeePee 7 741 Jul 25, 2014 18:41
Last Post: rich2005
  Problem with Cursor/Brush tip Pyrefly 5 578 Jul 24, 2014 15:59
Last Post: iForStyle007
  problem gimp with my genius tablet mahermatrix 2 321 Jul 23, 2014 16:40
Last Post: mahermatrix

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS