Post Reply 

Select Average Color Doesn't Work in 2.8

Nov 16, 2012, 08:05
Post: #1
Select Average Color Doesn't Work in 2.8
There was a very lean plug-in called "Sample Average Color" that I used a lot in the past. Its page is here: http://registry.gimp.org/node/16678

This Sample Average Color plug-in simply takes all of the colors of a selection, averages them, and then makes that your foreground color. Very quick and simple.

However, now in 2.8, I'm no longer seeing it under the Colors tab.

(This MIGHT be caused by my recent upgrade to Windows 7 64-bit? I don't know. But I believe it's more likely because of 2.8.)

So is there anybody who can explain why this isn't working and give me any instructions on how to make it work? (Alternately, if anybody knows any work-arounds for quickly selecting an average color, that would be appreciated, as well.)

Thanks as always.
Find all posts by this user
Quote this message in a reply
Nov 16, 2012, 10:21
Post: #2
RE: Select Average Color Doesn't Work in 2.8
(Nov 16, 2012 09:28)ofnuts Wrote:  Since this isn't part of standard Gimp, it has to be reinstalled for Gimp 2.8. Where did you put it?

This is on Windows 7 64-bit (so there are both "Program Files" and "Program Files (x86)" Folders, it is in:

Program Files > Gimp 2 > Lib > gimp > 2.0 > Plug-ins

I'm nearly certain that this is the same destination as most all other plug-ins used for GIMP. I tried placing it in several other folders, as well, but it never showed up in the GIMP program under the Colors tab.
Find all posts by this user
Quote this message in a reply
Nov 16, 2012, 10:35
Post: #3
RE: Select Average Color Doesn't Work in 2.8
I don't see any folders called "Scripts".

Should I create one? If not, where would it be (I believe I just checked most all possible locations.)
Find all posts by this user
Quote this message in a reply
Nov 16, 2012, 12:02
Post: #4
RE: Select Average Color Doesn't Work in 2.8
(Nov 16, 2012 11:46)ofnuts Wrote:  In your Gimp profile the "plug-ins" directory has a brother called "scripts". There is also one in your Gimp general installation, use your file explorer to look for "*.scm" files. But it is a better idea to keep them in your profile, or in a third folder, that you indicate to Gimp in "Edit/Preferences/"->Folders.

Ah, thanks. Yeah, there was a native folder in this directory (which I learned of via the post you linked to):

C:\Users\{your_id}\.gimp-2.6 (ie, a "sibling" of "Application Data" and "My Documents")

So I just cut-and-pasted it from my plug-ins folder to there, and now it is available.

I do indeed have a separate folder to keep copies of all the extra scripts/plug-ins I use, and I guess I might eventually just want to make that the folder that GIMP reads directly, now that I know that I can customize that.

Thanks as always, OfNuts.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Help - can't get Mathmap and GMIC to work together paul2332 1 520 Jul 15, 2017 18:58
Last Post: ythgilb
  Cant get Heal Selection to work ianp5a 1 663 Oct 9, 2014 20:04
Last Post: rich2005
  Script fu and Color to alpha john 4 1,348 Sep 20, 2014 08:46
Last Post: rich2005
  Color menuitems in script or plugin Barbie 2 1,045 Sep 15, 2014 08:09
Last Post: rich2005
  plug_in_dog won't work covjek123 2 635 Jun 28, 2014 21:47
Last Post: covjek123

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS