Post Reply 

Script-fu window hangs after using plugin

Aug 27, 2014, 04:06
Post: #1
Script-fu window hangs after using plugin
Pretty new to GIMP here. I'm using version 2.8.4 on a Mac OS X 10.9.4

Whenever I use a script-fu plugin, the plugin window hangs up and doesn't go away after I hit "OK", even though the plugin effect works. There are no error messages or anything, just a straggling window and a "script-fu" icon in my dock. If I put my mouse over the windows, I get the spinning wheel and can't click on anything. I can't get rid of them unless I "force quit" script-fu.

I can use multiple script-fu plugins, and their windows will all just hang around. It isn't too intrusive of an issue, but it's pretty annoying!

Anyone else experience this or know a fix?

Thanks!
Find all posts by this user
Quote this message in a reply
Aug 27, 2014, 05:37
Post: #2
RE: Script-fu window hangs after using plugin
Haven't heard of that one before.
Where did you source Gimp from?
Partha's builds for Mac OS are very reliable...
Find all posts by this user
Quote this message in a reply
Aug 27, 2014, 14:02
Post: #3
RE: Script-fu window hangs after using plugin
Thanks for the replies.

I actually just upgraded to GIMP 2.8.10 straight from the website, and the "hanging window" problem went away, though I still notice a "script-fu" icon in my dock after using one of the plugins.

ofnuts, I tried the python-fu script you mentioned, and everything worked fine. There are no hanging windows or dock icons.

To be more specific, I was using drop-shadow (Filters>Light & Shadow>Drop Shadow). The Drop Shadow window would come up, where I would adjust the settings. Once I clicked OK, the effect was added to selected object. I would then look at my dock and see an icon next to the GIMP icon, which said "script-fu" when I put my mouse over it. After minimizing all the windows on my desktop, I'd find the Drop Shadow settings window still open and left hanging as if it was still working.

Like I said, now that I've upgraded, the windows don't hang around anymore when I use the Drop Shadow plugin, but I still see the script-fu icon on my dock. If I choose force quit to get rid of it, the Drop Shadow plugin (and I'm assuming all the other plugins that are from script-fu) disappear from the filter menu until I restart GIMP. I guess that dock icon just shows up when you use a script-fu plugin? Again, this doesn't happen with the python-fu script you mentioned.

Please excuse my newness if I'm getting my terms messed up!
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  plugin save for web in Gimp 2.9.6 Dkk 1 87 Oct 19, 2017 09:02
Last Post: paynekj
  Request for script chlebna 1 137 Sep 13, 2017 09:35
Last Post: ythgilb
  Request for script - Guillotine + Watermark sunslick 1 196 Sep 4, 2017 08:51
Last Post: ythgilb
  Script-fu: How to create new, addressable layer using gimp-floating-sel-to-layer Bertholom√§us 2 192 Aug 31, 2017 14:32
Last Post: Bertholomäus
  How to modify this script-fu? Zakary81 1 156 Aug 23, 2017 12:48
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS