Post Reply 

Script error

Sep 3, 2012, 20:48
Post: #1
Script error
I tried to install mats-and-frames.scm today after putting the scm file in the scripts folder and later in the plugins folder.
In either case I get this error, is there anything I can do to make the script work in 2.8?

Error: ( : 1) eval: unbound variable: gimp-drawable-image
Find all posts by this user
Quote this message in a reply
Sep 3, 2012, 22:26
Post: #2
RE: Script error
(Sep 3, 2012 22:09)ofnuts Wrote:  Why don't you ask the author?

http://gimpguru.org/Tutorials/MatsAndFrames/
I did thanks, a lot of this stuff is so old the authors are available
Find all posts by this user
Quote this message in a reply
Sep 4, 2012, 02:04
Post: #3
RE: Script error
(Sep 3, 2012 23:39)ofnuts Wrote:  Hmmm. A Gimp 2.2 script...

Replace "gimp-drawable-image" by "gimp-drawable-get-image". But that could be the beginning of a long and painful update process... more things may be obsolete or work in subtly different ways.

Well, some of the other scripts in the package I downloaded worked OK. I was hoping there would be an easy way to make mats and frames work, guess that is not possible it's OK though I will find something that will work someday.
Find all posts by this user
Quote this message in a reply
Sep 4, 2012, 11:55
Post: #4
RE: Script error
Go here:
http://www.gimphelp.org/script28.shtml
down to the bottom of the page and this is the link to the download
http://www.gimphelp.org/DL/gimp_scripts-2.8.zip
One of them is the matte_and_frame script, works here in Gimp 2.8.2

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Sep 5, 2012, 01:12
Post: #5
RE: Script error
Unfortunately that is the one I have, I get an error when I try to run mat_and_frame.
Find all posts by this user
Quote this message in a reply
Sep 5, 2012, 08:11
Post: #6
RE: Script error
Well, I can only go with what I see here. Maybe more info, What OS? Which version of Gimp 2.8?

This is in a WinXP & Gimp 2.8.2 using FU_edges_mats-and-frames.scm for gimp 2.6 size 20618 B
[Image: r6h5O.jpg]

And this is using FU_edges_mats-and-frames.scm for gimp 2.8 size 20342 B

[Image: XuU7a.jpg]

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Run script on action rchav 2 1,147 Aug 13, 2018 14:57
Last Post: rchav
  Script Fu Errors Gimp 2.10.4 lightsaber jd3481 1 723 Aug 2, 2018 05:13
Last Post: paynekj
  Script-fu script to conversion pdf to image 4ever 12 13,199 Jul 17, 2018 16:01
Last Post: paynekj
  Problems with a bat script :( ThaUnknown_ 1 568 Mar 26, 2018 21:14
Last Post: paynekj
  Script-fu ordered file list vnicent 1 379 Mar 19, 2018 17:33
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS