Post Reply 

Save function no workie

Jul 23, 2011, 16:47
Post: #1
Save function no workie
[Image: attachment.php?attachmentid=198109&a...1311378915]Meerkat/Gimp 2.6

I'm fairly new with Ubuntu but having used Photoshop for years most of Gimp's funtions are familiar.

However

Have a Gearhead mouse and a Wacom Bamboo tablet that work just fine in Gimp until I try to save the work.
I get a strange page. and neither mouse nor tablet will let me select anything. I tried your tutorial for setting up the tablet, but when I go to Input controllers, the devices aren't there, Ubuntu is saying device not available, permission denied.

Don't know if you ca enlarge the graphic, but that's what I get on save.

If I can't save images in the formats I need, Gimp isn't much use. Please help.
Thanks
Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 17:14
Post: #2
RE: Save function no workie
I'm using (K)ubuntu 10.04 with Gimp 2.6.8 and have no such problems even when I use my Bamboo tablet.

Your attachment doesn't work. Just use the attachment items at the bottom of the post editor.

Futhermor in Gimp each image type has its own plugin to load & save files, so without even knowing the type you are trying to save I can't make any guesses.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 17:43 (This post was last modified: Jul 23, 2011 17:46 by weezyrider.)
Post: #3
RE: Save function no workie
(Jul 23, 2011 17:14)ofnuts Wrote:  I'm using (K)ubuntu 10.04 with Gimp 2.6.8 and have no such problems even when I use my Bamboo tablet.

Your attachment doesn't work. Just use the attachment items at the bottom of the post editor.

Futhermor in Gimp each image type has its own plugin to load & save files, so without even knowing the type you are trying to save I can't make any guesses.

   

What I am getting is Ubuntu's desktop instead of Gimp's. It is simply ignoring any Gimp dialog box and going straight to the folder!
I have to save by typing the file format I want.
I've tried attaching again.
If you want to see what I get when I click on Open in Gimp, go to places>pictures>
and I simply cannot make the mouse/tablet work.
However, if I open that file from the desktop, the mouse/tablet do work.
I bought the book beginning Gimp and the dialog boxes are totally different.
The same thing happens with save. There are preferences for a BMP file and I don't get that dialog!

I do know file formats. I use Photoshop most of the time, so I know that threr are preferences for certain formats.
Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 20:00
Post: #4
RE: Save function no workie
This isn't your desktop... this is a Save dialog (that looks maximized). Mine is a bit different because I use KDE, so it looks more like KDE (this is called "Desktop integration").

Since your file is called "untitled", it has never been saved, so Gimp can't tell what format you want, so all you have to do is replace "Untitled" in the top entry field by "somename.xcf" or "somename.png" or whatever format is supported by your Gimp setup. This will lead to a dialog with the options specific to that file format:

[attachment=563]

In the coming version "save" will always be to XCF (native Gimp format) and you'll have to use "export" to save in a different format.

Books on Gimp have to be taken with a grain of salt. The GUI evolves... the mere idea that they use BMP file indicates that 1) the book has been meant for Windows users and 2) it's quite out of date (who uses BMP these days?)

If the mouse is inoperative I suspect some kind of focus problem, for instance a "modal" dialog (error message?) that appears but is masked because the Gimp window opened over it. Try to minimize all your windows one by one.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 20:32
Post: #5
RE: Save function no workie
Open finally worked - why did making the window smaller help?
BTW no error message underneath
If that's the way Gimp saves, then so be it. Will work with it for a bit.
Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 20:41
Post: #6
RE: Save function no workie
I can now select using the mouse in open, but not in any of the save functions. I can't select the select folder or file type by extension.
I would at least want to select the folder as I just might want to save the picture to the (separate) xp drive


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 20:57
Post: #7
RE: Save function no workie
(Jul 23, 2011 20:41)weezyrider Wrote:  I can now select using the mouse in open, but not in any of the save functions. I can't select the select folder or file type by extension.
I would at least want to select the folder as I just might want to save the picture to the (separate) xp drive
Do you mean that if you double-click a folder name (Webcam, for instance in your dialog) it doesn't enter that folder? Or that if you click on Documents on the right it doesn't open it in the center part? 'XP' may be a different case, if it's your Windows partition, accessing it requires specific privileges (it may not be mounted by default), and on my system I am asked for a password (typically, in a modal dialog, that may get overlooked and left one wondering why the mouse no longer works).

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 21:26
Post: #8
RE: Save function no workie
Sometimes it will, most of the time it won't. I can't move that blue selection marker anywhere else, I can't select the file formats, nor the folder. I don't have a windows partition. I have 2 hard drives. 1 for Linux, 1 for XP. I don't need a password for XP as it's like saving to a USB stick. I can boot directly into XP from Grub
It seems you have to delete the whole name and start over. I usually save as file, work with it, save as file2, just by inserting the number 2. I can't do this. I have to delete the whole file name, then type in file2 and I might get a dialog.

It's funny that no other program has this problem. Inkscape and Paint work as normal.
I found some more installation instructions and they said to disable wacom bamboo pad in the configure input. That made the rest of the tablet work somewhat in the save menu. Open is now working normally.
Find all posts by this user
Quote this message in a reply
Jul 23, 2011, 21:46
Post: #9
RE: Save function no workie
(Jul 23, 2011 21:26)weezyrider Wrote:  It seems you have to delete the whole name and start over. I usually save as file, work with it, save as file2, just by inserting the number 2. I can't do this. I have to delete the whole file name, then type in file2 and I might get a dialog.
From "untitled"
The whole name is selected, which means that if you type anything directly it's replaced. But if you do a cursor-right before typing, the selection disappears and you are in a mode where you can append to the file name. Likewise, if you "save as", you get a selection on the name (but not on the extension), so cursor-right puts you in a mode where what you type is inserted at the end of the name part. In other words, if you are editing sample.png

- [ctrl-shift-s]
- [cursor-right]
- ['2']
- [enter]
- [enter]

Saves the file as 'sample2.png', and from 'sample2.png' ([enter] is used twice, in the save dialog and once in the PNG options dialog)

- [ctrl-shift-s]
- [cursor-right]
- [baskspace]
- ['3']
- [enter]
- [enter]

Saves the file as 'sample3.png'.

If this doesn't work for you then figure out:

Linux type/distro and version
Desktop type (Gnome, KDE or else) and version
Windows manager type (Sawfish, Metacity, KWM, Enlightenment...) and version
Gimp version

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 24, 2011, 18:21
Post: #10
RE: Save function no workie
That worked for changing the name, but I still can't select which place or file. I save most of my stuff to a USB stick or portable hard drive rather than the C drive. I've always saved stuff elsewhere.

I have Ubuntu 10.10 Maverick Meerkat

I have no idea what the desktop type is. It's not one of the fancy ones. It's whatever came with Ubuntu.

What do you mean by Windows Manager? XP is on it's own hard drive. No partition. I have to reboot the computer to access it. I can see it from Ubuntu, and drop files on the desktop, or copy files, but can't run programs. Which is the way it was set up at my request. The Ubuntu drive was W2K.

Gimp is 2.6.11
Find all posts by this user
Quote this message in a reply
Jul 24, 2011, 19:03
Post: #11
RE: Save function no workie
A 'windows manager' in Linux is the software layer that display things on the screen (its manages which windows are visible, which receive input, hence its name). There is another layer above it that manages the 'desktop' (usually Gnome or KDE, or Unity in Ubuntu 11.04). IMHO your problems either stem from this or from some unfamiliarity with the way Linux user interfaces work.

Note that by default Gimp loads/Save files in its working directory, so if you have a favorite directory for Gimp things, you can set up your Gimp shortcut to make it the current directory when Gimp starts.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 24, 2011, 20:00
Post: #12
RE: Save function no workie
Where are the settings for windows manager? You have me curious.
DEsktop is plain Jane Gray, the way we were taught in Photoshop classes.
There might be something wrong with the file system. I clicked on it yesterday and it opened up at least 50 versions of itself. Somehow I don't think that's right.

I've been lucky that everything I have does work. Printers, tablet, mouse, mike, webcam for Skype, ethernet, external drives.

I can drag all the stuff from the native folder of Gimp to a card, just to keep the HD clean. I think I have 2 80g drives and neither one is 1/2 full. I always save elsewhere. I've had to dig files off a half dead computer and it's no fun.

I do like what Gimp does on the creation end. It probably is capable on the photo side, but I can't set the tool cursors the way I want.
Find all posts by this user
Quote this message in a reply
Jul 24, 2011, 20:14
Post: #13
RE: Save function no workie
I don't play with Window maangers. Not experienced enough for that...

One of the benefit of Ubuntu compared to other desktop-oriented distros is that everything works out of the box.

File systems problems is a possibility, especially access rights. Check that the directories you want to use have bot the read and execute bit set for you.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Applying a GEGL function via commandline Bernhard Hiller 1 120 Sep 3, 2017 18:51
Last Post: ythgilb
  nothing works from the File menu, can't save, export, close, etc jperiod 1 110 Aug 3, 2017 05:19
Last Post: ythgilb
  Default save-as location Babudro 1 157 Jun 7, 2017 15:44
Last Post: ythgilb
  Create new images button & Save as override from Script-fu beniman 12 483 Sep 10, 2014 10:57
Last Post: paynekj
Rainbow How do I save an index image's color map? Zippy0723 1 311 Sep 7, 2014 00:50
Last Post: Zippy0723

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS