Post Reply 

Quick mask selection issue...

Dec 31, 2013, 06:29
Post: #1
Quick mask selection issue...
I'm having problems getting a selection with quick mask. What I'm trying to do is get radial gradient selection in the center of an image going to the outer edge. I open an image, dupe it, hit quick mask then click the gradient tool. I choose Radial in the dialogue box and set the offset. I then draw a line from the center of the image outwards and the whirly thing shows it's working. But when I toggle the quick mask off, sometimes I have a nice round selection, sometimes I don't have anything and sometimes I have an opaque black-to-transparent gradient circle in the center.

I don't know what I'm doing wrong. Am i missing a step? Do I have to click the layer icon or something before I do the gradient? What am I unconsciously forgetting? Add Alpha channel (that doesn't seem to make a reliable difference)?

I've been using 2.8.10 for a short while and haven't had any other problems. Should I change back to 2.8.8? I never tried this in .8, so I don't know if it worked reliably then. Did I maybe set an environment variable wrong when I started with 10? Is this just further evidence of age-related cognitive decline and I should think about taking up tatting?

Thanks
Find all posts by this user
Quote this message in a reply
Dec 31, 2013, 09:40
Post: #2
RE: Quick mask selection issue...
Working here with Gimp 2.8.10, so maybe your technique Wink I do not know what you are doing wrong either. Maybe post a sample image in xcf format.

Otherwise, very much depends on the gradient settings
As well as the type of gradient fg-to-bg (+HSV +RGB not much difference) fg-to-bg (hard, very different), there are the offset and repeat setting.
comparison screenshot http://i.imgur.com/Q4DtFaM.jpg

Depends what you want to do but a layer mask will give an instant result.
A black layer mask, with white fg / black bg is the equivalent to making, inverting and cutting a selection.
http://i.imgur.com/PLUJW1I.jpg

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Dec 31, 2013, 11:10
Post: #3
RE: Quick mask selection issue...
I'm sorry. I cannot figure out how to post an .xcf. When I try to do it in this reply box by hitting the little icon after selecting the reply button under the message, I get the "post URL" dialogue box, but I only know how to get a URL by using imgur and imgur won't take the .xcf.

I just don't know how to use these forums I guess. Right now I'm typing in the "quick reply" box. I give up.
Find all posts by this user
Quote this message in a reply
Dec 31, 2013, 12:22 (This post was last modified: Dec 31, 2013 12:42 by rich2005.)
Post: #4
RE: Quick mask selection issue...
You have the answer to posting an xcf file, image hosting sites such as imgur will only accept the common formats, jpg, png.

Back to quick mask, a thousand words and you might not be any wiser.
So a quick video that hopefully reminds you how a quick mask works. Not an epic, 3.5 mins.

http://www.youtube.com/watch?v=1trmjV-eKQo&hd=1

edit: adding a file. use the full editor, not quick edit

[Image: m1ZHLje.jpg]
1. choose (browse) for the file, could be an image or a zip or something else
2. add the file (attachment)
3. wait for it to be added. if nothing happens then the file is too large/wrong format.
4. You might want to insert it into the post, depends on what it is.
then post or update

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Dec 31, 2013, 12:45
Post: #5
RE: Quick mask selection issue...
How did that happen?!? You're watching me fumble around like an idiot real time? Is this going to be on YouTube? If it goes viral, who gets the revenue from the ads?
Find all posts by this user
Quote this message in a reply
Dec 31, 2013, 12:46
Post: #6
RE: Quick mask selection issue...
I figured out the quick mask thing, it was to reverse fg bg. Works great now. Thanks.
Find all posts by this user
Quote this message in a reply
Dec 31, 2013, 12:51
Post: #7
RE: Quick mask selection issue...
It was that tut that did it, by the way. That one little thing, foreground color. So obvious, how could I miss that. DUH!
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Free Select Tool Issue! hammsman 1 81 Dec 9, 2018 09:00
Last Post: paynekj
  Selection Tool Glitch DavidCoy 2 485 Jul 5, 2018 21:34
Last Post: paynekj
  Gimp 2.8.22 in Windows 10: Filename issue Mona Eberhardt 3 523 Jan 28, 2018 21:16
Last Post: ythgilb
  Issue viewing GIMP-modified picture JuniorPear 1 743 Jul 6, 2017 05:03
Last Post: ythgilb
  Image Quality Degradation Issue dedoubleu 2 656 Jun 7, 2017 06:37
Last Post: ythgilb

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS