Post Reply 

Querying plugins on startup

Jul 4, 2013, 22:07 (This post was last modified: Jul 4, 2013 22:31 by attackofopportunity.)
Post: #1
Querying plugins on startup
Edit: Ah, I see this is a known bug in the 32 bit version:
http://www.gimpusers.com/forums/gimp-use...ry-startup

Original post:

The 2.8.4 (MS Windows) version didn't query plugins every startup, shortening load time TREMENDOUSLY. I noticed that 2.8.6 does query plugins, slowing things to a crawl again.

Was this a bug in 2.8.4, or did we lose an improvement going to 2.8.6?

If the plugin query is needed, is there something that could be done to speed it along or improve how it's done?

- Could the plugins that come bundled with the program be whitelisted, leaving only new plugins to be queried?
or
- Could it be turned into a user-initiated action?
or
- Could it be turned into a background task performed after load?
Find all posts by this user
Quote this message in a reply
Jul 6, 2013, 17:52
Post: #2
RE: Querying plugins on startup
(Jul 4, 2013 22:07)attackofopportunity Wrote:  Edit: Ah, I see this is a known bug in the 32 bit version:
http://www.gimpusers.com/forums/gimp-use...ry-startup

Original post:

The 2.8.4 (MS Windows) version didn't query plugins every startup, shortening load time TREMENDOUSLY. I noticed that 2.8.6 does query plugins, slowing things to a crawl again.

Was this a bug in 2.8.4, or did we lose an improvement going to 2.8.6?

Every program needs to load their tools so they work properly. I have the new 2.8.6, upgraded straight from an earlier version(2.6)
If the operation of the plugins was the same without query, then maybe we did lose an enhancement somewhere in the process of them upgrading it.

(Jul 4, 2013 22:07)attackofopportunity Wrote:  - Could it be turned into a background task performed after load?

I like that idea! With 2.8.6 mine only takes about 10-15 seconds to load, not really slow.

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Question Gimp 2.8 Startup Keeps Not Responding lolly325 31 28,131 Jun 5, 2017 15:46
Last Post: blighty
  adding 10,000 fonts to Gimp user folder causes Gimp startup to slow my computer moltres_rider 6 1,258 Sep 28, 2014 21:40
Last Post: iForStyle007
  Gimp 2.8 crashes during startup huntrramo 7 2,364 Aug 5, 2014 15:09
Last Post: LadyGalasya
  Plugins/script help needed stigzler 1 474 Jul 5, 2014 15:20
Last Post: stigzler
  Newly installed GIMP crashes on startup Kevin L 1 599 May 12, 2014 19:38
Last Post: Kevin L

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS