Post Reply 

Pen tablet position incorrect.

May 14, 2011, 20:08 (This post was last modified: May 14, 2011 20:08 by TheAngryMongoose.)
Post: #1
Pen tablet position incorrect.
Using:
TB-5300 Slimline Design Tablet
Windows 7 (32 and 64 bit, problem occurs on both)

The problem I am having is that the X-coordinate for my pen tablet is incorrect. The paint brush appears to the left of the screen and doesn't move as far left/right as my pen does. By moving the position of the drawing area I have found that pressure works correctly. Strangely, the position of the mouse when being controlled by the pen tablet is correct, it's just the paint brush which is wrong.

I can correct this problem by uninstalling the pen tablets drivers, but then the pressure sensitivity stops working.

This problem fixed itself for about a few days, but then came back without anything apparently having changed in that time.

It's occuring in both a 32 and 64 bit version of windows.

The problem is identical to the one in this video (but the solution in the comments there doesn't work for me)
http://www.youtube.com/watch?v=b1Nx_L9x9dw

Any help would be appreciated. Thanks Smile
Find all posts by this user
Quote this message in a reply
Jan 3, 2012, 09:31
Post: #2
RE: Pen tablet position incorrect.
Exactly the same problem here. Same hardware and os. Other programs get it right.

Is it somehow possible to change the resolution for each axis (axes) in devicerc or some other config file?

It is kinda hard to recognize what is going on so I think most people will report this as tablet not working or pressure not working.
Find all posts by this user
Quote this message in a reply
Jan 5, 2012, 09:07
Post: #3
RE: Pen tablet position incorrect.
I'm having this problem, too. It happened a few months ago and... well, I just stopped using Gimpfor a month. When I began again there were no problems, but tonight it's back to this misplaced cursor issue. The worst part of it is, when I think I can settle with the position being an inch away from the lines it draws, suddenly it jumps around to another position. It also randomly forces my brush color to change to black. Sensitivity is fine, though.

I've uninstalled and reinstalled Gimp and my tablet driver, changed all the settings for the tablet itself and its settings in Gimp, and reset everything to default. Nothing fixes the problem. Help?
Find all posts by this user
Quote this message in a reply
Jan 5, 2012, 11:17 (This post was last modified: Jan 5, 2012 11:18 by ofnuts.)
Post: #4
RE: Pen tablet position incorrect.
(Jan 5, 2012 09:07)confusedandlost Wrote:  I'm having this problem, too. It happened a few months ago and... well, I just stopped using Gimpfor a month. When I began again there were no problems, but tonight it's back to this misplaced cursor issue. The worst part of it is, when I think I can settle with the position being an inch away from the lines it draws, suddenly it jumps around to another position. It also randomly forces my brush color to change to black. Sensitivity is fine, though.

I've uninstalled and reinstalled Gimp and my tablet driver, changed all the settings for the tablet itself and its settings in Gimp, and reset everything to default. Nothing fixes the problem. Help?
The color change is a bit surprising... I can't think of any use case in the UI where the coloor changes implicitly on the same pointing device. However, as far as I know all these settings are actually per pointing device, so an explanation is that the pointing device changes (tablet to pseudo-mouse and back) and that the color associated to each is different (this would be easy to test, one color is associated with a pressure-capable device and the other is not).

On the whole there is little point in {un/re}installing Gimp. All the info is in your Gimp profile. Better erase/rename the profile to get a new one created (IIRC you can even erase/rename individual files, such as "devicerc").

Speaking of the "devicerc" file can you post yours? (include in zip if needed)

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jan 8, 2012, 10:24
Post: #5
RE: Pen tablet position incorrect.
(Jan 5, 2012 11:17)ofnuts Wrote:  
(Jan 5, 2012 09:07)confusedandlost Wrote:  I'm having this problem, too. It happened a few months ago and... well, I just stopped using Gimpfor a month. When I began again there were no problems, but tonight it's back to this misplaced cursor issue. The worst part of it is, when I think I can settle with the position being an inch away from the lines it draws, suddenly it jumps around to another position. It also randomly forces my brush color to change to black. Sensitivity is fine, though.

I've uninstalled and reinstalled Gimp and my tablet driver, changed all the settings for the tablet itself and its settings in Gimp, and reset everything to default. Nothing fixes the problem. Help?
The color change is a bit surprising... I can't think of any use case in the UI where the coloor changes implicitly on the same pointing device. However, as far as I know all these settings are actually per pointing device, so an explanation is that the pointing device changes (tablet to pseudo-mouse and back) and that the color associated to each is different (this would be easy to test, one color is associated with a pressure-capable device and the other is not).

On the whole there is little point in {un/re}installing Gimp. All the info is in your Gimp profile. Better erase/rename the profile to get a new one created (IIRC you can even erase/rename individual files, such as "devicerc").

Speaking of the "devicerc" file can you post yours? (include in zip if needed)

Pointer dynamics attached to color?

I think this is another issue, though. Dodgy


here is my devicerc:

# GIMP devicerc

(GimpDeviceInfo "Core Pointer"
(tool "gimp-paintbrush-tool")
(paint-info "gimp-paintbrush")
(brush "Circle (11)")
(pattern "Pine")
(gradient "VG nach HG (RGB)")
(mode screen)
(axes 2 x y)
(keys 0))
(GimpDeviceInfo "Tablet, Port:HID, Dim:5500x4000 Model:84 3 Buttons Stylus Pen (Pressure)"
(tool "gimp-pencil-tool")
(paint-info "gimp-pencil")
(brush "Circle (11)")
(pattern "Pine")
(gradient "VG nach HG (RGB)")
(mode screen)
(axes 3 x y pressure)
(keys 0))

# end of devicerc
Find all posts by this user
Quote this message in a reply
Jan 8, 2012, 12:45
Post: #6
RE: Pen tablet position incorrect.
No, I'm not talking about brush dynamics. I'm talking about a device change on the fly (cause by Windows/Gimp losing track or your stylus) which translates into a color change because the color is associated to the device and you have a different color on the "Core pointer" and the tablet.

devicerc looks ok...

Is the tablet working OK (pressure included) with other software?

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 26, 2012, 19:28
Post: #7
RE: Pen tablet position incorrect.
I encountered all of the problems mentioned above. The colour pointer changes to black, the touch sensitivity gone, and most annoying the incorrect coordinates issue.

I would bite my own butt if I could because I don't have any old version of the Gimp any more I could install. They all worked like cream for me (apart from tiny issues like having to start the Gimp tapping the shortcut with the pen, not the mouse or it wouldn't be recognized and similar manageable things.)

I have a Bamboo tablet, and Windows7 64 bit.

Please tell me there is any fix planned for that, or how to fix the issue myself. Things that did not work include de-installing the tablet and the gimp and reinstalling the Gimp and the drivers in various orders.

The weird thing about it is that when I first installed the latest Gimp, it worked fine. I was really happy with it; it was awesome. First the various brushes dynamics like changing size and angle wouldn't work, then the opacity was gone, no matter the settings, and finally there was this resizing problem.

No matter how often I de- and reinstalled the Gimp or the drivers, I couldn't get any of those issues to disappear again.

Thanks in advance for any help -- I would be terribly grateful.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  New Surface Pro and Detecting Pen/Pressure Sensitivity aheroindisguise 1 466 Jul 7, 2017 05:19
Last Post: ythgilb
  Pressure sensitivity pen left click shortcut dogjake10 1 242 Jun 25, 2017 22:34
Last Post: ofnuts
  xp-pen artist display 10.1 hd Richard1967 1 267 Jun 5, 2017 16:58
Last Post: blighty
  Tablet Problems with Gimp 2.8 riveter 4 761 Oct 1, 2014 11:23
Last Post: riveter
  2 problems with Intuos tablet and GIMP (Slow input/lag and Tablet Eraser not working) Xarizzar 3 1,027 Sep 21, 2014 16:10
Last Post: Xarizzar

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS