Post Reply 

Opening files.

Aug 27, 2012, 09:31
Post: #1
Opening files.
Couple of problems cropped up so far.

First of Gimp seems to be throwing a real hissy fit when ever I try to open a saved image. I click on open, the open image window appears and the cursor arrow and busy icon flash on and off like a thing possessed, also the create image message flashes or says image out of date - if I click on it to update the image Gimp can lock up completely. This doesn't stop me from opening any of the files but it's a tad distracting. Any fix for this?

I made an inquiry and was told that there should be a British language option in preference. Alas it's not there only a version that says "en-us." Is it possible to download and add the GB version or would I need to reinstall 2.8?

Cheers.

[Image: DjIVv.png?1]

My DeviantArt gallery
http://caz747.deviantart.com/
Find all posts by this user
Quote this message in a reply
Aug 27, 2012, 10:37
Post: #2
RE: Opening files.
Quote:I made an inquiry and was told that there should be a British language option in preference. Alas it's not there only a version that says "en-us." Is it possible to download and add the GB version or would I need to reinstall 2.8?

In your gimp 'locales' folder you should have something like this.
[Image: js74n.jpg]

The whole thing runs to 70 MB so if you are using a portable version maybe a lot of the localization has been left out & you will have to search a bit in the 'portable' installation for the above folder.

If you need them, just the en_xxxx files
https://rapidshare.com/files/964440240/locale.zip (0.6 MB)

Flashing dialogs etc. Don't know. Long shot - maybe a missing system font.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Aug 27, 2012, 17:21
Post: #3
RE: Opening files.
Quote:In your gimp 'locales' folder you should have something like this.

Yeah, I've got the en-GB file in the locale folder. Do I need to move it to different folder?
The only option I've got when I open the the preference window is for en-US.

Just noticed that even though I'd removed 2.6 the user folder for it was still there. I deleted it, not permanent, just to the recycle bin, and now the flashing cursors appear to have calmed down. Not completely stopped but calmer than it was. I was wondering if it might be because all the files I've made with Gimp was for 2.6. Could 2.8 be having trouble trying to retrieve them from an old folder? Just a stab in the dark really.

Thanks for the info, Rich.

[Image: DjIVv.png?1]

My DeviantArt gallery
http://caz747.deviantart.com/
Find all posts by this user
Quote this message in a reply
Aug 27, 2012, 20:07
Post: #4
RE: Opening files.
Quote:The only option I've got when I open the the preference window is for en-US.
That only happens here with a portable version.

I do have a 'real' machine running XPsp3 with PortableGimp 2.8 installed

Looking at this, I found the same as you, the only language option is American English.

Digging a bit deeper there was no 'locale' folder, so I copied the 'locale + en_xxx' sub-folders to ....\App\gimp\share.

The language options show in the interface preferences.
To *make sure* I added a (language "en_GB") line to the local gimprc file in
....\App\DefaultData\.gimp

Screenshots of those 3 steps. http://i.imgur.com/L0sPC.jpg

The menus are now British spelling. Check that your locale folder is in the correct place.
Still don't know about your opening files problem, it works ok here, although the set up is a regular gimp 2.6 + this 2.8 portable which might make a difference.

Quote:Just noticed that even though I'd removed 2.6 the user folder for it was still there. I deleted it, not permanent, just to the recycle bin
No need to delete, just rename it maybe gimp_old

Quote:I was wondering if it might be because all the files I've made with Gimp was for 2.6
AFAIK the files are compatible.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Aug 28, 2012, 18:10
Post: #5
RE: Opening files.
   

I've had a good look around and my set-up looks quite different to your one. There is a locale folder but no app\gimp\share. I tried copy the locale folder to my gimp user folder but nothing came of that. Also I managed to locate the Gimprc file but there is no mention of the...
I just had another look and the font path line is different in my copy of the file but I found the line that says data\fonts\language en-us. So I changed it to GB and Gimp is now using the Queen's English. It still insists that the only language available is US English in the preferences window, buy what the hell it works anyway.

Thanks for all your help. I really wouldn't be able to do any of this stuff if it wasn't for the help people around here give me. Cheers.

[Image: DjIVv.png?1]

My DeviantArt gallery
http://caz747.deviantart.com/
Find all posts by this user
Quote this message in a reply
Aug 7, 2013, 21:57
Post: #6
RE: Opening files.
Hey I thought, I'd give this message a bump.

I tried searching around for the 'File -> open...' flickering bug that I have experienced myself.
The thumbnails for the images flicker like crazy and the mouse pointer also flickers from hourglass to pointer continuously.

I have found a way to stop this happening, so I thought put it forward here in order to maybe shed a bit more light on this bug...

1. First open a folder that has a handful of images via 'File -> Open...'

2. Note the sizes of the images, say for instance you have fives images:
image1.jpg 125 KB
image2.bmp 230 KB
image3.png 500 KB
image4.jpg 700 KB
image5.jpg 1.2 MB

3. Go to 'Edit -> Preferences' to open the preferences dialog;
Select 'Environment'; Look for the section under the heading 'Image Thumbnails', there is an option to set 'Maximum filesize for thumbnailing:'.

4. Set 'Maximum filesize for thumbnailing:' to some value that's between the size of the biggest and smallest file in your image folder.
In this example, you would set 'Maximum filesize for thumbnailing:' to say, 300 KB.

5. Now go into 'File -> Open...' and if your system is somewhat like mine, when you highlight the files that are less in size than what you have set for the 'Maximum filesize for thumbnailing', they should flicker along with the mouse pointer.
Images that exceed the 'Maximum filesize for thumbnailing', should look fine and cause no flicker.


I am only posting this, to highlight the flickering problem when opening images, the default 'Maximum filesize for thumbnailing:' is set to be 4 MB, and so I had this problem with almost all my images.
An easy and obvious fix is to set the 'Maximum filesize for thumbnailing:' to something really low, 8 KB or so.

I am a new Gimp user and today upgraded from 2.8.4 to 2.8.6. I had the same problem with 2.8.4 and hoped the upgrade would have maybe resolved it.

The flickering doesn't stop you from opening files, but it just looks sloppy.
I am planning to use gimp to develop website front end prototypes for future clients. It wouldn't look professional at all to have flickering going on while trying to pitch sales.
Is this a purely cosmetic bug? is there something more to it?
I also notice that under the thumbnail previews there is written "Preview out of date".
Any help much appreciated. Thanks.

My system specs:
Windows XP pro SP-3
nVidia GeForce 9300M GS
Intel Core2 duo
(I don't know if anything else is relevant but would be happy to provide more details.)
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Opening a 300dpi JPG changes to 72ppi? Ilpoxi 1 121 Apr 11, 2018 13:24
Last Post: paynekj
  Sorting out old .xcf files Yumi 1 200 Feb 12, 2018 14:36
Last Post: paynekj
  GiMP 2.8.10 freezes on 'Opening '[filename]' Rasha 0 211 Jan 24, 2018 00:00
Last Post: Rasha
  Gimp Crashes when: Opening A File, Creating A New File, Saving The File and exporting tomayopan 2 817 Sep 1, 2014 21:34
Last Post: tomayopan
  Local help files 2.8.14 caz 5 605 Aug 30, 2014 16:59
Last Post: caz

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS