Post Reply 

Need to submit bug report, but can't give good description

May 14, 2014, 07:22 (This post was last modified: May 14, 2014 18:49 by MurphysLawIncarnate.)
Post: #1
Need to submit bug report, but can't give good description
I really need to submit a bug report, but I can't really give much description or details.

Persistent random crashes on Linux (Debian/Ubuntu/Mint etc) across multiple physical computers and virtual machines (across multiple visualization programs) running 2.8.4 (at oldest?) through 2.8.10. I held off until I could actually describe what the ----- is going on... but I can't. I can't take this anymore either, GIMP is effectively unusable but I really want/need/like some of it's features, unfortunately.

I can, without fail, replicate the crash within 5 seconds to 15 minutes of GIMP booting up. I can't, however, give a description as to what the ----- is going on. I take my tablet, press the pen down, move it, BOOM memory corruption error logs. That's it. I've checked into the IRC on rare occasion over a year on this... and the most specific idea I've gotten is that it's a corrupt custom brush (which I've already disproven as it crashes with default brushes although I want to say it crashes faster with some custom brushes) or that it's some kind of Heisenbug (because booting up GIMP with gdb logging seems to affect the stability). Hell, I want to say compulsively saving every two seconds also affects the stability, but everything at this point is just a perceived placebo to what are essentially completely random crashes and I have no real method to pin this down.

I've tried just messing around to produce these crashes, and while I can it can take anywhere from seconds to HOURS. Anyone have some better ideas on how to narrow down the exact cause of these crashes? I've got like a hundred nigh-identical error logs too. I could just upload like a dozen of those. Really just want to absolve myself of responsibility for this so I can get on with learning a more stable program to use.

edit: Whoops, filter didn't catch everything. Fixed.
Find all posts by this user
Quote this message in a reply
May 14, 2014, 07:37 (This post was last modified: May 14, 2014 07:38 by rich2005.)
Post: #2
RE: Need to submit bug report, but can't give good description
1. Watch your language.
2. This is the wrong place to report a Gimp bug. No developers here. Go to https://bugzilla.gnome.org
3. It sound more like an OS problem, maybe a conflict in some of the packages. Debian/Ubuntu/Mint are really all forms of the same (debian) go to one of their forums and see if anyone has the same problem. Sounds like a memory leak.
4. I use PClinuxOS / Gimp 2.8.10 and never had a problem.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
May 14, 2014, 19:04 (This post was last modified: May 14, 2014 19:08 by MurphysLawIncarnate.)
Post: #3
RE: Need to submit bug report, but can't give good description
I know this isn't a place to submit bug reports.
-I can't just submit a bug description of "Completely random, good luck!"
-I need a reliable, replicable means of producing the crash
-I can't sit in the IRC 24/7, with 4+ hours between replies that aren't saved

If no one has any other ideas as to the cause, I can just submit with no real instructions to replicate it. But unreplicable bugs never get fixed, hence I'm fishing around for ideas.

I've spoken with developers, yes, complete with crash logs and we swapped some ideas as to the cause. Memory leakage in Debian hasn't even been suggested, but I'm using some of the most popular distributions with no modifications post-install... and there's no memory leakage reports I see affecting GIMP in this particular manner.

I can give PClinuxOS a shot, sure. I just kept moving upstream on Debian previously, hoping something was patched or changed. Since Debian is one of the only consistent factors, yeah I can move on to that community to fish for ideas too.
Find all posts by this user
Quote this message in a reply
May 14, 2014, 22:40
Post: #4
RE: Need to submit bug report, but can't give good description
Wacom Bamboo as well. Older(?) MTE-450 model. Should have had that in the OP, sorry.

I have Krita, though it isn't as fully featured. Guess I'll go back to doing some figure studies to test it.

I'll get xev for event dumps from the tablet, and I'm setting up a PCLinuxOS machine to test on as well. I've already got lots of gdb logs (all the memory corruption errors), and then I'll have some logs from the tablet too... any other debuggers I should grab for logs?
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Exclamation Bug: Changing text size by one changes it by thousands Puntherline 1 315 Jun 16, 2018 18:25
Last Post: paynekj
Exclamation Bug ~ Gimp crashes when I do... well... anyhing tilts 1 278 Jun 11, 2018 16:28
Last Post: paynekj
  SPAM - How Important Is It to Have a Good Mailing List For Direct Marketing Campaign? TaslimaRahman627 0 271 Jan 10, 2018 04:19
Last Post: TaslimaRahman627
  Layerfx bug? caz 3 630 Sep 11, 2014 16:59
Last Post: caz
  I found a bug with moving the layers and docable dialogs. How do I fix it? CopperZirconium 2 618 Jun 21, 2014 17:21
Last Post: CopperZirconium

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS