Post Reply 

Issue with Gimp 2.8 on OSX

May 11, 2012, 07:32
Post: #1
Issue with Gimp 2.8 on OSX
First some background. I have a mac book pro that I have previously installed gimp 2.6.12 through Macports.
After uninstalling gimp and macports I installed the Gimp 2.8 package for OSX.

I found that as soon as I tried using the Text tool mac X11 2.3.6 crashed with a SIGSEGV error.

I tried uninstalling and reinstalling both Gimp and X11 to no avail.

Next I installed Xquarttz which resolved the issue.

My guess is that the problem may be caused by having Macports previously installed
but I am not techy enough to know this for sure. Perhaps it changes some settings that are not removed when uninstalling.

Hope this helps someone.

Pete
Find all posts by this user
Quote this message in a reply
May 11, 2012, 20:42 (This post was last modified: May 11, 2012 20:43 by PaulSlocum.)
Post: #2
RE: Issue with Gimp 2.8 on OSX
Yes, 2.8 is faster and less buggy for me after installing XQuartz too (on Lion)
Find all posts by this user
Quote this message in a reply
May 19, 2012, 14:21 (This post was last modified: May 19, 2012 14:34 by FloridaJo.)
Post: #3
RE: Issue with Gimp 2.8 on OSX
(May 11, 2012 20:42)PaulSlocum Wrote:  Yes, 2.8 is faster and less buggy for me after installing XQuartz too (on Lion)

Still crashing for me with Text insertion.
iMac Snow Leopard.
XQuartz (2/12 build)
Gimp 2.8.0p1


Process: X11.bin [9714]
Path: /Applications/Utilities/X11.app/Contents/MacOS/X11.bin
Identifier: org.x.X11
Version: 2.3.6 (2.3.6)
Build Info: X11server-850300~2
Code Type: X86-64 (Native)
Parent Process: Xquartz [9712]

Date/Time: 2012-05-19 10:16:49.086 -0400
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 973319 sec
Crashes Since Last Report: 1
Per-App Interval Since Last Report: 94945 sec
Per-App Crashes Since Last Report: 1
Anonymous UUID: B79FD624-5AE3-4B1F-BC67-B19C864FA9F2
Find all posts by this user
Quote this message in a reply
May 19, 2012, 14:33
Post: #4
RE: Issue with Gimp 2.8 on OSX
Okay, had to restart computer whereby XQuartz installed an update to whereby Text now works fine.
[Solved]
Find all posts by this user
Quote this message in a reply
May 23, 2012, 20:17
Post: #5
RE: Issue with Gimp 2.8 on OSX
XQuartz got GIMP 2.8 working for me on my Leopard.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Eraser function on Gimp 2.10 halligant 1 91 Jun 23, 2018 15:39
Last Post: paynekj
Exclamation Gimp 2.10.2 boots up with a lot of errors but still works Christophil 1 152 Jun 19, 2018 09:21
Last Post: paynekj
  Gradient fill doesn't work the same in Gimp 2.10.2? Sorceress21 1 153 Jun 13, 2018 21:58
Last Post: paynekj
  Gimp vs photoshop elements Edvin Persson 1 148 Jun 12, 2018 21:39
Last Post: paynekj
Exclamation Bug ~ Gimp crashes when I do... well... anyhing tilts 1 132 Jun 11, 2018 16:28
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS