Post Reply 

How come themes aren't working properly?

May 28, 2014, 07:18 (This post was last modified: May 28, 2014 07:21 by magatsu.)
Post: #1
How come themes aren't working properly?
I tried adding themes to Gimp, and it's working properly, but I keep having a problem and its irking my nerves.
I screened this image off a website that offers themes.
   
The menu bar is supposed to look like this with the theme, but when I set this as my theme, it ends up looking like this
   
I tried using other themes too, but the problem persists. Is there anything I can do so that the menu bar looks like the first image?
Find all posts by this user
Quote this message in a reply
May 28, 2014, 07:58 (This post was last modified: May 28, 2014 07:59 by rich2005.)
Post: #2
RE: How come themes aren't working properly?
Windoze OS ?
Did you get the themes from here http://thegimp.ca/category/gimp-themes/

One problem is, many (most) of those are only partial, they build on what is already there. Sometimes you can 'tweak' them and substitute your own colour/font values.
Another problem is using a Gimp 2.6 theme with Gimp 2.8. Not a good idea.

First thing to try, is change your over-all Windows theme (maybe lose the aero temporarily) and see if the new Gimp theme works. Then you have narrowed the problem down a little.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
May 28, 2014, 08:17
Post: #3
RE: How come themes aren't working properly?
Which theme is it you are having problems with?

As Rich says, I've found a few that don't work completely on Windows but not normally on the menubar.

Kevin
Find all posts by this user
Quote this message in a reply
May 28, 2014, 08:37 (This post was last modified: May 28, 2014 08:40 by magatsu.)
Post: #4
RE: How come themes aren't working properly?
(May 28, 2014 07:58)rich2005 Wrote:  Windoze OS ?
Did you get the themes from here http://thegimp.ca/category/gimp-themes/

One problem is, many (most) of those are only partial, they build on what is already there. Sometimes you can 'tweak' them and substitute your own colour/font values.
Another problem is using a Gimp 2.6 theme with Gimp 2.8. Not a good idea.

First thing to try, is change your over-all Windows theme (maybe lose the aero temporarily) and see if the new Gimp theme works. Then you have narrowed the problem down a little.

My OS is windows 7, sorry I forgot to mention. I tried running the program with aero disabled, yet it still kept happening. Even with themes compatible with 2.8, I still have the issue.

EDIT: Also, yes, that's where I got the themes from.
Find all posts by this user
Quote this message in a reply
May 28, 2014, 08:39
Post: #5
RE: How come themes aren't working properly?
(May 28, 2014 08:17)paynekj Wrote:  Which theme is it you are having problems with?

As Rich says, I've found a few that don't work completely on Windows but not normally on the menubar.

Kevin

Well I've tried a few themes, the one in the screenshot is ClearlooksDarkOrange. Others I've tried are Industrial Charcoal Theme and T-ish Brushed Metal Aqua Theme.
Find all posts by this user
Quote this message in a reply
May 28, 2014, 09:09 (This post was last modified: May 28, 2014 09:10 by rich2005.)
Post: #6
RE: How come themes aren't working properly?
Those three work ok here Gimp 2.8.10 & Win7 32 bit VM with default settings

[Image: Y2pLcFz.jpg]

Have you/can you delve into the 'personalize' settings and see if your menu bar colour has been 'adjusted'

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
May 28, 2014, 09:30 (This post was last modified: May 28, 2014 09:31 by paynekj.)
Post: #7
RE: How come themes aren't working properly?
I tried the ClearlooksDarkOrange and it sort of works in GIMP 2.8.10. The menu items aren't being highlighted in orange as they are in the screenshot.

In GIMP 2.6.7 the menu bar isn't styled at all.

It is using the GTK Clearlooks rendering engine in places and I'm not sure if that's included with GIMP on Windows.

Kevin

GIMP 2.6.7 showing the GIMP 2.8.10 styling
   
Find all posts by this user
Quote this message in a reply
May 28, 2014, 16:36
Post: #8
RE: How come themes aren't working properly?
I know I said I tried this without aero and for some reason the menu bar was still affected, but I tried it again and I'm not having the problem anymore. The menu bar is unchanged, so I guess I'll just have to work without it.

A few of the programs I use often can't work with it on, so it's best if I leave it off now too. Thanks for your help.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  eraser not working njoe 3 445 Oct 10, 2014 03:55
Last Post: njoe
  GIMP 2.8 Eyedropper Color Selection Tool Not Working? Upgraded App is Slow?? tootallll 14 9,959 Oct 9, 2014 18:39
Last Post: Graphicman2014
  Custom fonts no longer working TheBorzoi 4 434 Oct 2, 2014 23:45
Last Post: TheBorzoi
  2 problems with Intuos tablet and GIMP (Slow input/lag and Tablet Eraser not working) Xarizzar 3 1,044 Sep 21, 2014 16:10
Last Post: Xarizzar
  GIMP 2.8 on Mac // Huion h610 Pro pressure sensitivity not working! XxMiakatxX 1 368 Sep 19, 2014 23:47
Last Post: iForStyle007

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS