Post Reply 

Gimp will not run (Mavericks)

Feb 15, 2014, 02:45 (This post was last modified: Feb 26, 2014 00:26 by ofnuts.)
Post: #1
Question Gimp will not run (Mavericks)
Hello, I'm operating on 10.9.1 Mavericks and I've been having a difficult time trying to run Gimp. Here's my problem:

I've been attempting to run many different versions of Gimp for the past few hours from many different sources but to no avail. The version I downloaded from download page at http://www.gimp.org/downloads/ will stop responding and freeze when loading fonts, then precede to disappear. The other versions I found would start extensions then disappear as well.

Any and all help is greatly appreciated, getting this to work has become very frustrating.
Find all posts by this user
Quote this message in a reply
Feb 15, 2014, 04:23 (This post was last modified: Feb 15, 2014 04:23 by fluffybunny2.)
Post: #2
RE: Gimp will not run
(Feb 15, 2014 02:45)Gunshed Wrote:  Hello, I'm operating on 10.9.1 Mavericks and I've been having a difficult time trying to run Gimp. Here's my problem:

I've been attempting to run many different versions of Gimp for the past few hours from many different sources but to no avail. The version I downloaded from download page at http://www.gimp.org/downloads/ will stop responding and freeze when loading fonts, then precede to disappear. The other versions I found would start extensions then disappear as well.

Any and all help is greatly appreciated, getting this to work has become very frustrating.
Hi Gunshed,
Have you tried the Mac versions from either here or here?
Find all posts by this user
Quote this message in a reply
Feb 16, 2014, 01:07
Post: #3
RE: Gimp will not run
The first one was tried prior to this post and failed.

The second one you offered I tried now which also failed. This one actually drew a crap ton of ram and lagged my computer quite a bit before being flagged "Application Not Responding"

All of the versions and different downloads I have tried were written for mac I'm pretty sure.
Find all posts by this user
Quote this message in a reply
Feb 16, 2014, 01:09
Post: #4
RE: Gimp will not run
Check out this screen shot of my Activity Monitor when trying to run the second one


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Feb 16, 2014, 08:59
Post: #5
RE: Gimp will not run
(Feb 16, 2014 01:07)Gunshed Wrote:  The first one was tried prior to this post and failed.

The second one you offered I tried now which also failed. This one actually drew a crap ton of ram and lagged my computer quite a bit before being flagged "Application Not Responding"

All of the versions and different downloads I have tried were written for mac I'm pretty sure.
Unfortunately I am not a Mac user.
Either wait for someone with more Mac knowledge to answer this, or post a message to the compilers of those Mac builds and ask for their advice.
I have had personal experience with Partha's Windows builds and he is very responsive and provides reputable builds including the Mac ones.
On another forum I have seen Mac users ask him questions and he was always quick with an answer.
My advice, fire off an email to him and see what happens... Sad
Find all posts by this user
Quote this message in a reply
Feb 16, 2014, 11:12
Post: #6
RE: Gimp will not run
(Feb 15, 2014 02:45)Gunshed Wrote:  Hello, I'm operating on 10.9.1 Mavericks and I've been having a difficult time trying to run Gimp. Here's my problem:

I've been attempting to run many different versions of Gimp for the past few hours from many different sources but to no avail. The version I downloaded from download page at http://www.gimp.org/downloads/ will stop responding and freeze when loading fonts, then precede to disappear. The other versions I found would start extensions then disappear as well.

Any and all help is greatly appreciated, getting this to work has become very frustrating.

Not sure it's your problem but the first time it is run, Gimp (or the GTK library it uses) creates its own font configuration, and this can take a very long time (15-20 minutes in some cases). So the fix is just to be patient. This of course happens only once and then Gimp starts rather quickly (unless overloaded with hundreds of patterns/brushes).

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 16, 2014, 22:37
Post: #7
RE: Gimp will not run
I let GIMP run for one hour this time and it still did nothing but waste my time.
After "Starting Extensions" is complete the loading menu disappears and nothing happens at all. The app remains open but clicking on the GIMP icon does nothing.[/align]


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Feb 17, 2014, 04:20
Post: #8
RE: Gimp will not run
Hmm... Gunshed, if you're still willing to get the program to work,

could it be an added plug-in (python or other) in an incorrect folder?

When was the last time Gimp was running normally for you?
What did you add, change or update to Gimp or your computer before Gimp started acting up?

Last, can you list all the sources of gimp(sites / links) you tried? (title the version on the site if possible) , then I we can see which one you missed if any.
.

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 17, 2014, 08:06
Post: #9
RE: Gimp will not run
(Feb 16, 2014 22:37)Gunshed Wrote:  I let GIMP run for one hour this time and it still did nothing but waste my time.
After "Starting Extensions" is complete the loading menu disappears and nothing happens at all. The app remains open but clicking on the GIMP icon does nothing.[/align]

1) erase your Gimp profile and restart Gimp. This often fixes things, you may get lucky.

2) If this isn't enough, start Gimp in a terminal with the "--verbose" parameter (note the double dash), and copy the contents of the terminal window here.

From you latest post ("The app remains open but clicking on the GIMP icon does nothing."), it looks like you have a Gimp process started but not showing any windows. Make sure it is stopped (task manager) before you try 1) and 2) above.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 17, 2014, 20:35
Post: #10
RE: Gimp will not run
This is my first time trying to use GIMP, I have no other history with it. So it has never run normally for me
These are some of the downloads I have tried. I may have missed a few because I tried many~

All of the ones on the main page- http://www.gimp.org/downloads/
And then these-
http://gimp.en.softonic.com/mac
http://sourceforge.net/projects/gimponosx/
http://gimp.lisanet.de/Website/Download.html
http://www.oldapps.com/gimp.php?old_gimp=7656#changelog
http://www.gimpusers.com/downloads

I'm not very proficient in terminal, in fact I'm quite a noob.
Anyways, this is what I tried...

Last login: Sun Feb 16 16:15:03 on ttys000
Thomas-Mayers-iMac-2:~ thomasmayer$ --verbose GIMP
-bash: --verbose: command not found
Thomas-Mayers-iMac-2:~ thomasmayer$ --verbose
-bash: --verbose: command not found
Thomas-Mayers-iMac-2:~ thomasmayer$

Any time I try to start a new GIMP download or rerun an existing, I make sure to end the application in task manager.
Find all posts by this user
Quote this message in a reply
Feb 17, 2014, 20:44 (This post was last modified: Feb 17, 2014 20:46 by Gunshed.)
Post: #11
RE: Gimp will not run
I also tried this in terminal. Again, I'm not fluent in this

Thomas-Mayers-iMac-2:~ thomasmayer$ ls Applications
GIMP.app Team Fortress 2.app
Thomas-Mayers-iMac-2:~ thomasmayer$ --verbose GIMP.app
-bash: --verbose: command not found
Thomas-Mayers-iMac-2:~ thomasmayer$
Find all posts by this user
Quote this message in a reply
Feb 17, 2014, 21:09
Post: #12
RE: Gimp will not run
"--verbose" is a parameter to the gimp command. Try
Code:
gimp --verbose

If you are on Mavericks you need Gimp 2.8.10 (earlier versions run, but have usability problems). Another trustable source is Partha's site: http://www.partha.com

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 01:43
Post: #13
RE: Gimp will not run
I downloaded the version from Partha's site and didn't get much progress.

This is what I tried in terminal-

Thomas-Mayers-iMac-2:~ thomasmayer$ cd Applications
Thomas-Mayers-iMac-2:Applications thomasmayer$ ls
Gimp-2.8.app Team Fortress 2.app
Thomas-Mayers-iMac-2:Applications thomasmayer$ Gimp --verbose
-bash: Gimp: command not found
Thomas-Mayers-iMac-2:Applications thomasmayer$ Gimp-2.8.app --verbose
-bash: Gimp-2.8.app: command not found
Thomas-Mayers-iMac-2:Applications thomasmayer$
Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 02:51 (This post was last modified: Feb 19, 2014 02:53 by iForStyle007.)
Post: #14
RE: Gimp will not run
Did you have mavericks 10.9.1 when you bought your computer, or did you update to it?

Also, do you get any errors have any problems running other apps/programs on your Mac?

the partha build is 64-bit, do you have a 32-bit or 64-bit OSX? (this is important, 64 won't work on 32-bit OS's)

I noticed you tried oldapps.com, from what I could see, they only have windows builds
( http://www.oldapps.com/gimp.php see left sidebar)


Please ensure you downloaded the correct operating system version of Gimp by clicking the below link

*uninstall any versions of gimp just in case before you install it:

*click the "2.8.10" one
ftp://ftp.gimp.org/pub/gimp/v2.8/osx/
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 19, 2014, 07:44
Post: #15
RE: Gimp will not run
(Feb 19, 2014 01:43)Gunshed Wrote:  I downloaded the version from Partha's site and didn't get much progress.

This is what I tried in terminal-

Thomas-Mayers-iMac-2:~ thomasmayer$ cd Applications
Thomas-Mayers-iMac-2:Applications thomasmayer$ ls
Gimp-2.8.app Team Fortress 2.app
Thomas-Mayers-iMac-2:Applications thomasmayer$ Gimp --verbose
-bash: Gimp: command not found
Thomas-Mayers-iMac-2:Applications thomasmayer$ Gimp-2.8.app --verbose
-bash: Gimp-2.8.app: command not found
Thomas-Mayers-iMac-2:Applications thomasmayer$

I don't know OSX much, but I understand it's mostly a Unix under the hood. To start a command like this from any directory in a terminal, it has to be in the "path" (the list of directories the systems searches for executable commands), and it is likely not in it since it is meant t be started by clicking on an icon. So you have to find where the executable is, make that directory your current directory ("CD" command), and then start Gimp using "./{Gimp executable file} --verbose" (dot-slash-executable-space-dash-dash-verbose).

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Gimp GUI icons missed massimobarbieri 1 160 Aug 23, 2017 17:51
Last Post: ofnuts
  why gimp in mac has bad performance mcheung63 1 152 Aug 20, 2017 10:13
Last Post: ythgilb
  Issue viewing GIMP-modified picture JuniorPear 1 255 Jul 6, 2017 05:03
Last Post: ythgilb
  GIMP Taking Too Long to Start (Fonts) Seta 2 294 Jun 20, 2017 16:10
Last Post: Seta
  Problem with pressure on gimp (huion h610) protosd3 18 5,479 Jun 8, 2017 19:20
Last Post: John Penfold

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS