Post Reply 

Gimp silly problem in Macs

Dec 14, 2013, 22:59
Post: #16
RE: Gimp silly problem in Macs
They fixed this in 2.8.10. I installed it and works fine in Mavericks. No need to disable the keybaord shortcuts any longer.

2.8.10:
http://gimp.lisanet.de/Website/Download.html
Find all posts by this user
Quote this message in a reply
Dec 17, 2013, 12:28
Post: #17
RE: Gimp silly problem in Macs
I'm having the same issue. It only started happening noticeably with Mac O/S Mavericks.
It sounds like there has been a request for more info in order to fix the problem, but ultimately whoever's going to fix it will have to verify it on a Mac anyways.
Problem occurs pretty consistently and reliably, as far as I can tell.
Find all posts by this user
Quote this message in a reply
Dec 17, 2013, 12:54
Post: #18
RE: Gimp silly problem in Macs
If you have O/S Mavericks, get the gimp build from here:

http://gimp.lisanet.de/Website/News/News.html

It resolved the problem for me without my having to disable keyboard
shortcuts..
Find all posts by this user
Quote this message in a reply
Dec 25, 2013, 19:23
Post: #19
RE: Gimp silly problem in Macs
(Oct 23, 2013 13:47)animeshsaxena Wrote:  This is an extremely beginner question, but I can't seem to get my head around it so shamelessly asking a stupid question Sad

Whenever I try to type text into a textbox in GIMP it thinks that I am using some keyboard shortcut. I checked the preferences the shortcuts for some keys are by default letters like "S" and "T"...etc. I also thought some other key like Ctrl or Alt might be pressed, but no it's some letters which are shortcuts and while typing GIMP thinks I am invoking the shortcut. This is frustrating......coz I have to type somewhere else and then copy paste. Even if I use GIMP text editor...it defaults to shortcut mode. GIMP I am sure can't be that stupid to make default shortcuts as simple letters. What can I do to resolve this?

Thanks in advance Smile

I, too, run the latest version of Gimp 2.8.2. and encounter the same problem as above. After selecting the text tool, I tried to type in "Here" and got as far as the "H." After entering "e," Gimp thinks I'm trying to toggle a keyboard shortcut. I tried circumventing the issue by typing "Here" outside the application, copying it, and pasting it into the text box field through using the "Paste" command in the "Copy" menu, but the application couldn't even paste foreign text into the text box.

As a side, I gave up on Gimp and saved the file, opened it in Seashore, and tried to add a text box - but all that resulted were a few, illegible horizontal lines that looked like remnants of a bug more than text. (I was a bit disappointed by the quality of free image editing software.) Finally came Pinta, another image editing program. This one worked much better. I opened the TIFF file I exported, clicked on the text box tool and then the image, only to be greeted by a force quit error box.

I was using Windows from 1996 to 2012, roughly 16 years, and am not familiar with (good) free software available for the Mac. If anybody could offer me any suggestions outside of the buggy latter, it would be much appreciated.

intelliquest
Find all posts by this user
Quote this message in a reply
Jan 2, 2014, 21:59
Post: #20
RE: Gimp silly problem in Macs
ofnuts

Thank you for the suggestion.
I just downloaded 2.8.10 and confirmed the issues to be resolved.

The Gimp download page had 2.8.2 as the stable working edition, and I didn't see 2.8.10 at the bottom. Thanks again!

intelliquest
Find all posts by this user
Quote this message in a reply
Jan 14, 2014, 02:45 (This post was last modified: Jan 14, 2014 02:46 by BryanKoch.)
Post: #21
RE: Gimp silly problem in Macs
I just disabled the shortcuts that are only letters, so now I can use those letters again. Didn't see a disable option, so I just kept setting each shortcut that was formerly a letter to the same combo, and disabling it in the popup menu. I will eventually DL a new build, but works for tonight. (I also just DLed Mavericks)
Find all posts by this user
Quote this message in a reply
Mar 11, 2014, 10:33
Post: #22
RE: Gimp silly problem in Macs
(Oct 24, 2013 10:09)Darthpearce Wrote:  
(Oct 24, 2013 10:00)ofnuts Wrote:  There must be a settable tweak for keyboard focus in there...

Otherwise you try the varoius windows management options in the Gimp Preferences.

Thanks - I've solved it by disabling all keyboard shortcuts.

I used Preferences-->Interface-->Remove All Keyboard Shortcuts

That worked by disabling the shortcuts
Find all posts by this user
Quote this message in a reply
Apr 5, 2014, 10:42
Post: #23
RE: Gimp silly problem in Macs
(Oct 23, 2013 13:47)animeshsaxena Wrote:  This is an extremely beginner question, but I can't seem to get my head around it so shamelessly asking a stupid question Sad

Whenever I try to type text into a textbox in GIMP it thinks that I am using some keyboard shortcut. I checked the preferences the shortcuts for some keys are by default letters like "S" and "T"...etc. I also thought some other key like Ctrl or Alt might be pressed, but no it's some letters which are shortcuts and while typing GIMP thinks I am invoking the shortcut. This is frustrating......coz I have to type somewhere else and then copy paste. Even if I use GIMP text editor...it defaults to shortcut mode. GIMP I am sure can't be that stupid to make default shortcuts as simple letters. What can I do to resolve this?

Thanks in advance Smile

Same issue for me... very frustrating
Find all posts by this user
Quote this message in a reply
Apr 29, 2014, 15:14
Post: #24
RE: Gimp silly problem in Macs
I was struggling with this issue for hours and your response helped me. Thank you.
Find all posts by this user
Quote this message in a reply
May 27, 2014, 23:46
Post: #25
RE: Gimp silly problem in Macs
I had a similar problem. Thanks for sharing your fix. It was extremely helpful!
Find all posts by this user
Quote this message in a reply
Aug 10, 2014, 21:18 (This post was last modified: Aug 10, 2014 21:20 by TheChristoph.)
Post: #26
RE: Gimp silly problem in Macs
I found the answer to my problem and the board won't let me delete my post.
Find all posts by this user
Quote this message in a reply
Dec 13, 2017, 15:53
Post: #27
RE: Gimp silly problem in Macs
Does anyone in this forum know how to create color filled letters? I am trying to create a label for the first time and want to do candy cane striping in one word and green and red filled letters in the other word.

Thanks,
Dan M
Find all posts by this user
Quote this message in a reply
Dec 13, 2017, 17:12
Post: #28
RE: Gimp silly problem in Macs
Every post in the last 7 months has been answered with the following:
.
This forum is DEAD and has been abandoned to spammers.

Folk from here have moved to
https://www.gimp-forum.net
Please ask there to have questions answered
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  How to install fonts for gimp only (not install on windows) Jacob123 1 84 Dec 7, 2018 08:58
Last Post: paynekj
  gimp tool icons leonardo 2 312 Nov 23, 2018 22:20
Last Post: paynekj
  paste Powerpoint objects to GIMP HPE007 1 250 Nov 21, 2018 21:59
Last Post: paynekj
  Gimp 2.10.8 error coyote 2 474 Nov 12, 2018 13:49
Last Post: coyote
  \Data\.gimp\backups\.goutputstream-XXXXXX Files DoughyInTheMiddle 1 400 Nov 10, 2018 10:01
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS