Post Reply 

Gimp silly problem in Macs

Oct 23, 2013, 13:47
Post: #1
Gimp silly problem in Macs
This is an extremely beginner question, but I can't seem to get my head around it so shamelessly asking a stupid question Sad

Whenever I try to type text into a textbox in GIMP it thinks that I am using some keyboard shortcut. I checked the preferences the shortcuts for some keys are by default letters like "S" and "T"...etc. I also thought some other key like Ctrl or Alt might be pressed, but no it's some letters which are shortcuts and while typing GIMP thinks I am invoking the shortcut. This is frustrating......coz I have to type somewhere else and then copy paste. Even if I use GIMP text editor...it defaults to shortcut mode. GIMP I am sure can't be that stupid to make default shortcuts as simple letters. What can I do to resolve this?

Thanks in advance Smile
Find all posts by this user
Quote this message in a reply
Oct 23, 2013, 15:32
Post: #2
RE: Gimp silly problem in Macs
If you have the focus on the input field then the letters go to the text field and aren't see as keyboard shortcuts by Gimp. The shortcuts on simple letters have been around for years and you are the first I see having a problem with that, even on OSX.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Oct 24, 2013, 09:34
Post: #3
RE: Gimp silly problem in Macs
(Oct 23, 2013 13:47)animeshsaxena Wrote:  This is an extremely beginner question, but I can't seem to get my head around it so shamelessly asking a stupid question Sad

Whenever I try to type text into a textbox in GIMP it thinks that I am using some keyboard shortcut. I checked the preferences the shortcuts for some keys are by default letters like "S" and "T"...etc. I also thought some other key like Ctrl or Alt might be pressed, but no it's some letters which are shortcuts and while typing GIMP thinks I am invoking the shortcut. This is frustrating......coz I have to type somewhere else and then copy paste. Even if I use GIMP text editor...it defaults to shortcut mode. GIMP I am sure can't be that stupid to make default shortcuts as simple letters. What can I do to resolve this?

Thanks in advance Smile

I have the same problem and I think it's because I upgraded to Mavericks (OSX 10.9) yesterday....
Find all posts by this user
Quote this message in a reply
Oct 24, 2013, 10:00 (This post was last modified: Oct 24, 2013 10:01 by ofnuts.)
Post: #4
RE: Gimp silly problem in Macs
There must be a settable tweak for keyboard focus in there...

Otherwise you try the varoius windows management options in the Gimp Preferences.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Oct 24, 2013, 10:09
Post: #5
RE: Gimp silly problem in Macs
(Oct 24, 2013 10:00)ofnuts Wrote:  There must be a settable tweak for keyboard focus in there...

Otherwise you try the varoius windows management options in the Gimp Preferences.

Thanks - I've solved it by disabling all keyboard shortcuts.

I used Preferences-->Interface-->Remove All Keyboard Shortcuts
Find all posts by this user
Quote this message in a reply
Oct 26, 2013, 06:34
Post: #6
RE: Gimp silly problem in Macs
I upgraded to 2.8.6 GIMP on mac and it fixes this problem. Thanks for all the replies Big Grin

Probably 2.8.4 had a bug
Find all posts by this user
Quote this message in a reply
Oct 28, 2013, 12:53
Post: #7
RE: Gimp silly problem in Macs
I've upgraded to 2.8.6 but the problem remains for me......
Find all posts by this user
Quote this message in a reply
Oct 28, 2013, 13:29
Post: #8
RE: Gimp silly problem in Macs
AFAIK the problem exists on all Gimp versions.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Nov 3, 2013, 03:11
Post: #9
RE: Gimp silly problem in Macs
I too have just started having problems with my MAC. And I think the key is yes I just upgraded to Mavericks which is when the problem of not being able to name anything due to keyboard issues. I'll get rid of keyboard shortcuts to see if that helps. Oh, and if it matters the only letter that shows up when I try to name my file is 'g'.
Find all posts by this user
Quote this message in a reply
Nov 3, 2013, 03:20
Post: #10
RE: Gimp silly problem in Macs
Follow-up: Not only did removing all keyboard shortcuts fix my save problem, it also sped up all functions in Gimp considerably.Exclamation
Find all posts by this user
Quote this message in a reply
Nov 3, 2013, 18:08
Post: #11
RE: Gimp silly problem in Macs
I just registered on this site to seek help with this problem. Searching did not turn up any help, which was a surprise. I seem to recall running into this problem before Mavericks and I haven't seen it on Windows or Linux.
Turning off keyboard shortcuts did the trick but it also disables the shortcuts I rely on (cut cmd+x, copy ctrl+c, paste ctrl+v) so this work around is less than adequate.
Upon further research, it looks like the Gimp team has been informed of this bug (see here) but they're requesting more information from users before taking action. Anyone proficient with gdb around here?
Find all posts by this user
Quote this message in a reply
Nov 3, 2013, 18:33
Post: #12
RE: Gimp silly problem in Macs
(Nov 3, 2013 18:08)ElegantKraken Wrote:  Turning off keyboard shortcuts did the trick but it also disables the shortcuts I rely on (cut cmd+x, copy ctrl+c, paste ctrl+v) so this work around is less than adequate.
Turning off all shortcuts works but is a bit drastic. I'm pretty sure you can keep/reinstate things like Ctrl-C/Ctrl-V (and all the other Ctrl-/Alt- ones).

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Nov 5, 2013, 11:14 (This post was last modified: Nov 5, 2013 11:19 by robpieke.)
Post: #13
RE: Gimp silly problem in Macs
(Oct 23, 2013 15:32)ofnuts Wrote:  If you have the focus on the input field then the letters go to the text field and aren't see as keyboard shortcuts by Gimp. The shortcuts on simple letters have been around for years and you are the first I see having a problem with that, even on OSX.

This is happening for me as well. I don't want to wildly point fingers, but it only seems to have started since upgrading to Mavericks.

[EDIT]

Ah, I see others have also made the link to Mavericks. I'll try to track down 2.8.6 to see if it resolves it for me as well.
Find all posts by this user
Quote this message in a reply
Nov 5, 2013, 11:22
Post: #14
RE: Gimp silly problem in Macs
2.8.6 doesn't resolve the Mavericks problem...
Find all posts by this user
Quote this message in a reply
Nov 5, 2013, 12:13
Post: #15
RE: Gimp silly problem in Macs
Nor does the just-released 2.8.8, AFAIK.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Issue viewing GIMP-modified picture JuniorPear 1 119 Jul 6, 2017 05:03
Last Post: ythgilb
  GIMP Taking Too Long to Start (Fonts) Seta 2 161 Jun 20, 2017 16:10
Last Post: Seta
  Problem with pressure on gimp (huion h610) protosd3 18 4,761 Jun 8, 2017 19:20
Last Post: John Penfold
Question Gimp 2.8 Startup Keeps Not Responding lolly325 38 21,896 Jun 5, 2017 15:46
Last Post: blighty
  GIMP 2.8 Eyedropper Color Selection Tool Not Working? Upgraded App is Slow?? tootallll 14 8,926 Oct 9, 2014 18:39
Last Post: Graphicman2014

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS