Post Reply 

GIMP saving the transparency checkerboard in image

Jan 9, 2019, 01:50 (This post was last modified: Jan 9, 2019 02:40 by SlyCooperReloadCoded.)
Post: #1
GIMP saving the transparency checkerboard in image
I've never had a problem with GIMP before, but I can't find any information about this online and it just started happening randomly.

Whenever I add transparency to a PNG (Add Alpha Channel, Fuzzy Select Tool), the exported image also includes GIMP's "transparency grid" as part of the image. Here's an example:

Original image:
https://imgur.com/a/dIR8FYU

Exported image:
https://imgur.com/a/DBG9cjr

I can't find any other examples of this on the internet. This has never happened before, and it just started happening today. I've added transparency to dozens of images just like this one and it's worked perfectly until now.

To clarify, yes - both the original and exported image are PNG. And yes - GIMP is set to RGB mode.

Edit: Through my own experimentation, I've learned that GIMP automatically applies a "transparency checkerboard" to any transparent layer I make. Imagine GIMP's pattern that represents transparency, but only every other square is transparent.
Find all posts by this user
Quote this message in a reply
Jan 9, 2019, 08:56
Post: #2
RE: GIMP saving the transparency checkerboard in image
As it says in the forum announcements, this forum is had been DEAD for a long time.

The spammers keep trying to take over.

Save yourself from them and go to https://www.gimp-forum.net instead
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Flipping an image delpi767 1 75 May 22, 2019 08:06
Last Post: paynekj
  Gimp 2.10 error opening XCF connorhawke 1 135 May 9, 2019 08:03
Last Post: paynekj
  I Support GIMP Could You Please At Least Look At This Thread Nicol Bolas 2 450 Mar 28, 2019 16:53
Last Post: Nicol Bolas
  Gimp opening file for reading Permission denied fixit7 1 337 Mar 27, 2019 14:11
Last Post: paynekj
  Gimp craashes in LM 19.1 Yumi 2 682 Mar 13, 2019 11:05
Last Post: alexsmith789

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS