Post Reply 

GIMP not opening own output

Jun 2, 2011, 08:21
Post: #1
GIMP not opening own output
I have a strange problem. GIMP 2.6.10-1 on Debian 6 does not open JPEG files recently written by itself. The program freezes and the only way out is to reboot. Older JPEG files are opened as usual, and the problem files can be opened in Digikam and Fotoxx. A sample problem file is attached.


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 09:30
Post: #2
RE: GIMP not opening own output
No such problem on my Ubuntu. I have a hard time convincing myself that it could be truly a Gimp problem. For me it looks more like a filesystem problem. What kind of FS is the file on?

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 09:54
Post: #3
RE: GIMP not opening own output
I think it's ext3. The problem has only just begun to occur, and there has been no change to the GIMP. I even re-installed it, but that did not improve matters.
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 15:16
Post: #4
RE: GIMP not opening own output
When Gimp creates a new file from scratch, by default it puts the text "Created with GIMP" in the comment field. If you open an existing file for editing and then save it, Gimp leaves the comment field untouched. The comment on your image reads "CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), default quality".

Try opening Gimp and creating a new, blank image, then saving it as a jpeg. See if that image will open properly.

[Image: viragogimpforumssig.png]
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 15:28
Post: #5
RE: GIMP not opening own output
Thank you, Virago. I made a small test file (attached), which opened without trouble.


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 17:13
Post: #6
RE: GIMP not opening own output
(Jun 2, 2011 15:16)Virago Wrote:  When Gimp creates a new file from scratch, by default it puts the text "Created with GIMP" in the comment field. If you open an existing file for editing and then save it, Gimp leaves the comment field untouched. The comment on your image reads "CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), default quality".

Try opening Gimp and creating a new, blank image, then saving it as a jpeg. See if that image will open properly.
Good findSmile

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 18:12
Post: #7
RE: GIMP not opening own output
The problem, a peculiar one, has been identified. I took a photo each with my two Olympus cameras, an E-300 and an E-510. They were both converted from raw with UFRaw, and each was saved in three ways: TIFF, JPEG, reduced size JPEG. Only the reduced size JPEG from the E-510 cannot be opened with the GIMP and makes that program hang. Both small files are attached, should anyone wish to compare them.


Attached File(s) Thumbnail(s)
       
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 18:16
Post: #8
RE: GIMP not opening own output
(Jun 2, 2011 15:28)payasam Wrote:  Thank you, Virago. I made a small test file (attached), which opened without trouble.

Okay, that tells us that Gimp is working okay. The problem is likely an incompatibility between some other graphics program and Gimp. Did you recently upgrade any of your other software or your OS? Any firmware upgrades to your camera? Where did this file originally come from (what program created it)? If you can find something in common with all the files you're having trouble with, that may be the source of the problem.

Also, are you using any jpeg plug-ins or other file saving plug-ins with Gimp, or just the default "File > Save as" that came with it?

[Image: viragogimpforumssig.png]
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 18:28
Post: #9
RE: GIMP not opening own output
Just the File -> Save As. In my last, I said that the difficulty had been narrowed down to one camera.
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 18:32
Post: #10
RE: GIMP not opening own output
That is a rather peculiar set of circumstances. The only thing I can imagine is that it must be some type of bug either in the jpeg compression at a certain level in UFRaw (or whatever library its using), or a similar bug in Gimp's jpeg import library. But that's just a guess on my part. I think at this point we're probably down to a solution that resembles an old joke. A guy goes into a doctor's office and says "My arm hurts when I move it like this." To which the doctor responds "Well, don't move it like that!" Big Grin

[Image: viragogimpforumssig.png]
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 18:35 (This post was last modified: Jun 2, 2011 18:37 by Virago.)
Post: #11
RE: GIMP not opening own output
(Jun 2, 2011 18:28)payasam Wrote:  Just the File -> Save As. In my last, I said that the difficulty had been narrowed down to one camera.
I think we're getting a little out of sync. I actually wrote my reply before I saw your comment about the one camera. Smile

Have you checked for any firmware updates for that camera? Or maybe an update for UFRaw? FWIW I tried both of the images you posted and had no trouble at all opening them in Gimp and a couple of other programs.

[Image: viragogimpforumssig.png]
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 18:39
Post: #12
RE: GIMP not opening own output
Virago, I shall follow your mythical doctor's advice. Thank you.
Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 21:46
Post: #13
RE: GIMP not opening own output
Another possibility if that you aren't using standard software, either a non-standard file-jpeg Gimp plug-in, or a standard plugin not using libjpeg but something else (gd-jpeg).

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 23:12
Post: #14
RE: GIMP not opening own output
Hmmm. Futher evidence shows that on my machine the JPEG files are opened via the ufraw-gimp plugin and not with file-jpeg. Furthermore even on my Ubuntu, the E300 file opens quickly (had to write a script to catcth the ufraw plugin in the act), but the E510 file triggers 4 ufraw-gimp instances (*) that all go to 100% CPU (I don't remember seeing my CPU getting this hot...).

So that may be a problem with the ufraw plugin.

(*) I have a dual-core with hyper-threading, so that's 4 virtual cores and there may be a link.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jun 2, 2011, 23:29
Post: #15
RE: GIMP not opening own output
Digging a bit more: when it works, ufraw-gimp eventually calls the file-jpeg plugin. When it loops, file-jpeg doesn't show.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Scaling GIMP for high definition monitors kerry 1 72 Nov 18, 2017 15:01
Last Post: paynekj
  GIMP on High Sierra won't open rickyleaks 1 100 Nov 9, 2017 12:45
Last Post: paynekj
  embedding icm profile in a psd generated by gimp Richar_d 1 148 Oct 13, 2017 12:00
Last Post: paynekj
  Gimp GUI icons missed massimobarbieri 1 275 Aug 23, 2017 17:51
Last Post: ofnuts
  why gimp in mac has bad performance mcheung63 1 288 Aug 20, 2017 10:13
Last Post: ythgilb

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS