Post Reply 

Gimp 2.8 GTK messed up

May 10, 2012, 20:34
Post: #1
Gimp 2.8 GTK messed up
Gimp 2.8s GTK theme is messed up (look at attached screenshot). Before I upgraded to 2.8 I had 2.6 and the theme was the way it was supposed to be.
How do I fix this?

OS: Windows 7 64bit

   
Find all posts by this user
Quote this message in a reply
May 10, 2012, 21:05
Post: #2
RE: Gimp 2.8 GTK messed up
Messed up where? How?

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
May 11, 2012, 19:49
Post: #3
RE: Gimp 2.8 GTK messed up
Hey, same problem here. Windows 7 64-bit. Stuff disappears and shows up where its not supposed to. especially with transparent elements. (screenshot) Its just ugly as all hell, too. I'd rather not have it look like i'm using windows 95. That gimpthemes 1.0 program doesn't work, either.

[Image: lI9rr.jpg]
the black stuff either isn't supposed to be there or supposed to not be cut off at irregular parts. also there appears to be part of a button missing next to the font size thing.
Find all posts by this user
Quote this message in a reply
May 11, 2012, 20:13 (This post was last modified: May 11, 2012 20:14 by ofnuts.)
Post: #4
RE: Gimp 2.8 GTK messed up
http://gimp-win.sourceforge.net/contact.html Angel

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
May 14, 2012, 14:55
Post: #5
RE: Gimp 2.8 GTK messed up
Hey,

I think I've managed to sort it, if you copy the "MS-Windows" folder from "C:\Program Files\GIMP 2\share\themes" to "C:\Program Files\GIMP 2\share\gimp\2.0\themes" them move the content out so rather than it being "MS-Windows\gtk-2.0\[then the file called gtkrc]" its just, "MS-Windows\[then the file]".

Then open Gimp and go Edit>Preferences>Theme select "MS-Windows" and press "Ok", then you can press "Reload Current Theme", and that should sort it.

Hope this helps,
Dylan Smile

Ps. Not sure why it doesn't work, its fine on my home PC but my work machine had this bug.
Find all posts by this user
Quote this message in a reply
May 14, 2012, 22:28
Post: #6
RE: Gimp 2.8 GTK messed up
(May 14, 2012 14:55)DylanMc93 Wrote:  Hey,

I think I've managed to sort it, if you copy the "MS-Windows" folder from "C:\Program Files\GIMP 2\share\themes" to "C:\Program Files\GIMP 2\share\gimp\2.0\themes" them move the content out so rather than it being "MS-Windows\gtk-2.0\[then the file called gtkrc]" its just, "MS-Windows\[then the file]".

Then open Gimp and go Edit>Preferences>Theme select "MS-Windows" and press "Ok", then you can press "Reload Current Theme", and that should sort it.

Hope this helps,
Dylan Smile

Ps. Not sure why it doesn't work, its fine on my home PC but my work machine had this bug.


It works! Thanks Smile. Except the "Reload Current Theme" button didn't do anything for me. I had to restart Gimp and then it worked.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Gimp GUI icons missed massimobarbieri 1 160 Aug 23, 2017 17:51
Last Post: ofnuts
  why gimp in mac has bad performance mcheung63 1 148 Aug 20, 2017 10:13
Last Post: ythgilb
  Issue viewing GIMP-modified picture JuniorPear 1 255 Jul 6, 2017 05:03
Last Post: ythgilb
  GIMP Taking Too Long to Start (Fonts) Seta 2 289 Jun 20, 2017 16:10
Last Post: Seta
  Problem with pressure on gimp (huion h610) protosd3 18 5,464 Jun 8, 2017 19:20
Last Post: John Penfold

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS