Post Reply 

Gimp 2.8 does not recognize my tablet

Aug 30, 2013, 11:59
Post: #16
RE: Gimp 2.8 does not recognize my tablet
Same problem as which one? Smile

Otherwise your best bet is the last 2.6 version (2.6.12 IIRC).

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Nov 30, 2013, 04:26
Post: #17
RE: Gimp 2.8 does not recognize my tablet
the gimp 2.8 32 bit verison works fine, but don't know why 64 bit doesn't support the tablet.
Find all posts by this user
Quote this message in a reply
Nov 30, 2013, 05:10
Post: #18
RE: Gimp 2.8 does not recognize my tablet
(Nov 30, 2013 04:26)maaz Wrote:  the gimp 2.8 32 bit verison works fine, but don't know why 64 bit doesn't support the tablet.

(also saw your post in the last thread I replied to)
You said its a graphic tablet, does that mean the type you plug into the computer with no screen on it?
(Lol, I wish everyone on here would revert to the regular graphic tablets(no screen), would make troubleshooting more easier)

32-bit vs 64-bit apps
its probably just an incompatibility with the 64-bit version. Its like if you try to run a 64-bit application on a 32-bit Operating system, it COULD work but your going to run into some kind of problems unless its not feature-heavy.
Visit this user's website Find all posts by this user
Quote this message in a reply
Nov 30, 2013, 07:30
Post: #19
RE: Gimp 2.8 does not recognize my tablet
its a graphic tablet without screen, the simple one. And I'm using windows 8 64 bit but gimp 2.8 64 bit doesn't give pressure sensitivity where as 32 bit does.
Find all posts by this user
Quote this message in a reply
Nov 30, 2013, 07:39
Post: #20
RE: Gimp 2.8 does not recognize my tablet
One more question, I'm thinking of dual-booting and installing lubuntu, will gimp 2.8 64 bit work fine on it, coz I've seen on the threads that gimp 2.8 windows support for tablets is broken.
Find all posts by this user
Quote this message in a reply
Nov 30, 2013, 09:04
Post: #21
RE: Gimp 2.8 does not recognize my tablet
(Nov 30, 2013 07:39)maaz Wrote:  One more question, I'm thinking of dual-booting and installing lubuntu, will gimp 2.8 64 bit work fine on it, coz I've seen on the threads that gimp 2.8 windows support for tablets is broken.

I'd wait to see what ofnut says about it, as he uses linux I'm a windows8 user myself.

As to why the 32-bit gimp works better on your win8 OS is probably becuase the 64-bit one is experimental? Or it could be windows 8, win8 is still not 100%compatible with all programs, but its close ^_^
Visit this user's website Find all posts by this user
Quote this message in a reply
Dec 13, 2013, 08:44
Post: #22
RE: Gimp 2.8 does not recognize my tablet
(Nov 30, 2013 07:39)maaz Wrote:  One more question, I'm thinking of dual-booting and installing lubuntu, will gimp 2.8 64 bit work fine on it, coz I've seen on the threads that gimp 2.8 windows support for tablets is broken.

Works fine on Linux...

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Dec 15, 2013, 21:22
Post: #23
RE: Gimp 2.8 does not recognize my tablet
(Jul 28, 2012 03:29)otrotipomas Wrote:  Hey, i got the same tablet and OS.
This is how i got it to work.

First, install drivers that come with the tablet. Is your tablet connected?
Now open gimp 2.8.

go to input devices. (edit>preferences>input devices.)

Now click configure input devices. You should see the pen, the eraser(if you have one) and the arrow pointer.
Make sure they are selected to screen.

1) If you can Not see them, then reply what is exactly what you see. Only the the core pointer (arrow) ?

2) If you Can see them, gimp recognized your tablet. You only need to config the brush Dynamics so it uses pressure. It changed a bit.

Here a little tour into brush dynamics in Gimp 2.8.
Gimp 2.8 gives you a lot of options. Go to the brush tool options.

click Dynamics and select one. Each dynamic has different config. Some use pressure, others don't.

Select pen generic and try to draw something. With this Dynamic more pressure is more opacity. Draw a line. if it the line is darker when you apply more pressure , then it works.

If this works, then Congrats ! gimps has detected your pen and can use pressure.

There are several Dynamics. Test them one by one till you find the one you need.

Now, one thing you Must know. Just like in gimp 2.0 , You can create your own brush Dynamics settings.

I created Pressure Size, wich is when this Dynamic is Selected, More pressure = more Size, but with constant opacity.

How ? Well first thing is to open your paint dynamic editor.
It's in windows>dockable dialogs > Paint Dynamics.

Now thats open, right click and select new dynamics. This will open the editor.
Pick a name you like, and check the options you like to have in the mapping matrix.

For example, for Pressure Size you need to check pressure size checkbox (2,1) and leave all the others empty.

Now from the brush options select the dynamic you created and draw to your heart content.

Pretty cool, uh ?

Hope this solves your problem. If not, just describe your problem once again and we'll try to help you.

Saludos !

On the part where you wrote, "1) If you can Not see them, then reply what is exactly what you see. Only the the core pointer (arrow) ?"

I'm having that problem. Except I'm using a Sony Vaoi touchscreen tablet, which allows me to draw directly onto the screen. When I go to preferences, the only thing showing is the pointer (no pen of which I am using). Does anyone know how to apply the pessure sensitivity here?

You'd be greatly appreciated if you do and shared it with me! lol
Find all posts by this user
Quote this message in a reply
Jan 3, 2014, 18:01
Post: #24
RE: Gimp 2.8 does not recognize my tablet
(Jan 29, 2013 16:48)DaVince Wrote:  
(Aug 12, 2012 19:44)siehorse Wrote:  Here's how you get your tablet to work on GIMP:
Open GIMP
On the upper toolbar, click EDIT -> PREFERENCES
On the lefthand menu, click INPUT DEVICES
Click CONFIGURE EXTENDED INPUT DEVICES
On the lefthand menu, click PEN and change its mode to SCREEN
Click SAVE in the lower righthand corner
Click OK in the lower righthand corner
Restart GIMP

You can now customize your own Dynamics or use the premade ones Smile. Enjoy your new pen pressure![/u]

My tablet (an older Trust one) is visible in the input devices list, but whenever I enable it, I can't draw anything. Instead, when I start drawing with the pen, middle mouse button and right mouse button behaviour keeps happening over and over and over again. The driver is set up so pressing the pen acts as the left mouse button, so I have no clue why this is happening. It looks like this in the GIMP settings:

[Image: gimputdevices.png]

Anyone got any suggestions?

Same exact problem here using an old Trust tablet (no screen) and Windows 8.1...I've tried everything I can from the suggestions in this thread, nothing works.

Several people have mentioned that they got it to work using the 32-bit version of 2.8...now I could be missing something here as nobody else has mentioned it, but to run it as 32-bit my understanding is that you run the installer in Windows XP (service pack 3) compatability mode right? If so this doesn't work either.

When installed using the XP setting I then tried running the program using all available compatability options (Vista's, windows 7/8) No luck.

I tried installing 2.8.6 and 2.8.2 (the last version I was using with no problem on my old laptop running XP) using XP compatability etc....No luck....

Just about ready to take a dump on my laptop, slam it shut and throw it at the f#@king wall!

I even considered buying SAI instead but that doesn't recognise the tablet at all!

BTW the tablet is a TRUST TB-6300, I know it's old but it worked fine 4 minutes ago on my old laptop running XP and GIMP 2.8.2. I have the latest software and driver installed for it and it works fine on everything else, including the pressure sensitivity test on the configuration software you get with it.

hmmmm, I've tried to give as much info as possible here in the hope that someone will find a solution or point me to the one I've missed or mis-understood, I'm new here, only joined because of this problem, I've been using GIMP for years but I'm a layman in terms of coding and farting around with software so please bear that in mind!
Find all posts by this user
Quote this message in a reply
Jan 4, 2014, 02:38 (This post was last modified: Jan 4, 2014 02:39 by iForStyle007.)
Post: #25
RE: Gimp 2.8 does not recognize my tablet
Try the pre-installed brush dynamics (Under Brush Tool Options, a blue arrow pointing down-right) their setting will be greyed out, but you an choose between them.

3.2.2. Editing Paint Dynamics
http://docs.gimp.org/en/gimp-tool-dynamics.html
Try those, then make your own if none of them work with pressure or what you need, create a custom new one(SEE BELOW VIDEO/info).

In my video, I detail how to make a new dynamic, try checking the "Pressure" column in the Dynamic editor window
http://youtu.be/fVZYvOFBetw?t=2m5s
(you can ignore the check-boxes in this video, they are specific to the brush I made)
Visit this user's website Find all posts by this user
Quote this message in a reply
Jan 7, 2014, 20:15
Post: #26
RE: Gimp 2.8 does not recognize my tablet
(Jan 4, 2014 02:38)iForStyle007 Wrote:  Try the pre-installed brush dynamics (Under Brush Tool Options, a blue arrow pointing down-right) their setting will be greyed out, but you an choose between them.

3.2.2. Editing Paint Dynamics
http://docs.gimp.org/en/gimp-tool-dynamics.html
Try those, then make your own if none of them work with pressure or what you need, create a custom new one(SEE BELOW VIDEO/info).

In my video, I detail how to make a new dynamic, try checking the "Pressure" column in the Dynamic editor window
http://youtu.be/fVZYvOFBetw?t=2m5s
(you can ignore the check-boxes in this video, they are specific to the brush I made)

Thanks for this suggestion and links...I made a custom fade brush that'll act as a competent work around for now... it's far from ideal though, Still I did have fun faffing with some the brush dynamic settings I hadn't used before!

I still wouldn't mind the actual pressure sensitivity to just work again though, I still have to disable my pen in the input devices for this to work, if I set it to screen you can't do anything. If anyone catches wind of a full on fix I'm all ears!

Thanks again.
Find all posts by this user
Quote this message in a reply
Jan 11, 2014, 21:57 (This post was last modified: Jan 11, 2014 21:58 by Felixader.)
Post: #27
RE: Gimp 2.8 does not recognize my tablet
I am writing this response to keep the topic afloat and to peoples attention, beacuase i have the exact same problem.
Find all posts by this user
Quote this message in a reply
Mar 9, 2014, 06:04
Post: #28
RE: Gimp 2.8 does not recognize my tablet
So I know this thread is a little old, but I didn't see an answer really. I ended up here after a Google search because I was having the problem of my pen not showing up in the input devices screen. Out of desperation, and even though I hadn't changed anything, I hit the reset option and closed/reopened gimp. When I went back, the pen was there, I was able to set it to screen and now it works fine. I don't know if it'll help everyone or even anyone, but it worked for me and I thought I should share. I even made an account just to do so. If it makes a difference I'm using a Bamboo Fun tablet on Win 8.1.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  why gimp in mac has bad performance mcheung63 1 18 Today 10:13
Last Post: ythgilb
  Issue viewing GIMP-modified picture JuniorPear 1 194 Jul 6, 2017 05:03
Last Post: ythgilb
  GIMP Taking Too Long to Start (Fonts) Seta 2 208 Jun 20, 2017 16:10
Last Post: Seta
  Problem with pressure on gimp (huion h610) protosd3 18 5,058 Jun 8, 2017 19:20
Last Post: John Penfold
Question Gimp 2.8 Startup Keeps Not Responding lolly325 38 22,383 Jun 5, 2017 15:46
Last Post: blighty

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS