Post Reply 

Gimp 2.8 does not recognize my tablet

Jul 25, 2012, 03:14
Post: #1
Gimp 2.8 does not recognize my tablet
I have been using bamboo fun with gimp(2.6 or older) for ages without any problems with either one. Today I finally managed to make it into the store and upgrade my tablet to bamboo pen and touch. Also found a new gimp version and decided to get that one as well. I uninstalled all old drivers and the old gimp before installing the new ones

So I got my pen tablet working and gimp 2.8 installed. Everything seemed to be just fine until I tried to add my tablet as an input devise. Gimp just does not show tablet on the list, it wont recognize it's pressure sensitivity or any similar things the tablet is supposed to do. I restarted my computer between installing the drivers and the latest gimp, I restarted after installing gimp. Heck, I've restarted my computer about a dozen times today and still nothing gimp wont find my tablet. I've deleted my old profile data from the .gimp2.6 folder in the uninstalling process so it cant be about that

I tried searching fixes and things that worked for 2.6 but none of those worked for me so here I am. Anyone has any idea what to do? I tried using both the latest drivers and the ones that came with the tablet but neither made gimp recognize the tablet that is working just fine with every other program in existence

I'm running win7 if that's any help
Find all posts by this user
Quote this message in a reply
Jul 28, 2012, 01:46
Post: #2
RE: Gimp 2.8 does not recognize my tablet
I remember having trouble get my pressure sensitivity to work as well. I went to edit/ input devices and i put the pen mode to screen does it show up under that?
Find all posts by this user
Quote this message in a reply
Jul 28, 2012, 03:29
Post: #3
RE: Gimp 2.8 does not recognize my tablet
Hey, i got the same tablet and OS.
This is how i got it to work.

First, install drivers that come with the tablet. Is your tablet connected?
Now open gimp 2.8.

go to input devices. (edit>preferences>input devices.)

Now click configure input devices. You should see the pen, the eraser(if you have one) and the arrow pointer.
Make sure they are selected to screen.

1) If you can Not see them, then reply what is exactly what you see. Only the the core pointer (arrow) ?

2) If you Can see them, gimp recognized your tablet. You only need to config the brush Dynamics so it uses pressure. It changed a bit.

Here a little tour into brush dynamics in Gimp 2.8.
Gimp 2.8 gives you a lot of options. Go to the brush tool options.

click Dynamics and select one. Each dynamic has different config. Some use pressure, others don't.

Select pen generic and try to draw something. With this Dynamic more pressure is more opacity. Draw a line. if it the line is darker when you apply more pressure , then it works.

If this works, then Congrats ! gimps has detected your pen and can use pressure.

There are several Dynamics. Test them one by one till you find the one you need.

Now, one thing you Must know. Just like in gimp 2.0 , You can create your own brush Dynamics settings.

I created Pressure Size, wich is when this Dynamic is Selected, More pressure = more Size, but with constant opacity.

How ? Well first thing is to open your paint dynamic editor.
It's in windows>dockable dialogs > Paint Dynamics.

Now thats open, right click and select new dynamics. This will open the editor.
Pick a name you like, and check the options you like to have in the mapping matrix.

For example, for Pressure Size you need to check pressure size checkbox (2,1) and leave all the others empty.

Now from the brush options select the dynamic you created and draw to your heart content.

Pretty cool, uh ?

Hope this solves your problem. If not, just describe your problem once again and we'll try to help you.

Saludos !
Find all posts by this user
Quote this message in a reply
Aug 12, 2012, 19:44
Post: #4
RE: Gimp 2.8 does not recognize my tablet
Here's how you get your tablet to work on GIMP:
Open GIMP
On the upper toolbar, click EDIT -> PREFERENCES
On the lefthand menu, click INPUT DEVICES
Click CONFIGURE EXTENDED INPUT DEVICES
On the lefthand menu, click PEN and change its mode to SCREEN
Click SAVE in the lower righthand corner
Click OK in the lower righthand corner
Restart GIMP

You can now customize your own Dynamics or use the premade ones Smile. Enjoy your new pen pressure![/u]
Find all posts by this user
Quote this message in a reply
Aug 14, 2012, 16:48
Post: #5
RE: Gimp 2.8 does not recognize my tablet
(Jul 28, 2012 03:29)otrotipomas Wrote:  Hey, i got the same tablet and OS.
This is how i got it to work.

First, install drivers that come with the tablet. Is your tablet connected?
Now open gimp 2.8.

go to input devices. (edit>preferences>input devices.)

Now click configure input devices. You should see the pen, the eraser(if you have one) and the arrow pointer.
Make sure they are selected to screen.

1) If you can Not see them, then reply what is exactly what you see. Only the the core pointer (arrow) ?

2) If you Can see them, gimp recognized your tablet. You only need to config the brush Dynamics so it uses pressure. It changed a bit.
I'm having this same problem. I do not see any options other than the mouse when configuring input devices. The only device that appears is the Core Pointer.
Find all posts by this user
Quote this message in a reply
Oct 8, 2012, 13:02
Post: #6
RE: Gimp 2.8 does not recognize my tablet
(Aug 14, 2012 16:48)glathon Wrote:  
(Jul 28, 2012 03:29)otrotipomas Wrote:  Hey, i got the same tablet and OS.
This is how i got it to work.

First, install drivers that come with the tablet. Is your tablet connected?
Now open gimp 2.8.

go to input devices. (edit>preferences>input devices.)

Now click configure input devices. You should see the pen, the eraser(if you have one) and the arrow pointer.
Make sure they are selected to screen.

1) If you can Not see them, then reply what is exactly what you see. Only the the core pointer (arrow) ?

2) If you Can see them, gimp recognized your tablet. You only need to config the brush Dynamics so it uses pressure. It changed a bit.
I'm having this same problem. I do not see any options other than the mouse when configuring input devices. The only device that appears is the Core Pointer.



I just got GIMP around half an hour ago in desperation to have something while I try to get parallels desktop for sai to work on my new mac, so what happened for me was this: My tablet (bamboo pen and touch) wasn't turning up on the menu of input devices everyone keeps talking about, and it's hard to set it to screen when it's not actually there, but it started working when I went to input devices in preferences, then I clicked "Configure Extended Input Devices". From what came up I just set the "quartz" eraser and pen etc to screen and my tablet's working alright now. Of course you'll probably still want to mess with it a bit to try and get the brushes and settings right, but at least now the damn pressure sensitivity's working.
Find all posts by this user
Quote this message in a reply
Nov 25, 2012, 18:31
Post: #7
RE: Gimp 2.8 does not recognize my tablet
Mine is doing this too.. Although I have a monoprice tablet. The pressure worked fine when I had an older version. I tried everything listed, but I still can't use it. When I set the tablet to screen, I can't even draw anything. Any one know how to fix it?
Find all posts by this user
Quote this message in a reply
Dec 4, 2012, 20:30
Post: #8
RE: Gimp 2.8 does not recognize my tablet
My Bamboo Create is finally working, thanks to the instructions in this thread, but I have a new problem - the crosshairs and the actual drawing area are never in the same place. My crosshairs might be in the upper part of the drawing window, but the actual drawing cursor (brush circle, et al) is offset by what appears to be a random amount either to the side or below.

I've searched everything I can think of in order to get the two to sync up, but I'm pulling a blank. Anyone here ever encounter this with a Bamboo of any sort?
Find all posts by this user
Quote this message in a reply
Jan 29, 2013, 16:48 (This post was last modified: Jan 29, 2013 16:54 by DaVince.)
Post: #9
RE: Gimp 2.8 does not recognize my tablet
(Aug 12, 2012 19:44)siehorse Wrote:  Here's how you get your tablet to work on GIMP:
Open GIMP
On the upper toolbar, click EDIT -> PREFERENCES
On the lefthand menu, click INPUT DEVICES
Click CONFIGURE EXTENDED INPUT DEVICES
On the lefthand menu, click PEN and change its mode to SCREEN
Click SAVE in the lower righthand corner
Click OK in the lower righthand corner
Restart GIMP

You can now customize your own Dynamics or use the premade ones Smile. Enjoy your new pen pressure![/u]

My tablet (an older Trust one) is visible in the input devices list, but whenever I enable it, I can't draw anything. Instead, when I start drawing with the pen, middle mouse button and right mouse button behaviour keeps happening over and over and over again. The driver is set up so pressing the pen acts as the left mouse button, so I have no clue why this is happening. It looks like this in the GIMP settings:

[Image: gimputdevices.png]

Anyone got any suggestions?
Find all posts by this user
Quote this message in a reply
Mar 14, 2013, 05:56 (This post was last modified: Mar 14, 2013 05:56 by Skit78.)
Post: #10
RE: Gimp 2.8 does not recognize my tablet
(Jan 29, 2013 16:48)DaVince Wrote:  
(Aug 12, 2012 19:44)siehorse Wrote:  Here's how you get your tablet to work on GIMP:
Open GIMP
On the upper toolbar, click EDIT -> PREFERENCES
On the lefthand menu, click INPUT DEVICES
Click CONFIGURE EXTENDED INPUT DEVICES
On the lefthand menu, click PEN and change its mode to SCREEN
Click SAVE in the lower righthand corner
Click OK in the lower righthand corner
Restart GIMP

You can now customize your own Dynamics or use the premade ones Smile. Enjoy your new pen pressure![/u]

My tablet (an older Trust one) is visible in the input devices list, but whenever I enable it, I can't draw anything. Instead, when I start drawing with the pen, middle mouse button and right mouse button behaviour keeps happening over and over and over again. The driver is set up so pressing the pen acts as the left mouse button, so I have no clue why this is happening. It looks like this in the GIMP settings:

[Image: gimputdevices.png]

Anyone got any suggestions?

Good! I'm not the only one suffering from this problem. This just started happening today on my machine. I'm using an old Digipro Wp5540. I've tested the tablet in other applications--it's definitely working fine, recognizing pen pressure and everything. I don't know why switching input device pressure would make it behave in this way.

My new computer is a Windows 8 machine. Could this be the problem?
Find all posts by this user
Quote this message in a reply
Mar 20, 2013, 18:12
Post: #11
RE: Gimp 2.8 does not recognize my tablet
(Mar 14, 2013 05:56)Skit78 Wrote:  Good! I'm not the only one suffering from this problem. This just started happening today on my machine. I'm using an old Digipro Wp5540. I've tested the tablet in other applications--it's definitely working fine, recognizing pen pressure and everything. I don't know why switching input device pressure would make it behave in this way.

My new computer is a Windows 8 machine. Could this be the problem?

Just registered to say that I have exactly the same problem. I'm using a brandnew Monoprice and Windows 7 64-bit. Just like Skit78 the drawing tablet works great with other applications (including pressure sensitivity). Is there any solution for this problem? Sad
Find all posts by this user
Quote this message in a reply
Mar 21, 2013, 06:58
Post: #12
RE: Gimp 2.8 does not recognize my tablet
(Mar 20, 2013 18:12)Tapokr Wrote:  
(Mar 14, 2013 05:56)Skit78 Wrote:  Good! I'm not the only one suffering from this problem. This just started happening today on my machine. I'm using an old Digipro Wp5540. I've tested the tablet in other applications--it's definitely working fine, recognizing pen pressure and everything. I don't know why switching input device pressure would make it behave in this way.

My new computer is a Windows 8 machine. Could this be the problem?

Just registered to say that I have exactly the same problem. I'm using a brandnew Monoprice and Windows 7 64-bit. Just like Skit78 the drawing tablet works great with other applications (including pressure sensitivity). Is there any solution for this problem? Sad

This FAQ may help, the relevant question is about halfway down:

http://draw2much.deviantart.com/journal/...-342426446

I have Windows 7, 64 bit and a brand new Monoprice tablet as well. I had to uninstall Gimp 2.8 and install 2.6. I could not get it to work with 2.8.

I also had to go to the UC Logic site--they make the tablet--and install the newest driver. Because I have a laptop with a touchpad, I had to go to the last tab in the Windows "Mouse Properties" dialogue, the tab for my touchpad, and make sure that the "Disable when external USB device plug in" box was NOT checked. At some point it was checked--I don't know if I did it or one of the drivers--and whenever I would plug in the tablet, everything went screwy and my touchpad stopped working. Now, with that box unchecked, I leave the tablet plugged in all the time and both the tablet and the touchpad work fine, better than fine, great.
Find all posts by this user
Quote this message in a reply
Mar 21, 2013, 14:22
Post: #13
RE: Gimp 2.8 does not recognize my tablet
I was so excited that I could finally run GIMP on my mac without using a separate program and now this! I also amusing a monoprice tablet and GIMP 2.8 won't recognize pressure sensitivity. I've tried all these things. Thanks for trying to get to the bottom of this, everybody, but so far no luck!

Guess I'll go download the older version for now...
Find all posts by this user
Quote this message in a reply
Apr 10, 2013, 14:24
Post: #14
RE: Gimp 2.8 does not recognize my tablet
(Mar 20, 2013 18:12)Tapokr Wrote:  
(Mar 14, 2013 05:56)Skit78 Wrote:  Good! I'm not the only one suffering from this problem. This just started happening today on my machine. I'm using an old Digipro Wp5540. I've tested the tablet in other applications--it's definitely working fine, recognizing pen pressure and everything. I don't know why switching input device pressure would make it behave in this way.

My new computer is a Windows 8 machine. Could this be the problem?

Just registered to say that I have exactly the same problem. I'm using a brandnew Monoprice and Windows 7 64-bit. Just like Skit78 the drawing tablet works great with other applications (including pressure sensitivity). Is there any solution for this problem? Sad

I too am having this problem I am using a digipro with win 7 64 bit. and yes I installed it correctly.
it is working wonderful in every other software except for gimp. I have tried all the solutions. Gimp sees it I have tried several different configurations. I am convinced this is a bug in gimp. Unless someone can give me a better solution.
Find all posts by this user
Quote this message in a reply
Aug 30, 2013, 08:37
Post: #15
RE: Gimp 2.8 does not recognize my tablet
Same problem.
Just wanted to ask if someone find solution to this?
Same tablet worked fine on older version on my old computer.
Can someone tell which older version of Gimp to download to work on my new 64x win?
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Gimp GUI icons missed massimobarbieri 1 160 Aug 23, 2017 17:51
Last Post: ofnuts
  why gimp in mac has bad performance mcheung63 1 152 Aug 20, 2017 10:13
Last Post: ythgilb
  Issue viewing GIMP-modified picture JuniorPear 1 255 Jul 6, 2017 05:03
Last Post: ythgilb
  GIMP Taking Too Long to Start (Fonts) Seta 2 294 Jun 20, 2017 16:10
Last Post: Seta
  Problem with pressure on gimp (huion h610) protosd3 18 5,479 Jun 8, 2017 19:20
Last Post: John Penfold

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS