Post Reply 

Gimp 2.8.2 not seeing installed User Manual

Sep 22, 2012, 17:57
Post: #1
Gimp 2.8.2 not seeing installed User Manual
New User. I have just installed Gimp 2.8.2 on Windows XP Pro SP3. Downloaded and installed the User Manual which went into C:Program Files/GIMP 2/gimp/share/gimp/2.0/help/en_GB etc.
I believe that this is the correct location. Loaded Gimp and selected Preferences - Help System which shows the error "User Manual is not installed locally". Selecting Help from the main screen produces the same error message. Any suggestions as what I have done wrong would be appreciated.

TonyA
Find all posts by this user
Quote this message in a reply
Sep 22, 2012, 18:41
Post: #2
RE: Gimp 2.8.2 not seeing installed User Manual
check in edit/preferences/ help system and change User manual to "use the on-line version" and Help browser to use "GIMP help browser"
Find all posts by this user
Quote this message in a reply
Sep 22, 2012, 21:26
Post: #3
RE: Gimp 2.8.2 not seeing installed User Manual
Hi Glimps

Already done that to prove a point. Prefer to use local manual and do not understand why it did not work. It would seem that either I have done something wrong or 2.8.2 might have a problem with this feature. So any other ideas would help.

TonyA
Find all posts by this user
Quote this message in a reply
Sep 23, 2012, 06:52
Post: #4
RE: Gimp 2.8.2 not seeing installed User Manual
Hi TonyA
After reading your reply I checked my settings and although they were configured to use my installed user manual the Gimp was using the on-line manual !!!. So it would seem I'm in the same situation as you. I'll let you know if I find a solution.
Glimps
Find all posts by this user
Quote this message in a reply
Sep 23, 2012, 08:08
Post: #5
RE: Gimp 2.8.2 not seeing installed User Manual
(Sep 23, 2012 06:52)Glimps Wrote:  Hi TonyA
After reading your reply I checked my settings and although they were configured to use my installed user manual the Gimp was using the on-line manual !!!. So it would seem I'm in the same situation as you. I'll let you know if I find a solution.
Glimps

I found maybe a problem with the en_GB help. Remove it and install the plain en version. see: http://gimpforums.com/thread-gimp-can-t-find-help-files

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Sep 23, 2012, 11:56
Post: #6
RE: Gimp 2.8.2 not seeing installed User Manual
Hi rich2005
Thanks for your reply. I looked at the thread you referred to. Most interesting comment was reference to System Language. I went into Preferences and found System Language was set to default, so set it to English GB. Being a newbie had not yet realised that this setting was available. Selecting Help loaded the Help screen. Checked that this was in fact the local instal of the User Manual by turning off my network before selecting Help.
It would seem that System Language needs to be set to the Language version of the User Manual. Presumably this applies to other language versions. Maybe the installation process of the User Manual needs to set the System Language automatically.
Problem solved. Your help much appreciated.
TonyA
Find all posts by this user
Quote this message in a reply
Oct 31, 2012, 03:09
Post: #7
RE: Gimp 2.8.2 not seeing installed User Manual
I'm having the same issue on my MAC. In 2.8 I installed the package and in preferences selected us local manual and it worked just fine. I installed 2.8.2 and have selected the same preferences. However, I keep getting an error saying that the local user manual is not installed. I've re-installed it two or three times, logged out, restarted my computer, etc., and get the same error. Where does Gimp look for the help files on a MAC?
Find all posts by this user
Quote this message in a reply
Nov 17, 2012, 14:01
Post: #8
RE: Gimp 2.8.2 not seeing installed User Manual
(Oct 31, 2012 03:09)remacreh Wrote:  I'm having the same issue on my MAC. In 2.8 I installed the package and in preferences selected us local manual and it worked just fine. I installed 2.8.2 and have selected the same preferences. However, I keep getting an error saying that the local user manual is not installed. I've re-installed it two or three times, logged out, restarted my computer, etc., and get the same error. Where does Gimp look for the help files on a MAC?

I would like an answer to this too, ASAP as I am totally confused as to where the user manual resides on my Macbook Pro. Spotlight searches come up with nothing!
Cheers, Mike.
Find all posts by this user
Quote this message in a reply
Nov 22, 2012, 17:03
Post: #9
RE: Gimp 2.8.2 not seeing installed User Manual
I've also installed Gimp User Manual on my Macbook Pro. Even though it says it installed okay I have yet to find it anywhere on my Mac. When trying to access the manual from Gimp it sends me directly to the on-line manual. Angry
Find all posts by this user
Quote this message in a reply
Nov 22, 2012, 20:01
Post: #10
RE: Gimp 2.8.2 not seeing installed User Manual
Just some thoughts

The obvious first, is a local version showing in Edit -> Preference -> Help from your post it is, the options are local and on-line

next

I use linux mainly, never used a Mac, so where did you get the help files from?

Was it here http://gimp.lisanet.de/Website/Download.html

unpacking the pkg file and I see this in the postinstall script.

GIMPHELP="/Users/Shared/Library/Application Support/Gimp/help"

so I suppose that is where it should end up.

Why not try a search for a file that can only exist in the Gimp help folder, it should locate that folder, Try say, gimp-help.html

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Nov 25, 2012, 13:12
Post: #11
RE: Gimp 2.8.2 not seeing installed User Manual
(Sep 22, 2012 17:57)TonyA Wrote:  New User. I have just installed Gimp 2.8.2 on Windows XP Pro SP3. Downloaded and installed the User Manual which went into C:Program Files/GIMP 2/gimp/share/gimp/2.0/help/en_GB etc.
I believe that this is the correct location. Loaded Gimp and selected Preferences - Help System which shows the error "User Manual is not installed locally". Selecting Help from the main screen produces the same error message. Any suggestions as what I have done wrong would be appreciated.

TonyA

I think you will find if you rename the help file "en" (without the quotation marks)
IE. delete the "_GB" part,it will find and read it
I had an old version I was using,with no problems,after I upgraded to 2.8 I had the same trouble with the Help file. After some digging about I found that the only difference was the name,deleted the "_GB" off the end,it all works OK!
Hope this helps.
Find all posts by this user
Quote this message in a reply
Dec 26, 2012, 06:26
Post: #12
RE: Gimp 2.8.2 not seeing installed User Manual
Same problem, same fix for me. Search works.

(Sep 23, 2012 11:56)TonyA Wrote:  Hi rich2005
Thanks for your reply. I looked at the thread you referred to. Most interesting comment was reference to System Language. I went into Preferences and found System Language was set to default, so set it to English GB. Being a newbie had not yet realised that this setting was available. Selecting Help loaded the Help screen. Checked that this was in fact the local instal of the User Manual by turning off my network before selecting Help.
It would seem that System Language needs to be set to the Language version of the User Manual. Presumably this applies to other language versions. Maybe the installation process of the User Manual needs to set the System Language automatically.
Problem solved. Your help much appreciated.
TonyA
Find all posts by this user
Quote this message in a reply
Dec 29, 2012, 23:26 (This post was last modified: Dec 29, 2012 23:34 by jim.)
Post: #13
RE: Gimp 2.8.2 not seeing installed User Manual
Hey guys, here is a workaround:

Note: Moderators, please do not delete my repeating posts, since I have work so hard to find the 4 different threads this info can be of help in.  Smile 

I have also been having a problem with the help files. I am trying to install the 2.6 help file folder "en" into my GIMP 2.8.2. The closest I have come is having "Help System" in Preferences say that I have a copy of the manual installed, but when I open it GIMP gives me the following message: "gimp message calling error for procedure 'plug-in-web-browser': no application is registered as handling this file".

My workaround for this right now is to simply find two HTML files in the 2.6 Help Files en folder titled "index.html" and "gimp-help-index.html", oped each of these in Safari, and then make bookmarks where I can get to them easily.

I hope this helps. Until a Mac Native GIMP Help System is released this seems to be the most reliable way of having help files "installed" on your system. We just have to be patient.

Good Photo Editing Mates
Stay Safe
Find all posts by this user
Quote this message in a reply
Jan 16, 2013, 17:38
Post: #14
RE: Gimp 2.8.2 not seeing installed User Manual
Many, many thanks for the tips in this thread and for the solution. The locally installed 2.8 manual finally works for me (on my Win 8 system) and using the GIMP help browser after renaming the "en-gb" folder to "en". However, I see that colour is still spelt color !! (To note my system language is set to UK English, but that obviously didn't matter as far as GIMP was concerned.) Anyway, result and, again, VMT.
Find all posts by this user
Quote this message in a reply
Apr 1, 2013, 11:15
Post: #15
RE: Gimp 2.8.2 not seeing installed User Manual
Yes, well done for finding this deceptively simple solution! I likewise renamed the "en-gb" folder to "en", and left System Language at the default (en_GB is not an option, only en_US). Now the help system works properly.

Surely this fix is easy for the developers to make? It took quite a bit of casting around until I found this forum and thread. Before then, I came across all sorts of more or less complex solutions (which fortunately I ignored) which could enmesh a beginner in hours of fruitless work. Please fix!

Many thanks to dkt1.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Blurry GIMP interface on macOS High Sierra 10.13.6 vagkavo 1 104 Aug 26, 2018 07:52
Last Post: paynekj
  Gimp wont keep merging when exporting Ergu 1 162 Aug 8, 2018 21:22
Last Post: paynekj
  Printers not showing in gimp chrismacor 1 185 May 24, 2018 06:03
Last Post: paynekj
  Gimp 2.8 wont't see my wcoom bamboo tablet NullPointer 1 269 May 22, 2018 12:53
Last Post: paynekj
  Gimp compatibility katie98 1 186 May 22, 2018 05:53
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS