Post Reply 

Gimp 2.10 with old vignette from Plugin registry.

May 19, 2018, 13:26 (This post was last modified: May 19, 2018 16:24 by DenisT.)
Post: #1
Gimp 2.10 with old vignette from Plugin registry.
Hi, my first message in here :-) don't know much about scripts and all, but I really wanted this to work...

So I installed Gimp 2.10 and quickly found out that many scripts would generate errors.
Sadly one of my favorite (Vignette script) from:
Dom_C at "http://registry.gimp.org/node/17267" would not work anymore.

The first error was: Error: eval: unbound variable: NORMAL
Quit Gimp
So I open the script file "vignette.scm" for me it was in:
"C:\Users\username\AppData\Roaming\GIMP\2.10\scripts\"
I search for the word "NORMAL" and replaced it with a zero "0"

Re-started Gimp and tried again.
Then second error was: Error: Procedure execution of plug-in-gauss-iir failed...
Quit Gimp
Again in the script file "vignette.scm":
I search for the word "plug-in-gauss-iir" at this point I did many trial and error to finally figure that it was with the radius so I searched for "radius" and finally found this line:
"(theRadius (* inRadius (/ (max theWidth theHeight) 25) ) )"
I replaced it with a different value like this:
"(theRadius (* inRadius (/ (max theWidth theHeight) 400) ) )"

Tried it with images of "RGB color 8-bit gamma integer" and
"RGB color 32-bit linear floating point 6000x4000"
and it worked for me :-)
I hope, for those who like this old script, this will help..
Have a nice day.
Find all posts by this user
Quote this message in a reply
May 19, 2018, 20:32
Post: #2
RE: Gimp 2.10 with old vignette from Plugin registry.
This forum has been DEAD for a long time and is abandoned to spammers.

We've all gone to https://www.gimp-forum.net
Find all posts by this user
Quote this message in a reply
May 19, 2018, 20:42
Post: #3
RE: Gimp 2.10 with old vignette from Plugin registry.
(May 19, 2018 20:32)paynekj Wrote:  This forum has been DEAD for a long time and is abandoned to spammers.

We've all gone to https://www.gimp-forum.net

Thank You, I did notice the pin message after I posted, So I Also posted it on:
gimp-forum.net :-)
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Tablet issues with GIMP 2.10 Phoenisca 1 299 May 30, 2018 14:30
Last Post: paynekj
  addonCollectionManager-3.0 on Gimp 2.10.2 (Solved) Pocholo 0 218 May 26, 2018 02:26
Last Post: Pocholo
  Export Layers Plugin not working with 2.10? Imc7r 2 234 Apr 30, 2018 14:22
Last Post: Imc7r
  having trouble doing multiple cuts on gimp gloege 1 283 Mar 20, 2018 11:47
Last Post: paynekj
  UFRAW and Gimp 2.8 64-bit mlitty 2 3,003 Mar 13, 2018 04:04
Last Post: ythgilb

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS