Post Reply 

Getting Layer Effects on GIMP 2.8 for Mac

Apr 24, 2014, 04:02
Post: #1
Getting Layer Effects on GIMP 2.8 for Mac
It all started when I tried to add a color overlay...
But that's not built in. Need layerfx.2.8.py
Found it, installed it. Or at least I thought I did.
It's not showing up in the menu.

1. What is the correct install path for such a .py on the 2.8.4 Mac build?
2. Do I have to set up anything with this Scipt-Fu thing, or should that be included?

Thanx
Find all posts by this user
Quote this message in a reply
Apr 24, 2014, 06:09
Post: #2
RE: Getting Layer Effects on GIMP 2.8 for Mac
The only way I got the Script-Fu menu to show up is by installing
not the .py but the .scm
into here:
/Applications/GIMP 2.8.4.app/Contents/Resources/lib/gimp/2.0/plug-ins

But then the Scipt-Fu menu is greyed out and unusable.
So this is not really a solution.

I suspect I may need to use the .py for GIMP 2.8 because of the way they are listed on the download page:
http://gimpscripts.com/2011/10/gimp-layer-effects/
Yet I have placed a copy of layerfx.2.8.py in every GIMP plugin or script folder I can find. Nothing works.
Find all posts by this user
Quote this message in a reply
Apr 24, 2014, 06:46
Post: #3
RE: Getting Layer Effects on GIMP 2.8 for Mac
(Apr 24, 2014 06:09)Q A Wrote:  The only way I got the Script-Fu menu to show up is by installing
not the .py but the .scm
into here:
/Applications/GIMP 2.8.4.app/Contents/Resources/lib/gimp/2.0/plug-ins

But then the Scipt-Fu menu is greyed out and unusable.
So this is not really a solution.

I suspect I may need to use the .py for GIMP 2.8 because of the way they are listed on the download page:
http://gimpscripts.com/2011/10/gimp-layer-effects/
Yet I have placed a copy of layerfx.2.8.py in every GIMP plugin or script folder I can find. Nothing works.
Check that the layerfx.2.8.py's Executable bit is set.
See here for solution.
Find all posts by this user
Quote this message in a reply
Apr 24, 2014, 08:01
Post: #4
RE: Getting Layer Effects on GIMP 2.8 for Mac
(Apr 24, 2014 06:09)Q A Wrote:  The only way I got the Script-Fu menu to show up is by installing
not the .py but the .scm
into here:
/Applications/GIMP 2.8.4.app/Contents/Resources/lib/gimp/2.0/plug-ins

But then the Scipt-Fu menu is greyed out and unusable.
So this is not really a solution.

again a caveat - I know little about OSX

Just checking - anything .scm goes in your scripts folder, anything .py goes in your plugins folder and for OSX or linux, has to be marked as executable.

screenshot of them both. http://i.imgur.com/fu1UAkt.jpg

The 3 versions mentioned come about because the original .scm was for an earlier Gimp version. Still works though. Then came a re-write in python and the last one, another re-write specifically for Gimp 2.8.x

Remember, it is layerfx, it does generally need a layer above the background to work. The script-fu menu options will be grayed-out if there is no active layer. The python version is in a separate place. bottom of the layers menu.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
May 28, 2014, 23:58
Post: #5
RE: Getting Layer Effects on GIMP 2.8 for Mac
(Apr 24, 2014 04:02)Q A Wrote:  It all started when I tried to add a color overlay...
But that's not built in.
why do you need a script for a color overlay ?

so my guess is you have some text...

01. create a new transparent layer on top of the text layer
02. alpha to select the text
03. fill selection with colour on your transparent layer, then deselect
04. adjust mode and opacity if necessary

layerfx does the very same thing

please visit Gimp-Science-Labs Blog
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Script Fu Errors Gimp 2.10.4 lightsaber jd3481 1 537 Aug 2, 2018 05:13
Last Post: paynekj
  GIMP Resynthesizer Plugin not working Mikkel Andersen 1 599 Jun 26, 2018 16:36
Last Post: paynekj
  Tablet issues with GIMP 2.10 Phoenisca 1 703 May 30, 2018 14:30
Last Post: paynekj
  addonCollectionManager-3.0 on Gimp 2.10.2 (Solved) Pocholo 0 440 May 26, 2018 02:26
Last Post: Pocholo
  Gimp 2.10 with old vignette from Plugin registry. DenisT 2 448 May 19, 2018 20:42
Last Post: DenisT

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS