Post Reply 

Fonts disappeared!? Won't work?

Jul 8, 2011, 17:22
Post: #1
Fonts disappeared!? Won't work?
Hi, I'm Wissem and I'm 15 years old. I live in Tunisia and I'm addicted to computers ^_^ My hobbies are studying, computering and my rabbits.
I often use GIMP, mainly to edit pictures. I'm using it for 1 or 2 years now and I really like it Smile
Saturday, I bought a laptop and I installed GIMP yesterday. Today I download some fonts and put them into the font file.
I refreshed the fonts in GIMP by clicking on the blue refresh button but then they all disappeared! So I restarted GIMP to look if they're back but in vain Sad
Does someone know how to fix this?

Thanks Smile

PS. I'm not sure if my English is 100% correct Tongue hh


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Jul 8, 2011, 20:30
Post: #2
RE: Fonts disappeared!? Won't work?
What do you call a "font file"? There are two places where you can install fonts for Gimp:

- as general system fonts (that you can then use on other applications)
- in your Gimp profile

So which one did you use?

On the other hand, Gimp should show you at least the system-installed fonts (Arial, Courier et al)...

Go to Edit/Preferences and then in the Folders (RĂ©pertoires?) at the bottom, the Font/Police one. Check that the directory listed "fonts" in your Gimp profile, usually) actually exists and is readable.

Otherwise: rename your Gimp profile (.gimp-2.6 -> .gimp-2.6-backup, for instance) and restart Gimp. This will recreate a new profile and hopefully reinstate the fonts. You can then copy things one by one from your previous profile.

If this is not enough, uninstall/reinstall Gimp.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 8, 2011, 22:40
Post: #3
RE: Fonts disappeared!? Won't work?
I've put the fonts I downloaded in:
Programmes -> GIMP-2.0 -> etc -> fonts

So I suppose that this is the Gimps font file?
Find all posts by this user
Quote this message in a reply
Jul 8, 2011, 22:59
Post: #4
RE: Fonts disappeared!? Won't work?
(Jul 8, 2011 22:40)Wissem Wrote:  I've put the fonts I downloaded in:
Programmes -> GIMP-2.0 -> etc -> fonts

So I suppose that this is the Gimps font file?
I doubt so... On Linux, /etc/fonts contains general font configurations but not the fonts themselves, that are in /usr/share/fonts.

But the real place to add fonts to Gimp is to either:
- install the fonts as Windows system fonts
- put the fonts in the fonts directory in your .gimp-2.6 profile (c:\users\{your id}\.gimp-2.6\fonts

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Jul 9, 2011, 12:16
Post: #5
RE: Fonts disappeared!? Won't work?
Yes it worked! I've put all the fonts in c:\users\[my ID]\.gimp-2/6\font Big Grin
I didn't knew that I had to put those fonts in that file.
Thank you very much Big Grin Big Grin
Find all posts by this user
Quote this message in a reply
Jul 9, 2011, 15:53
Post: #6
RE: Fonts disappeared!? Won't work?
That doesn't really explain why you didn't get *any* fonts in the list. The usual fonts (Arial, Courier, et al...) should have shown up there. Unless putting fonts in etc/fonts confused the font support.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Help - can't get Mathmap and GMIC to work together paul2332 1 188 Jul 15, 2017 18:58
Last Post: ythgilb
  Cant get Heal Selection to work ianp5a 1 276 Oct 9, 2014 20:04
Last Post: rich2005
  plug_in_dog won't work covjek123 2 379 Jun 28, 2014 21:47
Last Post: covjek123
  Batchscript won't work. covjek123 8 579 Jun 24, 2014 23:43
Last Post: ofnuts
Exclamation GMIC doesnpt work as previews EscapedNight 2 694 Mar 22, 2013 13:28
Last Post: EscapedNight

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS