Post Reply 

eraser won't erase

Jan 28, 2014, 18:26
Post: #1
eraser won't erase
I loaded one PNG pic.
I added an alpha channel to make it a transparency.
I used the select by color tool.
I clicked white & removed.
I saved.
I switched to eraser - but it is acting like I'm trying to erase something off the transparency layer and won't erase anything.
I have the correct layer selected in the layers window.
?????????????
Find all posts by this user
Quote this message in a reply
Jan 28, 2014, 18:34
Post: #2
RE: eraser won't erase
I exported it & closed Gimp; and the eraser still didn't work.

Remember when I mentioned I always have to hit rectangle - it is because that was the only way I could deselect the present selection. Is there a way to deselect the selection once you are through with that operation???
Find all posts by this user
Quote this message in a reply
Jan 28, 2014, 18:37
Post: #3
RE: eraser won't erase
(Jan 28, 2014 18:26)Terry50 Wrote:  I loaded one PNG pic.
I added an alpha channel to make it a transparency.
I used the select by color tool.
I clicked white & removed.
I saved.
I switched to eraser - but it is acting like I'm trying to erase something off the transparency layer and won't erase anything.
I have the correct layer selected in the layers window.
?????????????

Do you still have a selection active?

Always worth select menu -> select none, in case there is a tiny selection somewhere.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Jan 28, 2014, 19:52
Post: #4
RE: eraser won't erase
That's just the thing I was wanting. Thank you, Rich.
Find all posts by this user
Quote this message in a reply
Jan 29, 2014, 07:06
Post: #5
RE: eraser won't erase
Hi Ofnuts, Smile
I downloaded a fresh Gimp.
I loaded a picture and the erase tool shows up by selecting it; but it doesn't erase anything.
Zilch. Zero.
All the other tools work fine.
Any ideas?
Terry
Find all posts by this user
Quote this message in a reply
Jan 29, 2014, 20:00
Post: #6
RE: eraser won't erase
Blush Opacity was set at zero. That was the problem.
But I think I checked on it before; but the options may have been for a different tool.
Why is life so difficult???? Good thing I got Ofnuts. Smile
Good work !
Find all posts by this user
Quote this message in a reply
Jan 29, 2014, 20:27
Post: #7
RE: eraser won't erase
Oh, wow, I opened another and the opacity was 100% and the eraser wouldn't erase.
So I quit Gimp and opened the pic again and it worked……
Oh, well, things will clear up eventually.
Find all posts by this user
Quote this message in a reply
Jan 30, 2014, 03:35 (This post was last modified: Jan 30, 2014 03:37 by iForStyle007.)
Post: #8
RE: eraser won't erase
(Jan 29, 2014 20:27)Terry50 Wrote:  Oh, wow, I opened another and the opacity was 100% and the eraser wouldn't erase.
So I quit Gimp and opened the pic again and it worked……
Oh, well, things will clear up eventually.

(Feb 19, 2012 17:42)ofnuts Wrote:  [*]Check the brush you are using. If set to the 'clipboard', the clipboard contents may have changed. Try with another brush.

Just in case that got overlooked in the link above.
Pick a different brush if its set on "clipboard" then
Edit > Preferences > Tool Options
- Click "Save Tool Options Now..."
-click ok

If that didn't work, try the below

Near the bottom of the toolbox options
- Click the floppy disk icon on the bottom left of the Eraser Tool Option "Save tool preset..."

This opens a pulldown menu, click "New Tool Preset..."
-Make Sure "[]Apply Stored brush" is checked, then click the bottom floppy disk.
Sorry, this doesn't seem to work

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Aug 8, 2018, 23:22
Post: #9
RE: eraser won't erase
Just discovered - pressing Eraser tool after using the selection-box tool - you must deselect completely. (ie, Shift+Ctrl+A ) Seems that the little box with the running-ants remains active and doesn't allow the Eraser tool to be active. In Photoshop it is Ctrl+D for complete deselection. BTW, too many folks talking about alpha channels and such online to fix the problem really gets frustrating.
Thanks - P
Find all posts by this user
Quote this message in a reply
Aug 9, 2018, 05:53
Post: #10
RE: eraser won't erase
This forum has been DEAD for a long time and the spammers keep trying to take over.

Save yourself from them and go to https://www.gimp-forum.net instead
Find all posts by this user
Quote this message in a reply
Aug 9, 2018, 18:39
Post: #11
RE: eraser won't erase
Yes, this page is old, but a simple & specific google search with someone with the same problem I had (without having to sign-in to an account) will find it - It is the process that I prefer for quick fixes for problems that I know are inherently a quirky thing with the program and I like to avoid the "super users" who overthinks a solution and the guys who suggest trying "this & that" but never encountered the problem themselves.

hopefully, this will help new users; who just want an alternative to photoshop and reduce some frustration that comes along with learning new software program. - P
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Paintbrushing Eraser! halligant 1 218 Aug 20, 2018 20:08
Last Post: paynekj
  Eraser function on Gimp 2.10 halligant 1 191 Jun 23, 2018 15:39
Last Post: paynekj
  eraser not working njoe 5 1,174 May 12, 2018 06:53
Last Post: paynekj
  2 problems with Intuos tablet and GIMP (Slow input/lag and Tablet Eraser not working) Xarizzar 3 2,070 Sep 21, 2014 16:10
Last Post: Xarizzar
  Different curve for eraser Terry50 3 534 Jul 27, 2014 07:48
Last Post: rich2005

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS