Post Reply 

Disable Reading Default Fonts?

Feb 23, 2014, 02:01 (This post was last modified: Feb 23, 2014 02:03 by DarkFlameSquirrel.)
Post: #1
Disable Reading Default Fonts?
Is there a way to configure gimp to read ONLY the fonts I moved to the User>Gimp 2.8>Fonts directory and ignore the fonts installed on my machine? It would make using this program much easier for me, especially with all the recent font hunting I did. Help much appreciated. Thanks in advance.

Bonus question, what font is used here anyway? Smile

Edit: If this is in the wrong place to post this then I apologize, I'm sort of new to forums in general :/

Sometimes I like to pretend the rapper T.I. got his stage name from the calculator. Like what if he was actually a hella nerd back then, you know?
Find all posts by this user
Quote this message in a reply
Feb 23, 2014, 11:34
Post: #2
RE: Disable Reading Default Fonts?
(Feb 23, 2014 02:01)DarkFlameSquirrel Wrote:  Is there a way to configure gimp to read ONLY the fonts I moved to the User>Gimp 2.8>Fonts directory and ignore the fonts installed on my machine?

"As a quick workaround you can start gimp with the --no-fonts command-line option but of course you will not be able to use the text tool then."

http://www.gimp.org/unix/fonts.html

But you don't have to take my word for it *cue RR hi-hat music* XD

There also is the font manager route (disabling fonts) but be careful to not disable important system-wide fonts (you can google for your OS those fonts)

More on the font manager solution here: http://www.gimpusers.com/forums/gimp-use...imp-starts

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Feb 23, 2014, 14:58 (This post was last modified: Apr 7, 2014 16:50 by rich2005.)
Post: #3
RE: Disable Reading Default Fonts?
(Feb 23, 2014 02:01)DarkFlameSquirrel Wrote:  Is there a way to configure gimp to read ONLY the fonts I moved to the User>Gimp 2.8>Fonts directory and ignore the fonts installed on my machine?

AFAIK not possible.

You do not say which OS, but 'User" must be Windows.

The obvious solution is a font manager. Over the years I have tried a few, some better than others. All suffer from the same:
1. complicated
2. sooner rather than later, you press the wrong button and wreck your installation.
3. not that many up-to-date free font managers around. I have just tried nexusfont. Go-back-to-1

Looking at a basic Win7 installation it comes with about 130 fonts installed. You can get that down to 40 by removing the non-latin fonts.

for a how-to see:
http://www.support-ing.net/how-to-remove...tin-fonts/

edit: looks like everyone finished with this
To check that it works http://www.youtube.com/watch?v=MvjPcjX5R_Y&hd=1

That is as small as you will get without affecting other Windows applications.
If you want to use lots of fonts with Gimp, look at using a resources manager plug-in, such as GURM or Ofnuts addonCollectionManager plugin.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Feb 23, 2014, 23:41
Post: #4
RE: Disable Reading Default Fonts?
Wow this turned out to be a bit more complicated than I anticipated haha.
I would do the command line option but I use the text tool nearly all the time :I
And I don't think I'm responsible enough to use a font manager. I might be good with computers and all, but it still sounds pretty risky.
Yes, I use windows, my bad for not stating that earlier. I sometimes forget gimp is awesome enough to be cross-platform.
Thanks for the help guys. I'll go remove the non-latin fonts and test out the resource manager route and see how it works out.

Sometimes I like to pretend the rapper T.I. got his stage name from the calculator. Like what if he was actually a hella nerd back then, you know?
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Similarly named fonts not recognized poymando 0 103 Sep 16, 2017 17:58
Last Post: poymando
  GIMP Taking Too Long to Start (Fonts) Seta 2 398 Jun 20, 2017 16:10
Last Post: Seta
  change the default export setting of Untitled.png ezz9 2 257 Jun 9, 2017 16:31
Last Post: ezz9
  Custom fonts no longer working TheBorzoi 4 432 Oct 2, 2014 23:45
Last Post: TheBorzoi
  adding 10,000 fonts to Gimp user folder causes Gimp startup to slow my computer moltres_rider 7 953 Sep 28, 2014 21:40
Last Post: iForStyle007

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS