Post Reply 

Default Export image settings not saved in Gimp 2.8

May 25, 2012, 17:38
Post: #1
Default Export image settings not saved in Gimp 2.8
I recently upgraded my laptops to Fedora 17 and Linux Mint 13, which now come with Gimp 2.8. After discovering that Save and Save as are moved to Export to and Export, I tried saving the default export settings for JPG. I usually set the Quality to 80 and make some other adjustments. However, the defaults always revert back no matter how many times I press the Save Defaults button. Is anyone else having this problem or know of a solution?

Also, is there any way to make Gimp always use the previously selected settings? It seems that even though I set the defaults, with some images I open, edit and attempt to export, it tries to adjust the quality settings again. I just want to always have the defaults I have set for exporting jpg files without having to click an extra button or keyboard shortcut every time I save a file.

Themebot.com | CouponCodeSwap.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Jun 12, 2012, 09:52 (This post was last modified: Jun 12, 2012 12:22 by snu3.)
Post: #2
RE: Default Export image settings not saved in Gimp 2.8
(May 25, 2012 17:38)undoIT Wrote:  ... and make some other adjustments. However, the defaults always revert back no matter how many times I press the Save Defaults button. Is anyone else having this problem or know of a solution?

my 'save default' and 'load default' doesn't work at all (for 'export image as jpg'). i've seen other people report the same problem. the bug has been fixed (see https://bugzilla.gnome.org/show_bug.cgi?id=675981 ), but i'm not sure when the fix becomes available.

however, the 'quality settings' (eg Quality = 80) are a different issue. these quality settings are deliberately overwritten (replaced) if the current image has better quality than the current settings. search the various forums and Bugzilla for more details.

: )

[edited to show correct Bugzilla details]
Find all posts by this user
Quote this message in a reply
Jun 13, 2012, 05:03
Post: #3
RE: Default Export image settings not saved in Gimp 2.8
i was going to start a thread on this too, annoying stuff indeed.
mine used to be remembered @ 2.6 but 2.8 just ignores me.
Find all posts by this user
Quote this message in a reply
Jun 22, 2012, 10:52
Post: #4
RE: Default Export image settings not saved in Gimp 2.8
so this is normal behaviour now?! i have to put up with this every single export, far out that just ruined my day 8(
Find all posts by this user
Quote this message in a reply
Mar 14, 2014, 12:27
Post: #5
RE: Default Export image settings not saved in Gimp 2.8
Still cannot save jpg export defaults & I am using Gimp 2.8.10 but this problem still exists. I believe it worked in 2.8.8.
Find all posts by this user
Quote this message in a reply
Mar 14, 2014, 14:40 (This post was last modified: Mar 14, 2014 14:42 by iForStyle007.)
Post: #6
RE: Default Export image settings not saved in Gimp 2.8
(Mar 14, 2014 12:27)Blaine Wrote:  Still cannot save jpg export defaults & I am using Gimp 2.8.10 but this problem still exists. I believe it worked in 2.8.8.

What is your operating system?
The creator of this topic had issues under Fedora 17 & linux mint 13

Also, what steps have you tried to export to .jpeg?

1
"File > Export..."
Type the name for the file followed by typing .jpeg at the end
example.jpeg
then click the "export" button

2
"File > Export As..."
Type the name for the file followed by typing .jpeg at the end
example.jpeg
then click the "export" button


Both above methods should bring up the "Export image as JPEG" dialogue window.
Then click "export" once more to make the JPEG.
Visit this user's website Find all posts by this user
Quote this message in a reply
Mar 14, 2014, 16:08 (This post was last modified: Mar 14, 2014 16:09 by undoIT.)
Post: #7
RE: Default Export image settings not saved in Gimp 2.8
The problem with export defaults not being saved was fixed quite a while back with a GIMP update, not sure which one. I am currently using GIMP 2.8.10 on Fedora 20.
Visit this user's website Find all posts by this user
Quote this message in a reply
Mar 14, 2014, 20:20
Post: #8
RE: Default Export image settings not saved in Gimp 2.8
(Mar 14, 2014 14:40)iForStyle007 Wrote:  
(Mar 14, 2014 12:27)Blaine Wrote:  Still cannot save jpg export defaults & I am using Gimp 2.8.10 but this problem still exists. I believe it worked in 2.8.8.

What is your operating system?
The creator of this topic had issues under Fedora 17 & linux mint 13

Also, what steps have you tried to export to .jpeg?

1
"File > Export..."
Type the name for the file followed by typing .jpeg at the end
example.jpeg
then click the "export" button

2
"File > Export As..."
Type the name for the file followed by typing .jpeg at the end
example.jpeg
then click the "export" button


Both above methods should bring up the "Export image as JPEG" dialogue window.
Then click "export" once more to make the JPEG.

OS: Windows 7 64 bit. I have been using Gimp since 2.6 & edit my RAW images thru UFRAW with Gimp. I then Export as Jpeg with quality of 85 & try to save as defalut. The next time I try export the quality reverts back t0 80. If I press Load Default nothing changes.
Find all posts by this user
Quote this message in a reply
Mar 14, 2014, 20:43
Post: #9
RE: Default Export image settings not saved in Gimp 2.8
OK, something really strange here. Yesterday I started editing a group of ten RAW images & with the export of each on I had to manually set the quality...Load Defaults did not work for any photo. Now I just did another & this time the default quality that I last saved is there. I shut down Gimp & reloaded another RAW image & the saved default is there. Go figure.
Find all posts by this user
Quote this message in a reply
Mar 15, 2014, 07:11 (This post was last modified: Mar 15, 2014 07:14 by iForStyle007.)
Post: #10
RE: Default Export image settings not saved in Gimp 2.8
(Mar 14, 2014 20:43)Blaine Wrote:  OK, something really strange here. Yesterday I started editing a group of ten RAW images & with the export of each on I had to manually set the quality...Load Defaults did not work for any photo. Now I just did another & this time the default quality that I last saved is there. I shut down Gimp & reloaded another RAW image & the saved default is there. Go figure.

My mistake on the export default export save & export as confusion Blush

Maybe it will only save the default jpeg export settings after you export the image with those settings. Then next time you run the jpeg export, BAM, the defaults will work
Still, if it ever acts up again, check the new posts above.


When I apply filters, some of them have a drop-down list with previous settings on a specific date. Kinda like a cache.
Visit this user's website Find all posts by this user
Quote this message in a reply
Mar 15, 2014, 11:12
Post: #11
RE: Default Export image settings not saved in Gimp 2.8
That may be true. We will see.
Anyway, thanks all.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  How to install fonts for gimp only (not install on windows) Jacob123 1 51 Dec 7, 2018 08:58
Last Post: paynekj
  gimp tool icons leonardo 2 264 Nov 23, 2018 22:20
Last Post: paynekj
  paste Powerpoint objects to GIMP HPE007 1 222 Nov 21, 2018 21:59
Last Post: paynekj
  Gimp 2.10.8 error coyote 2 436 Nov 12, 2018 13:49
Last Post: coyote
  \Data\.gimp\backups\.goutputstream-XXXXXX Files DoughyInTheMiddle 1 392 Nov 10, 2018 10:01
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS