Post Reply 

Debian install (xfce)

May 30, 2012, 21:27
Post: #1
Debian install (xfce)
Hi. Thanks for reading. Any help is appreciated.

I'm having trouble installing 2.8 on crunchbang (Debian Xfce). Since, as opposed to popular belief, Ubuntu is not Debian these instructions are useless: http://www.gimp.org/downloads/

Does anyone know how to install on Debian. I tried adding ppa in Synaptic but "Add Source" button was still grayed out after pasting "ppa:otto-kesselgulasch/gimp"

Also tried "sudo apt-get update" then running "sudo apt-get install gimp" and got return message: "gimp is already the newest version."

Does anyone know how to actually upgrade to 2.8?

Thanks
Find all posts by this user
Quote this message in a reply
May 31, 2012, 08:17 (This post was last modified: May 31, 2012 08:53 by rich2005.)
Post: #2
RE: Debian install (xfce)
I managed it in LinuxMint Debian Ed. by enabling debian testing and the Ubuntu ppa.

From synaptic sources.

binary
http://ftp.debian.org/debian
testing
main contrib non-free

binary
http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu
oneiric
main

The Synaptic history shows this

Removed the following packages:
libgegl-0.0-0

Upgraded the following packages:
gimp (2.6.12-1+b1) to 2.8.0-1ubuntu0ppa3~oneiric
gimp-data (2.6.12-1) to 2.8.0-1ubuntu0ppa3~oneiric
libgdk-pixbuf2.0-0 (2.24.1-1) to 2.26.1-1
libgdk-pixbuf2.0-common (2.24.1-1) to 2.26.1-1
libgimp2.0 (2.6.12-1+b1) to 2.8.0-1ubuntu0ppa3~oneiric
libglib2.0-0 (2.30.2-6) to 2.32.0-4
libglib2.0-bin (2.30.2-6) to 2.32.0-4
libpango1.0-0 (1.29.4-3) to 1.30.0-1oneiric1~ppa

Installed the following packages:
libbabl-0.1-0 (0.1.10-4oneiric0~ppa)
libgegl-0.2-0 (0.2.0-5oneiric0~ppa)

That was about 3 weeks ago. I normally have those sources disabled but I did re-enable, and update successfully 10 days ago.
Just re-enabled again and I see another update, gimp-2.8.0 to gimp-2.8.0-2. Normal rules apply, I will make a partition image before the update 'just-in-case'.

Since I also use KDE, rather than the Mint DE's I can't say how XFCE will affect the outcome. Once had a E17 Enlightenment installation and gimp was horrible on that.

best of luck

edit: run into dependency hell.
that new update Depends: libfontconfig1 (>=2.9.0)
If I force that from debian testing it will uninstall my other graphic applications + half the system.

stuck for the moment.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [Solved] Install failure on Win 7 Pro, Suggestions? AshtonC 2 267 Sep 27, 2014 18:06
Last Post: AshtonC
  How do I install this?!?!? Letoatreides3508 5 928 Aug 28, 2014 12:07
Last Post: paynekj
  after new install, can't move layers up or down... vpan 6 542 Jun 14, 2014 18:09
Last Post: Lava
  Install 2.8.2 caz 5 640 May 27, 2013 19:24
Last Post: caz
  How to install help for Mac tbenner 2 500 Feb 22, 2013 10:33
Last Post: rich2005

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS