Post Reply 

Colour Picker Issue in Gimp 2.8

Jul 20, 2012, 12:26
Post: #1
Question Colour Picker Issue in Gimp 2.8
I have recently upgarded from the 2.6 version to the 2.8, and I have serious issues with the colour picker. Every time I use the dropper to select the colour I want to use from a picture, it ALWAYS comes out as black, never as the colour I want to use (for touching up, etc) can someone PLEASE tell me where I'm going wrong?
Find all posts by this user
Quote this message in a reply
Jul 20, 2012, 15:11
Post: #2
RE: Colour Picker Issue in Gimp 2.8
I'm picking in side of the Gimp window. I open a picture, and just want to be able to touch up a few areas with a brush, so click on the foreground/background button, click on the dropper, click on the colour I want to use on the picture, and then when I use the brush, it's ALWAYS black...
Find all posts by this user
Quote this message in a reply
Jul 20, 2012, 18:03
Post: #3
RE: Colour Picker Issue in Gimp 2.8
yes, I did
Find all posts by this user
Quote this message in a reply
Jul 21, 2012, 08:26
Post: #4
RE: Colour Picker Issue in Gimp 2.8
it happens on all pictures, regardless of whether it foreground or background, it doesn't change in the display
Find all posts by this user
Quote this message in a reply
Jul 21, 2012, 10:42
Post: #5
RE: Colour Picker Issue in Gimp 2.8
(Jul 21, 2012 08:26)universalady Wrote:  it happens on all pictures, regardless of whether it foreground or background, it doesn't change in the display

How many layers does your image have?

The only way I can duplicate this is by the color-picker on an active transparent layer, in a transparent area.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Jul 21, 2012, 11:01
Post: #6
RE: Colour Picker Issue in Gimp 2.8
I have one layer, i.e I have 'opened' an image, and just want to retouch it
Find all posts by this user
Quote this message in a reply
Jul 21, 2012, 11:01
Post: #7
RE: Colour Picker Issue in Gimp 2.8
I have one layer, i.e I have 'opened' an image, and just want to retouch it
Find all posts by this user
Quote this message in a reply
Jan 11, 2013, 17:33 (This post was last modified: Jan 11, 2013 17:34 by pho123to.)
Post: #8
RE: Colour Picker Issue in Gimp 2.8
I have been having the exact same problem ever since 2.8.0 (just upgraded to 2.8.2 and it still doesn't work). I'm using Windows XP x64, so the 64-bit build of GIMP is used.

The color picker tool works absolutely fine. On the other hand, clicking on the foreground color and using the color picker option from that dialog box always changes the color to black. (Options are only relevant for the picker tool, not the picker from the color dialog box.)
Find all posts by this user
Quote this message in a reply
Jan 11, 2013, 18:04
Post: #9
RE: Colour Picker Issue in Gimp 2.8
If you click on the color with the color picker it automaically changes the foreground color to that color. You don't have to click on foreground color. Just pick choose brush and it should work. I think when you click on foreground or background it sets it to black. Being a novice my self this is just my humble opinion but that's how it works for me.

you only learn if you try
Denster
Find all posts by this user
Quote this message in a reply
Jan 12, 2013, 04:41 (This post was last modified: Jan 12, 2013 04:42 by pho123to.)
Post: #10
RE: Colour Picker Issue in Gimp 2.8
I didn't see this was in the beginners' forum rather than the bug report forum: I'm not actually a beginner and I do know that it worked fine in previous versions. The issue here is a bug that happens when trying to pick a color from the image with the "dropper" button next to the HTML value of the color. The color is always set to black rather than the actual color from the image.
Find all posts by this user
Quote this message in a reply
Jan 28, 2013, 22:15
Post: #11
RE: Colour Picker Issue in Gimp 2.8
Hi guys,
i am having the exact same problem.
I inserted a 3 view aircraft drawing that i wish to turn into a blueprint.
1. i separated the original drawing into 3 separate layers
2. I added 3 new layers and merged them into the copied layers to clean up the images
3. chain linked 3 completed layers and cropped to 700x700 pixels
4. added a new layer for blueprint (opacity 30%)
5 attempt to change foreground/background colour to blue nothing happens. So i then chose the paint bucket tool and clicked on page...it goes any shade of grey to black but not blue (tried other colours but no colour will work)!!!

I cannot figure out what is going on???

Im going to start a new thread for this one hope you dont mind.
Find all posts by this user
Quote this message in a reply
Jan 28, 2013, 22:15
Post: #12
RE: Colour Picker Issue in Gimp 2.8
Hi guys,
i am having the exact same problem.
I inserted a 3 view aircraft drawing that i wish to turn into a blueprint.
1. i separated the original drawing into 3 separate layers
2. I added 3 new layers and merged them into the copied layers to clean up the images
3. chain linked 3 completed layers and cropped to 700x700 pixels
4. added a new layer for blueprint (opacity 30%)
5 attempt to change foreground/background colour to blue nothing happens. So i then chose the paint bucket tool and clicked on page...it goes any shade of grey to black but not blue (tried other colours but no colour will work)!!!

I cannot figure out what is going on???

Im going to start a new thread for this one hope you dont mind.
Find all posts by this user
Quote this message in a reply
Dec 21, 2013, 12:10
Post: #13
RE: Colour Picker Issue in Gimp 2.8
I'm new to Gimp and just experienced the same behavior.

I noticed that it was because I used the mouse and the pen together.
I used the mouse to pick the color and the color got updated.
But when I wanted to use the Paintbrush with the pen, the color suddenly became black again, again and again.
Until I noticed that the mouse and the pen have their own settings, apparently.
So when I pick the color with the pen, and then draw with the pen, the color stays the right one.

Hope this helps.
Find all posts by this user
Quote this message in a reply
Dec 22, 2013, 09:45 (This post was last modified: Dec 22, 2013 09:46 by iForStyle007.)
Post: #14
Exclamation RE: Colour Picker Issue in Gimp 2.8
(Jan 12, 2013 17:38)ofnuts Wrote:  In a Gimp canvas the picker picks the color from the active layer. If you pick the color where the layer is transparent, it can be picked as black (transparent layers are initialized to all zeros, in other words, to "transparent black").

I've confirmed this. Using the color picker (keyboard shortcut "O") on a transparent layer picks the color black.

*However, if you click the colorbox in the tools window. "Change Forground color"
and click the eyedropper there, then click on the transparent layer, it will pick up the color under it if any.

adamjedga Wrote:...
4. added a new layer for blueprint (opacity 30%)
5 attempt to change foreground/background colour to blue nothing happens. So i then chose the paint bucket tool and clicked on page...it goes any shade of grey to black but not blue (tried other colours but no colour will work)!!!
I cannot figure out what is going on???
...Im going to start a new thread for this one hope you dont mind.
Since you claim its the exact same problem, making another thread might be a bit repetitive.

adamjedga, can you post a screenshot with your canvas/image and "Layers" window/panel visible, so we can see if its a layer issue as mentioned earlier. ?

*Also check out this thread as mentioned earlier for a possible solution or workaround.
http://gimpforums.com/thread-gimp-2-8-ey...pp-is-slow

"In order to succeed, your desire for success should be greater than fear of failure." BC
[Image: 29uocaf.png]
iFS007 tut vids on YT ~ auto color B&W landscape tut
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Blurry GIMP interface on macOS High Sierra 10.13.6 vagkavo 1 110 Aug 26, 2018 07:52
Last Post: paynekj
  Gimp wont keep merging when exporting Ergu 1 167 Aug 8, 2018 21:22
Last Post: paynekj
  Printers not showing in gimp chrismacor 1 195 May 24, 2018 06:03
Last Post: paynekj
  Gimp 2.8 wont't see my wcoom bamboo tablet NullPointer 1 277 May 22, 2018 12:53
Last Post: paynekj
  Gimp compatibility katie98 1 196 May 22, 2018 05:53
Last Post: paynekj

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS