Post Reply 

Animated gif problem.

Apr 11, 2012, 18:20
Post: #1
Animated gif problem.
I'm a newbie to gimp, only be using it since the weekend, and have hit a problem with an avatar I'm making. I added an animated flag to a jpg picture of a boat that I already use as an avatar. Saved the new picture as an animated gif and all seemed well, the flag fluttered in the breeze when I viewed the animation in gimp and internet explorer. Loaded the avatar onto a forum and it no longer worked. So I guess I did something wrong when I made the gif image, or the breeze had dropped by the time I loaded it up at the forum. Cheers for any help with this.

[Image: DjIVv.png?1]

My DeviantArt gallery
http://caz747.deviantart.com/
Find all posts by this user
Quote this message in a reply
Apr 11, 2012, 20:12
Post: #2
RE: Animated gif problem.
Without having the GIF at hand it's hard to tell. Maybe you have some option in your navigator (or in the site HTML) to disable GIF animation on some sites.

I would first "Save as" the GIF from the forum, and check this is the very same GIF I uploaded (same size, and if so same binary contents). If not, the forum admins don't like animated avatars (with good reason Smile

Otherwise, if it's the same file, then load it in your navigator (File/Open..) and see if it is animated. If so, it's not the file.

Now answering your questions on
https://Gimp-Forum.net
Visit this user's website Find all posts by this user
Quote this message in a reply
Apr 12, 2012, 18:23
Post: #3
RE: Animated gif problem.
Thanks for your thoughts ofnuts. I just checked the file in FireFox and it works okay there. It is possible I loaded the wrong file up at the forum - I made a few screw up versions before I got it right - so I will have a look later and check it's the right one.

I know other people at the forum have animated avatars and admin's said that it should work, so I'll also try the rest of your suggestions and see if they sort the problem.

Cheers for your help. If I get the thing working I'll drop a line in here.

[Image: DjIVv.png?1]

My DeviantArt gallery
http://caz747.deviantart.com/
Find all posts by this user
Quote this message in a reply
Apr 14, 2012, 17:36
Post: #4
RE: Animated gif problem.
Several days later.

Problem solved. It seems that when I uploaded the file it was reduced in size from 100 by 85 pixels to 70 by 59 and changed into a png file which I'm told don't support animation. So I reduced the original file in size, saved it as an animated gif and hey presto it works. Cool.

[Image: DjIVv.png?1]

My DeviantArt gallery
http://caz747.deviantart.com/
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Combining gif image to static image help? littlegreendog 1 197 Jul 26, 2017 12:27
Last Post: ythgilb
  problem with drop shadow Kharl 37 1,611 Oct 8, 2014 04:53
Last Post: Kharl
  Resizing animated gifs drthrd 1 228 Oct 3, 2014 05:33
Last Post: iForStyle007
  Making a gif that shows middle portion of a word Deaf Smith 4 301 Sep 28, 2014 22:02
Last Post: iForStyle007
  Static text box adjacent to an animated GIF Ralph3 2 365 Sep 5, 2014 02:42
Last Post: Ralph3

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS