Post Reply 

Adding shadow text not working

Sep 24, 2014, 15:40
Post: #1
Adding shadow text not working
Hi guys,

I am trying to do something very simple. I have a jpg image that I want to use as a background for a button in my web app. I can add a layer of text to the image (First image below).
   
When I try to add a drop shadow to the text, I am not getting the desired results. The only thing that happens is that the background of the jpg image becomes transparent (Second image below).
   
What am I doing wrong to apply the drop shadow to the text?

I am also wondering why there is so much space above and below the text? Is that something I can control?

Thank you for your time,
Andrew
Find all posts by this user
Quote this message in a reply
Sep 24, 2014, 16:31
Post: #2
RE: Adding shadow text not working
@AndrewChristian

Mostly it is a matter of scale for your image

If I recreate your image looks like this as layers http://i.imgur.com/Hnl1lS5.jpg

Apply the standard drop shadow with appropriate settings http://i.imgur.com/ZwOrIaA.jpg

You get this http://i.imgur.com/imT0L3X.jpg

For these small images (actually any images) a better way is manually

Duplicate the layer, change the colour to black. http://i.imgur.com/141vf1A.jpg

Apply a small (depends on image) gaussian blur http://i.imgur.com/qPOEfkl.jpg

Then move that layer to create a shadow http://i.imgur.com/UULzH2x.jpg

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Sep 24, 2014, 17:29
Post: #3
RE: Adding shadow text not working
Hey, I know you! Smile

Yes, I am trying to create the shadow by using Filters>Light and shadow>Drop shadow. I have attached a sequence of screen shots and the original file. I think it has to do with my configuration because I can get the same results by creating a new image and then adding text and a shadow. I even uninstalled Gimp and reinstalled it to see if I could reset all of my settings - that didn't work. I have added a drop shadow before with Gimp, but I don't know what I did differently.

Thanks so much for your help,
Andrew

Before I start:
   

After I add text:
   

Drop shadow settings:
   

Result:
   

Original file:

.xcf  MainMenuConvert.xcf (Size: 1.17 KB / Downloads: 16)



(Sep 24, 2014 16:31)ofnuts Wrote:  1) how do you add the drop shadow? Filters>Light and shadow>Drop shadow or some other way? if using the standard filter, do you have a "Drop shadow" layer added? Can you show us the Layer list contents before/after (screenshot)? or maybe attach the XCF (in "before" state) here?

2) space above/below depends on the font extents. You can use Layer>Autocrop layer to remove it but your layer ceases to be a text layer and becomes a plain image layer.
Find all posts by this user
Quote this message in a reply
Sep 24, 2014, 17:40
Post: #4
RE: Adding shadow text not working
Thank you rich2005, but I can't see any of your links. I will look into your idea of duplicating the text. That should work. But I would still like to understand what I am doing wrong.

(Sep 24, 2014 16:31)rich2005 Wrote:  @AndrewChristian

Mostly it is a matter of scale for your image

If I recreate your image looks like this as layers http://i.imgur.com/Hnl1lS5.jpg

Apply the standard drop shadow with appropriate settings http://i.imgur.com/ZwOrIaA.jpg

You get this http://i.imgur.com/imT0L3X.jpg

For these small images (actually any images) a better way is manually

Duplicate the layer, change the colour to black. http://i.imgur.com/141vf1A.jpg

Apply a small (depends on image) gaussian blur http://i.imgur.com/qPOEfkl.jpg

Then move that layer to create a shadow http://i.imgur.com/UULzH2x.jpg
Find all posts by this user
Quote this message in a reply
Sep 24, 2014, 17:46
Post: #5
RE: Adding shadow text not working
(Sep 24, 2014 17:40)AndrewChristian Wrote:  Thank you rich2005, but I can't see any of your links.

Links not showing when you click on them? Must be your browser settings.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Sep 24, 2014, 21:38
Post: #6
RE: Adding shadow text not working
(Sep 24, 2014 15:40)AndrewChristian Wrote:  Hi guys,

I am trying to do something very simple. I have a jpg image that I want to use as a background for a button in my web app. I can add a layer of text to the image (First image below).

When I try to add a drop shadow to the text, I am not getting the desired results. The only thing that happens is that the background of the jpg image becomes transparent (Second image below).

What am I doing wrong to apply the drop shadow to the text?

I am also wondering why there is so much space above and below the text? Is that something I can control?

Thank you for your time,
Andrew
Hi Andrew.

What is happening when you apply your drop shadow this time with such a small image size is that you have left the default setting in the drop shadow to Blur at 15px size. This makes your shadow so faint that you can hardly see it.
Reduce your blur setting to say 2 and you will see the shadow.

Hope that helps you somewhat.
Find all posts by this user
Quote this message in a reply
Sep 24, 2014, 22:06
Post: #7
RE: Adding shadow text not working
Ah! That's it! And it makes perfect sense. Thank you very much. Smile

(Sep 24, 2014 21:38)fluffybunny2 Wrote:  
(Sep 24, 2014 15:40)AndrewChristian Wrote:  Hi guys,

I am trying to do something very simple. I have a jpg image that I want to use as a background for a button in my web app. I can add a layer of text to the image (First image below).

When I try to add a drop shadow to the text, I am not getting the desired results. The only thing that happens is that the background of the jpg image becomes transparent (Second image below).

What am I doing wrong to apply the drop shadow to the text?

I am also wondering why there is so much space above and below the text? Is that something I can control?

Thank you for your time,
Andrew
Hi Andrew.

What is happening when you apply your drop shadow this time with such a small image size is that you have left the default setting in the drop shadow to Blur at 15px size. This makes your shadow so faint that you can hardly see it.
Reduce your blur setting to say 2 and you will see the shadow.

Hope that helps you somewhat.
Find all posts by this user
Quote this message in a reply
Sep 24, 2014, 22:07
Post: #8
RE: Adding shadow text not working
This makes sense too. It explains what I was seeing. Thank you for pointing me here. Smile

(Sep 24, 2014 21:56)ofnuts Wrote:  
(Sep 24, 2014 21:38)fluffybunny2 Wrote:  
(Sep 24, 2014 15:40)AndrewChristian Wrote:  Hi guys,

I am trying to do something very simple. I have a jpg image that I want to use as a background for a button in my web app. I can add a layer of text to the image (First image below).

When I try to add a drop shadow to the text, I am not getting the desired results. The only thing that happens is that the background of the jpg image becomes transparent (Second image below).

What am I doing wrong to apply the drop shadow to the text?

I am also wondering why there is so much space above and below the text? Is that something I can control?

Thank you for your time,
Andrew
Hi Andrew.

What is happening when you apply your drop shadow this time with such a small image size is that you have left the default setting in the drop shadow to Blur at 15px size. This makes your shadow so faint that you can hardly see it.
Reduce your blur setting to say 2 and you will see the shadow.

Hope that helps you somewhat.
To add to FB: with a blur radius of 15px, the shadow is 15px wider than your text in all directions. To the "Drop shadow layer" that accommodates it is much bigger that your text, and the image canvas is enlarged to make it fit inside.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  How to wrap paragraph text in an image arun67 0 114 Aug 12, 2017 12:46
Last Post: arun67
  Change the space between lines of text ead 1 150 Jul 28, 2017 12:38
Last Post: ythgilb
  invert not working, no LqR remadepreacher 1 137 Jun 22, 2017 08:09
Last Post: ythgilb
  invert not working, no LqR remadepreacher 1 111 Jun 22, 2017 08:04
Last Post: ythgilb
  problem with drop shadow Kharl 37 1,460 Oct 8, 2014 04:53
Last Post: Kharl

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS