Post Reply 

Abysmal performance on 2.8.14/Windows

Oct 5, 2014, 09:04
Post: #1
Abysmal performance on 2.8.14/Windows
I've been a gimp user for quite some time now. However I've been having horrendous performance issues with 2.8.14 (and the 2.9) on Windows.

The Rectangle Selection lags massively. It skips 10-20+ pixels when dragging, making it unusable. Zooming in/out and panning isn't that smooth either. Even a basic fill operation takes half a second.

And that happens on even tiny images (say 100x100 pixels).

Tried increasing tile size to 1GB, didn't make a difference. Tried disabling color management thingy, again nothing.

All this on decent hardware (i5 2500k / 8GB RAM / GTX 760 / SSD) and a new windows 7/64bit installation. No other imaging program exhibits that behavior. Even tried PS and it's smooth as butter.

Anyone has a solution for this? Should I try dual boot ubuntu and the linux build?

Thank you for your time.
Find all posts by this user
Quote this message in a reply
Oct 5, 2014, 09:13 (This post was last modified: Oct 5, 2014 09:36 by Volrath.)
Post: #2
RE: Abysmal performance on 2.8.14/Windows
(Oct 5, 2014 09:07)ofnuts Wrote:  Which build? Partha's? The official one?

Both the official 2.8.14 and Partha's 2.9 64bit experimental (Git pull from september 20).

edit

Just as a showcase here's a video comparing gimp to PS. It's a bit difficult to discern it at 30fps through a video but just check how smooth the box selection in PS is compared to gimp.

https://www.youtube.com/watch?v=FJfUTBFf...e=youtu.be
Find all posts by this user
Quote this message in a reply
Oct 5, 2014, 09:45
Post: #3
RE: Abysmal performance on 2.8.14/Windows
(Oct 5, 2014 09:13)Volrath Wrote:  edit: Just as a showcase here's a video comparing gimp to PS. It's a bit difficult to discern it at 30fps through a video but just check how smooth the box selection in PS is compared to gimp.

I hope that is not just a bit of Gimp-bashing, if it is, wasting your time here.

Gimp 2.8.14 runs ok in my PClinuxOS KDE. In a Win7 VM, yes, a rectangular selection is a bit jerky & brushes a lag as well. But it is a VM with limited resources.

Is the problem across all image sizes or is it more with large images?

You could try ubuntu, I tried the latest in a VM, first time in a couple of years, not impressed, not my cup-of-tea, but there are other distros.
or
If Gimp 2.8.10 worked ok in Windows, why not roll back to that.
List of mirrors here http://gimpforums.com/thread-gimp-server...1#pid26881
where you can still download if required.

** https://www.gimp-forum.net/ now answering questions**
Find all posts by this user
Quote this message in a reply
Oct 5, 2014, 10:04
Post: #4
RE: Abysmal performance on 2.8.14/Windows
(Oct 5, 2014 09:45)rich2005 Wrote:  
(Oct 5, 2014 09:13)Volrath Wrote:  edit: Just as a showcase here's a video comparing gimp to PS. It's a bit difficult to discern it at 30fps through a video but just check how smooth the box selection in PS is compared to gimp.

I hope that is not just a bit of Gimp-bashing, if it is, wasting your time here.

Gimp 2.8.14 runs ok in my PClinuxOS KDE. In a Win7 VM, yes, a rectangular selection is a bit jerky & brushes a lag as well. But it is a VM with limited resources.

Is the problem across all image sizes or is it more with large images?

You could try ubuntu, I tried the latest in a VM, first time in a couple of years, not impressed, not my cup-of-tea, but there are other distros.
or
If Gimp 2.8.10 worked ok in Windows, why not roll back to that.
List of mirrors here http://gimpforums.com/thread-gimp-server...1#pid26881
where you can still download if required.

I don't compare PS with gimp for any other reason apart from showcasing my problem.

The problem persists across all image sizes (for instance in the video it's a 500x500 but the same thing happens even at smaller / larger sizes).

edit:

Checked 2.8.2 from your links. The problem seems to be gone. Let's hope that the official 2.9 release will solve it as well. Thanks.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  why gimp in mac has bad performance mcheung63 1 215 Aug 20, 2017 10:13
Last Post: ythgilb
  Missing icons v2.8.14 on Windows reyahtbor 3 416 Sep 1, 2014 07:35
Last Post: rich2005
  Gimp not working on windows 8.1 Justmenow 6 675 Aug 4, 2014 12:51
Last Post: Justmenow
  Problems with GIMP 2.8.10 on windows 8 64-bit Uncategorizable 3 490 Jul 20, 2014 06:55
Last Post: iForStyle007
  [BUG] Windows automatically closed xRoguex 2 328 Mar 19, 2014 19:16
Last Post: iForStyle007

Forum Jump:


GIMP ForumPortalArchiveContactTermsRSS