GIMP Forums

Full Version: Save for Web on Mac Maverick OS
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there. I'm using the basic Gimp and not the "Gimp for Mac".

How do I install the "Save for Web" feature in Gimp? I tried the instructions from the link below, but the option didn't show up in the file menu when I opened the program.

http://howto.sviluppo-siti-web.com/conte...n-mac-os-x

Thanks in advance for any help on this. I tried doing a quick search on the sight but didn't see anything recent.

Cheers!
StephenSmile
Thanks for the quick response. Where do I make sure the executable bit is turned on?

SSmile
I do not know what tools OSX has but usually you can use a file manager and select the file and look at the file properties.
edit: apparently this is the equivalent in oSX
http://osxdaily.com/2011/02/21/change-fi...sions-mac/

but

You did unpack the archive correctly?

tar -xf webexport-intel.tar.bz2

should give you a single file webexport, size 309,792 B and as far as I can tell it is already marked as executable.
Yeah, the file unpackaged fine. I went to get info to see the permissions. I did change them all to Read & Write. Was that correct?
Same issue here. Took the same actions recommended by this thread before I got here actually. Gimp no longer recognizes my Save for Web plug-in. Does the plug in need to be updated?
(Apr 22, 2014 16:40)segts Wrote: [ -> ]Hi there. I'm using the basic Gimp and not the "Gimp for Mac".

How do I install the "Save for Web" feature in Gimp? I tried the instructions from the link below, but the option didn't show up in the file menu when I opened the program.

Same issue here, expect I'm using Gimp for Mac 2.8.10. Took the same actions recommended by this thread before I got here actually. Gimp no longer recognizes my Save for Web plug-in after update. Was previously using SFW plugin for many years. Could the plug in itself need updating?
(May 22, 2014 22:18)d1lemma Wrote: [ -> ]Same issue here, expect I'm using Gimp for Mac 2.8.10. Took the same actions recommended by this thread before I got here actually. Gimp no longer recognizes my Save for Web plug-in after update. Was previously using SFW plugin for many years. Could the plug in itself need updating?


A lack of problem free Mac users here and I do not know much about OSX but have you tried the Partha version.

Having a look at the download for the 64 bit OSX version, & surprise, it is a straight zip rather than a dmg archive, so it unpacks rather easily.

The webexport plugin is there in "Gimp-2.8.app/Contents/Resources/lib/gimp/2.0/plug-ins/"

I will attach it just as an experiment. It is 64 bit and zipped so remember to unzip. The executable bit is already set at this end but check it anyway.
If you give it a go, maybe your local ~/.gimp-2.8/plug-ins might be a good place to put it.
(May 23, 2014 09:01)rich2005 Wrote: [ -> ]
(May 22, 2014 22:18)d1lemma Wrote: [ -> ]Same issue here, expect I'm using Gimp for Mac 2.8.10. Took the same actions recommended by this thread before I got here actually. Gimp no longer recognizes my Save for Web plug-in after update. Was previously using SFW plugin for many years. Could the plug in itself need updating?


A lack of problem free Mac users here and I do not know much about OSX but have you tried the Partha version.

Having a look at the download for the 64 bit OSX version, & surprise, it is a straight zip rather than a dmg archive, so it unpacks rather easily.

The webexport plugin is there in "Gimp-2.8.app/Contents/Resources/lib/gimp/2.0/plug-ins/"

I will attach it just as an experiment. It is 64 bit and zipped so remember to unzip. The executable bit is already set at this end but check it anyway.
If you give it a go, maybe your local ~/.gimp-2.8/plug-ins might be a good place to put it.

works now! thanks. I put webexport into ~/Library/Application Support/GIMP/plug-ins instead of /../gimp.app/Contents/plug-ins as had been for years previously. I can't believe I missed something that obvious. Thanks again.

EDIT: only works with the webexport.zip file provided by rich and still must be placed in ~/Library/Application Support/GIMP/plug-ins

EDIT EDIT: plug-ins will not work if system restored from Time Machine. If you restore system from Time Machine you must clean install gimp including all its plug-ins all over again. This is an issue with Apple's Time Machine mincing up permissions after restore. Actually this Time Machine is totally not worth it cause I end up having to re-install everything anyways cause it screws up the permissions every time without fail.
Ok, so I did a system restore from Time Machine and GIMP plug-ins are all totally FUBAR. None of them work. Sad

They worked for a couple hours then disappeared from from the menu. I know that Time Machine and permission issues are to blame. I cannot recommend Time Machine to any human being.

I hope this helps people save some time and aggravation.
Reference URL's